Symptomy
Podczas próby odświeżenia danych w skoroszycie programu Microsoft Excel, który jest połączony z bazą danych programu Microsoft Access, może zostać wyświetlony następujący komunikat o błędzie:
Nie można znaleźć instalatora ISAM
Ten problem występuje, jeśli skoroszyt został wcześniej otwarty i odświeżony w nowszej wersji programu Excel.
Przyczyna
Gdy skoroszyt programu Excel połączony z bazą danych programu Access zostanie otwarty w nowszej wersji programu Excel, parametry mogą zostać dodane do parametry połączenia. Jeśli wcześniejsza wersja programu Excel nie rozpoznaje tych parametrów, zostanie wyświetlony komunikat o błędzie.
Rozwiązanie
Aby rozwiązać ten problem, usuń nowe parametry z parametry połączenia. W tym celu wykonaj następujące czynności:
-
Otwórz skoroszyt programu Excel.
-
Na wstążce Dane kliknij przycisk Połączenia .
-
W oknie dialogowym Połączenia skoroszytu wybierz połączenie z bazą danych programu Access, a następnie kliknij pozycję Właściwości.
-
W oknie dialogowym Właściwości połączenia kliknij kartę Definicja .
-
Usuń z parametry połączenia następujące parametry:
Jet OLEDB:Bypass UserInfo Validation=False;Jet OLEDB:Limited DB Caching=False;Jet OLEDB:Bypass ChoiceField Validation=False
-
W oknie dialogowym Właściwości połączenia kliknij przycisk OK. W tym momencie dane powinny zostać odświeżone.
-
W oknie dialogowym Połączenia skoroszytu kliknij przycisk Zamknij, a następnie zapisz zaktualizowany skoroszyt.
Więcej informacji
Jeśli odświeżysz i zapiszesz skoroszyt w nowszej wersji programu Excel, problem zostanie rozwiązany ponownie.