Dotyczy
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Symptomy

Załóżmy, że korzystasz z programu SQL Server 2016 lub 2017. Podczas badania danych w strefie szyfrowania za pomocą usługi Hadoop wszystko działa prawidłowo. Jednak po około 10 godzinach kwerenda nie powiedzie się i wygeneruje następujący komunikat o błędzie w Dms_polybase. log. Chociaż tmoże zostać rozwiązany po ponownym uruchomieniu bazy. usługi kwerenda może zakończyć się niepowodzeniempo upływie 10 godzin.

org. Apache. Hadoop. Security. Authentication. Client. AuthenticationException: GSSException: nie podano prawidłowych poświadczeń (poziom mechanizmu: nie można znaleźć żadnego biletu Kerberos).

Przyczyna

Ten problem występuje, ponieważ baza Base nie automatyczne odnawianie biletu uprawniającego do przyznania biletu protokołu Kerberos (TGT). Bilet wygaśnie 10 godzin po jego utworzeniu.

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji "dotyczy".

Rozwiązanie

Ten problem został rozwiązany w następujących zbiorczych aktualizacjach programu SQL Server:

Informacje dotyczące aktualizacji zbiorczych dla programu SQL Server:

Każda nowa Zbiorcza aktualizacja programu SQL Server zawiera wszystkie poprawki i wszystkie poprawki zabezpieczeń uwzględnione w poprzedniej aktualizacji zbiorczej. Zapoznaj się z najnowszymi aktualizacjami zbiorczymi dla programu SQL Server:

Informacje

Informacje o terminologii używanej przez firmę Microsoft do opisywania aktualizacji oprogramowania.

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.