Szablonu: Poprawka ogólna

Nr błędu: 82981 (Obsługa zawartości)BUG #: 28823 (Vedbaek SE)

Microsoft Business Solutions-Navision 4.0 i Microsoft Navision 4.0 są teraz częścią systemu Microsoft Dynamics NAV 4.0. Wszystkie odwołania do programu Microsoft Business Solutions-Navision i Microsoft Navision 4.0 dotyczą systemu Microsoft Dynamics NAV.

Ten artykuł dotyczy systemu Microsoft Dynamics NAV dla wszystkich krajów i ustawień regionalnych języka.

Objawy

Po uruchomieniu kodu, który zawiera obiekt CFront.AssignField , aby przenieść pole Typ dużego obiektu binarnego (BLOB) do innego pola typu BLOB, pojawi się następujący komunikat o błędzie:

Błąd wykonania '10020': C/FRONT błąd krytyczny: błąd konwersji danych.

Ten problem występuje w następujących produktach:

  • Microsoft Dynamics NAV 5.0

  • Microsoft Dynamics NAV 4.0

Przyczyna

Ten problem występuje, ponieważ wewnętrznego obsługi złożonych typów danych nie może obsłużyć konwersji między dwoma polami typu BLOB.

Rozwiązanie

Obsługiwana poprawka jest obecnie udostępniana przez firmę Microsoft. Ta poprawka rozwiązuje problem opisany w tym artykule. Tylko w systemach, w których występuje ten problem, należy zastosować poprawkę.

Aby natychmiast rozwiązać ten problem, skontaktuj się z pomocy technicznej dla Microsoft Dynamics i produktów powiązanych w celu uzyskania poprawki. Możesz zalogować się w witrynie Microsoft Dynamics i utworzyć nowe żądanie pomocy technicznej. Aby to zrobić, odwiedź następującą witrynę firmy Microsoft w sieci Web:

https://mbs.microsoft.com/support/newstart.aspxUdzieli pomocy technicznej dotyczącej systemu Microsoft Dynamics i produktów powiązanych telefonicznie pod (888) 477-7877.

Uwaga W wyjątkowych przypadkach opłaty, telefonujący do pomocy technicznej mogą zostać anulowane, jeśli pomocy technicznej dla systemu Microsoft Dynamics i produktów powiązanych Określa, że określonej aktualizacji, można rozwiązać swój problem. Koszty obsługi zwykłych zastosuje się do wszelkich dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu określonej aktualizacji.

Jeśli ta poprawka nie została ogłoszona do publicznego pobierania (tzn. publiczny adres URL tej poprawki nie jest podany w treści artykułu), dystrybucja wymaga akceptacji kierownika technicznego, starszego członka zespołu lub menedżera i stosuje się następujące informacje:

  • Aby otrzymać poprawkę, klient musi napotkać błąd, który jest wymieniony w sekcji "Symptomy".

  • Należy śledzić klientom wysyła się poprawkę i przesłać im następny dodatek service pack, kiedy będzie dostępny (Jeśli zostanie wydany dodatek service pack).

Ta poprawka zostanie uwzględniona zostanie uwzględniona w dodatku Service Pack 1 dla systemu Microsoft Dynamics NAV 5.0.

Jak uzyskać poprawkę systemu Microsoft Dynamics NAV lub Aktualizuj moje pliki

Po zażądasz pomocy technicznej dotyczącej systemu Microsoft Dynamics o plik aktualizacji lub poprawek systemu Microsoft Dynamics NAV, hiperłącza będą wysyłane do Ciebie w wiadomości e-mail.


Wiadomość e-mail będzie zawierać hiperłącze i hasło. Hiperłącze można użyć do pobrania plików aktualizacji lub poprawek systemu Microsoft Dynamics NAV. Po kliknięciu hiperłącza zostanie otwarte okno dialogowe Pobieranie pliku — ostrzeżenie o zabezpieczeniach . Następnie monit, aby uruchomić, zapisać lub anulować pobieranie.


Jeśli klikniesz przycisk Uruchom, pliki rozpocznie się pobieranie i wyodrębnianie. Musisz określić folder dla nowych plików, a następnie podaj hasło.


Jeśli klikniesz przycisk Zapisz, należy określić ścieżkę do zapisania pliku skompresowanego. Po otwarciu zapisanego pliku są pojawi się monit, aby określić ścieżkę dla plików. Następnie należy podać hasło przesłane w wiadomości e-mail.


Jeśli klikniesz przycisk Anuluj, proces pobierania zostanie przerwany.

Jak zainstalować plik aktualizacji lub poprawek systemu Microsoft Dynamics NAV

Aktualizacje i poprawki dla systemu Microsoft Dynamics NAV są udostępniane jako pojedyncze pliki. Aby zastosować aktualizacji lub poprawek systemu Microsoft Dynamics NAV, należy zastąpić istniejące pliki instalacji systemu Microsoft Dynamics NAV z poprawki lub aktualizacji plików.

Informacje o plikach

Wersja globalna tej poprawki ma atrybuty plików (lub nowsze) wymienione w poniższej tabeli. Daty i godziny odpowiadające tym plikom zostały podane w formacie uniwersalnego czasu koordynowanego (UTC, Coordinated Universal Time). Po wyświetleniu informacji o pliku są konwertowane na czas lokalny. Aby zobaczyć różnicę między czasem UTC i czasem lokalnym, należy użyć z karty Strefa czasowa w aplecie Data i godzina w Panelu sterowania.

Nazwa pliku

Wersja pliku

Rozmiar pliku

Data

Godzina

Platforma

Cfront.dll

5.0.0.25533

1,242,232

11-Nov-2007

23:44

x86

Cfront.ocx

5.0.25533.0

148,600

11-Nov-2007

23:43

x86

Cfrontsql.dll

5.0.25533.0

1,369,208

11-Nov-2007

23:44

x86

Stan

Firma Microsoft potwierdziła, że jest to usterka występująca w produktach firmy Microsoft wymienionych w sekcji "Dotyczy".

Więcej informacji

Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

824684 Opis standardowej terminologii używanej do opisywania aktualizacji oprogramowania firmy Microsoft

Autor: lohndorf
Scenariusz: v-brialu
Weryfikacja tech.: lohndorf
Redaktor: v-smohun

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Jak zadowalająca jest jakość tłumaczenia?

Co wpłynęło na Twoje wrażenia?

Czy chcesz przekazać jakieś inne uwagi? (Opcjonalnie)

Dziękujemy za opinię!

×