Objawy
Po uruchomieniu FRx lub wygenerowanie raportu, pojawi się następujący komunikat o błędzie:
Błąd wykonania '3051': aparat bazy danych Microsoft Jet nie może otworzyć pliku "\\server\share\FRx\Sysdata\FRxQue32.mdb". Jest już otwarty przez innego użytkownika lub potrzebujesz uprawnień do wyświetlania danych
.
Przyczyna
Wymienionych w komunikacie o błędzie plik ma atrybut tylko do odczytu, zaznaczone lub użytkownik ma niewystarczające uprawnienia do katalogu zawierającego plik.
Rozwiązanie
-
W Eksploratorze Windows przejdź do katalogu, wymienionych w komunikacie o błędzie. Kliknij prawym przyciskiem myszy plik wymieniony w komunikacie o błędzie, a następnie kliknij polecenie Właściwości.
-
Sprawdź, czy pole wyboru Tylko do odczytu nie jest zaznaczone w obszarze atrybuty . Jeśli jest, należy je wyczyścić. Kliknij przycisk OK.
-
Przenieś w górę o jeden poziom do obiektu nadrzędnego katalogu bieżącego. Na przykład jeśli przeglądając znalazłeś \\server\share\FRx\Sysdata\, przesuń w górę o jeden poziom powinien być wyświetlany \\server\share\FRx\directory.
-
Kliknij prawym przyciskiem myszy na katalog zawierający plik z listy, a następnie kliknij polecenie Właściwości. W naszym przykładzie byłoby to katalog SysData.
-
Kliknij kartę Zabezpieczenia , sprawdź, czy wszyscy użytkownicy FRx mają uprawnienia Odczyt, Odczyt i wykonywanie, Zapisi Modyfikowanie katalogu. Jeśli wszyscy użytkownicy brakuje tych uprawnień, Dodaj uprawnienia, a następnie kliknij przycisk OK. Powtórz czynność, która spowodowała błąd - błąd nie powinien wystąpić.