Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Objawy

Microsoft SoftGrid Client próbuje uruchomić aplikację. Jednak próba się nie powiedzie, i zostanie wyświetlony komunikat o błędzie podobny do następującego:

Klient SoftGrid nie może uruchomić < nazwa_aplikacji >.
Nie można odnaleźć pakietu, żądana w bazie danych systemu lub na serwerze nie można odnaleźć plików skojarzonych z tym pakietem. Zgłoś następujący kod błędu do administratora systemu.
Kod błędu: xxxxxx xxxxxx0A-20000194

Wpis podobny do następującego może pojawić się w pliku dziennika klienta SoftGrid (Sftlog.txt):
Wpis podobny do następującego może pojawić się w pliku dziennika serwera wirtualnego aplikacji SoftGrid (Sft server.log):

Przyczyna

To zachowanie może wystąpić, jeśli jedna lub więcej z następujących warunków jest spełniony:

  • Próbujesz uruchomić korzystające z SoftGrid aplikacji, który nie został dodany do konsoli zarządzania SoftGrid.

  • Plik .sft, który jest określony w pliku .osd nie istnieje w strukturze katalogów zawartości.

  • Ścieżka lub nazwa pliku .sft określonej we wpisie Softricity względna ścieżka pliku jest nieprawidłowa.

  • Zasady dostawcy, który jest określony w pliku .osd nie istnieje.

Rozwiązanie

Następujące informacje podano rozwiązania dla każdej sprawy, który jest wymieniony w sekcji "Przyczyna".

  • Próbujesz uruchomić korzystające z SoftGrid aplikacji, który nie został dodany do konsoli zarządzania SoftGrid

    Istnieją dwa warunki, na jakich możesz spróbować pomyślnego uruchomienia aplikacji obsługujących SoftGrid, który nie został dodany do konsoli zarządzania SoftGrid:

    • Kliknij dwukrotnie plik .osd korzystające z SoftGrid aplikacji.

    • Kliknij dwukrotnie ikonę skrótu korzystające z SoftGrid aplikacji, która została usunięta z przystawki Zarządzanie klientem SoftGrid.

      Uwaga Skrót nie jest usuwany, gdy aplikacji obsługującej SoftGrid zostanie usunięta z przystawki Zarządzanie klientem SoftGrid. Skrót nie jest usuwany, jeśli użytkownik ręcznie skopiuj skrót do lokalizacji alternatywnej podczas dodawania aplikacji do zarządzania klientami SoftGrid. Gdy aplikacja jest nowszy usunięty, Zarządzanie klientem SoftGrid nie rozpoznaje lokalizacji alternatywnej, a skrót nie jest usuwany.

  • Plik .sft, który jest określony w pliku .osd nie istnieje w strukturze katalogów zawartości

    Plik .sft nie istnieje w strukturze katalogów zawartości. Ten plik .sft jest określona w atrybucie HREF elementu CODEBASE plik .osd.

    Rozważmy następujący scenariusz. Plik .osd jest skonfigurowany w następującym przykładzie:

    HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/Softricity/sft_ea70.v1.sft"Katalog zawartości jest skonfigurowane tak jak poniższy przykład ścieżki:

    C:\Program Files\Softricity\SoftGrid Server\contentW tym scenariuszu SoftGrid firmy Microsoft nie może uruchomić aplikację, jeśli plik sft_ea70.v1.sft nie istnieje w podkatalogu Softricity w następującej ścieżce katalogu zawartości:

    C:\Program Files\Softricity\SoftGrid Server\content\Softricity.

  • Ścieżka lub nazwa pliku .sft, która jest określona w "Softricity względną ścieżkę pliku" jest nieprawidłowe

    Względna ścieżka pliku Softricity musi zawierać tylko w podkatalogu katalogu zawartości i nazwa pliku .sft. Na przykład nazwa pliku .sft jest example.sft i istnieje w podkatalogu Przykładowe aplikacje w katalogu zawartości. Jeśli katalog zawartości jest C:\Program Files\Softricity\SoftGrid Server\content, Względna ścieżka pliku Softricity jest Applications\example.sft przykład. Jeśli katalog zawartości jest \\SERVERNAME\content, Względna ścieżka pliku Softricity jest nadal Applications\example.sft przykład.

    Aby sprawdzić, czy ścieżka względna zawiera tylko w podkatalogu katalogu zawartości i nazwa pliku .sft, wykonaj następujące kroki: kroki:

    1. W menu Narzędzia administracyjne Uruchom konsolę zarządzania SoftGrid.

    2. Rozwinięcie Systemów SoftGrid< nazwa_serwera > pakiety < wersja pakietu aplikacji, który nie uruchamia się > .

    3. Kliknij dwukrotnie wersja pakietu aplikacji, który nie uruchamia się.

    4. Sprawdź, czy Ścieżka względna pliku Softricity zawiera tylko w podkatalogu katalogu zawartości i nazwa pliku .sft.

  • Zasada dostawcy, który jest określony w pliku .osd nie istnieje

    Zasady dostawcy który ?Customer = określa nie istnieje. Ta zasada dostawcy jest określona w atrybucie HREF elementu CODEBASE plik .osd

    Rozważmy następujący scenariusz. Środowisko SoftGrid zawiera wiele zasad dostawcy, takich jak dostawcy domyślnych i niestandardowych zasad dostawcy, który nazywa się anonimowe. Dodatkowo należy skonfigurować plik .osd używać anonimowego zasady dostawcy. W tym scenariuszu. Atrybut HREF elementu CODEBASE plik .osd musi znajdować się w następującym przykładzie.

    HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/Softricity/sft_ea70.v1.sft?Customer=Anonymous"Uwaga Jeśli nazwa zasady dostawcy występujący na ?Customer = nie istnieje, Microsoft SoftGrid nie można uruchomić aplikacji.

Aby uzyskać więcej informacji na temat warunków użytkowania odwiedź następującą witrynę firmy Microsoft w sieci Web:

http://support.microsoft.com/tou/

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×