Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Objawy

Rozważ następujący scenariusz:

  • Masz serwer z systemem Windows Server 2012 R2, który ma programu Active Directory Federation Services (AD FS) 3.0 zainstalowany.

  • Masz komputerów klienckich z systemem Windows 7 lub systemem Windows 8.

  • Wartość właściwości NtlmOnlySupportedClientAtProxy jest ustawiona na wartość TRUE na serwerze.

  • Użytkownik próbuje edytować lub zapisać dokument programu Microsoft Office podczas korzystania z komputera klienckiego, który znajduje się poza siecią firmową.

W tym scenariuszu uwierzytelnianie usługi Microsoft Office 365 nie powiedzie się.

Przyczyna

Ten problem występuje, ponieważ kod serwera proxy usług AD FS szuka nagłówka "WWWAuthenticate" w nagłówki odpowiedzi Security Token Service (STS) zamiast w nagłówku żądania.

Składnik uwierzytelniania usługi Office 365 żądania "negocjować" Użyj serwera proxy usług AD FS jako mechanizmu uwierzytelniania między komputerami klienckimi z systemem Windows 7 lub systemem Windows 8. Nagłówek WWWAuthenticate zostanie dodany do nagłówka żądania. Jednak kod serwera proxy szuka nagłówka w STS nagłówki odpowiedzi zamiast w nagłówku żądania. W związku z tym nie można odnaleźć nagłówka, gdy serwer próbuje uwierzytelnić komputera klienckiego. Komputery klienckie z systemem 7 i systemem Windows 8 systemu Windows nie może wykonać uwierzytelnianie typu wezwanie/odpowiedź systemu Windows (NTLM).

Rozwiązanie

Informacje o poprawce

Obsługiwana poprawka jest udostępniana przez firmę Microsoft. Jednak ta poprawka jest przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Tylko w systemach, których dotyczy ten problem, należy zastosować tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, pojawi się sekcja "Poprawka dostępna do pobrania" na początku tego artykułu z bazy wiedzy Knowledge Base. Jeśli nie ma tej sekcji, należy przesłać żądanie do centrum obsługi klienta firmy Microsoft i obsługi technicznej w celu uzyskania poprawki.

Uwaga Jeśli wystąpią dodatkowe błędy lub konieczność rozwiązania problemu, być może trzeba będzie utworzyć osobne zlecenie usługi. Zwykłe koszty obsługi będą zastosowane do dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu określonej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta firmy Microsoft lub utworzyć osobne zlecenie usługi odwiedź następujące witryny firmy Microsoft:

http://support.microsoft.com/contactus/?ws=supportUwaga "Poprawka dostępna do pobrania" zawiera listę języków, dla których dostępna jest poprawka. Jeśli odpowiedni język nie jest widoczny, to dlatego, że poprawka nie jest dostępna dla danego języka.

Wymagania wstępne

Aby zastosować tę poprawkę, zostanie uruchomiony system Windows Server 2012 R2.

Informacje dotyczące rejestru

Aby użyć poprawki w tym pakiecie, nie trzeba wprowadzać żadnych zmian w rejestrze.

Wymagania dotyczące ponownego uruchomienia

Po zastosowaniu tej poprawki należy ponownie uruchomić komputer.

Informacje dotyczące zastępowania poprawek

Ta poprawka nie zastępuje wcześniej wydanej poprawki.

Wersja globalna tej poprawki instaluje pliki, których atrybuty wymieniono w poniższych tabelach. Daty i godziny odpowiadające tym plikom są podane w formacie uniwersalnego czasu koordynowanego (UTC, Coordinated Universal Time). Daty i godziny odpowiadające tym plikom na komputerze lokalnym są wyświetlane w formacie czasu lokalnego, wraz z Twoim bieżącym bias czasu letniego (DST). Dodatkowo, daty mogą ulec zmianie podczas wykonywania pewnych operacji na plikach.





Informacje o plikach w systemie Windows Server 2012 R2Ważne Poprawki systemu Windows 8.1 i systemu Windows Server 2012 R2 są zawarte w tych samych opakowaniach. Jednak tylko "Windows 8.1" znajduje się na stronie żądanie poprawki. Aby zażądać pakietu poprawek, który dotyczy jednej lub obu systemów operacyjnych, wybierz poprawkę, która jest wyświetlana w obszarze "Windows 8.1" na stronie. Zawsze sprawdzaj w sekcji „Stosuje się do”, do jakiego systemu operacyjnego dotyczy każda z poprawek.

  • Pliki dotyczące określonego produktu, etapu rozwoju (RTM, SPn) i składnika usługi (LDR, GDR) można zidentyfikować przez sprawdzenie wersji pliku, jak pokazano w poniższej tabeli:

    Wersja

    Produkt

    Kamień milowy

    Składnik usługi

    6.3.960 0,16 xxx

    Windows Server 2012 R2

    RTM

    GDR

  • Pliki MANIFESTU (manifest) i pliki MUM (mum) instalowane są dla każdego środowiska są wymienione osobno w sekcji "Informacje o dodatkowych plikach dla systemu Windows Server 2012 R2". Pliki MUM i pliki MANIFESTU oraz skojarzone pliki z wykazu zabezpieczeń (.cat), są bardzo ważne, aby utrzymać stan zaktualizowanych składników. Pliki katalogu zabezpieczeń, których atrybuty nie zostały wymienione, są podpisane za pomocą podpisu cyfrowego firmy Microsoft.

Dla wszystkich obsługiwanych wersji systemu Windows Server 2012 R2 x64

Nazwa pliku

Wersja pliku

Rozmiar pliku

Data

Godzina

Platforma

Microsoft.identityserver.proxyservice.exe

6.3.9600.16477

63,488

27-Nov-2013

15:33

x86

Microsoft.identityserver.proxyservice.exe.config

Nie dotyczy

1,067

18-Jun-2013

14:55

Nie dotyczy

Microsoft.identityserver.webhost.dll

6.3.9600.16392

172,032

31-Aug-2013

14:23

x86




Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Dotyczy”.

Więcej informacji

Aby uzyskać więcej informacji dotyczących terminologii aktualizacji oprogramowania, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

824684 Opis standardowej terminologii używanej do opisywania aktualizacji oprogramowania firmy Microsoft

Informacje o dodatkowych plikach dla systemu Windows Server 2012 R2

Dodatkowe pliki dla wszystkich obsługiwanych wersji systemu Windows Server 2012 R2 x64

Właściwości pliku

Wartość

Nazwa pliku

Amd64_01f5ce74bdcbc4589be5b7ccbd393d70_31bf3856ad364e35_6.3.9600.16477_none_efe8eb19b27435c2.manifest

Wersja pliku

Nie dotyczy

Rozmiar pliku

710

Data (UTC)

28-Nov-2013

Godzina (UTC)

01:03

Nazwa pliku

Amd64_b08f1d804fb2ba52c1a39f780276f717_31bf3856ad364e35_6.3.9600.16477_none_95426249afcc97f7.manifest

Wersja pliku

Nie dotyczy

Rozmiar pliku

705

Data (UTC)

28-Nov-2013

Godzina (UTC)

01:03

Nazwa pliku

Msil_microsoft.identityserver.proxyservice_31bf3856ad364e35_6.3.9600.16477_none_46ee2d31e9308eb5.manifest

Wersja pliku

Nie dotyczy

Rozmiar pliku

4,764

Data (UTC)

27-Nov-2013

Godzina (UTC)

16:14

Nazwa pliku

Msil_microsoft.identityserver.webhost_31bf3856ad364e35_6.3.9600.16477_none_7926ccd9e1870342.manifest

Wersja pliku

Nie dotyczy

Rozmiar pliku

3,334

Data (UTC)

28-Nov-2013

Godzina (UTC)

01:03


Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×