Symptomy
Rozpatrzmy następujący scenariusz:
-
Microsoft Commerce Server Catalog Menedżera 2009 tworzenia wariantów produktu przez dodanie właściwości wariantu produktu. Cena katalogowa produktu wariantu różni się od oryginalnego cennika produktu.
-
Format typu pełny eksport umożliwia eksportowanie katalogu do pliku XML.
-
Importowania wyeksportowanego pliku XML do wykazu przy użyciu Zamień typ formatu.
-
Możesz zmienić skojarzenia kategorii produktu. Aby to zrobić, Dodaj, a następnie wybierz kategorię na karcie Kategoria skojarzenia .
W tym scenariuszu cena katalogowa nowo dodanego produktu wariantu jest resetowany do oryginalnego cennika produktu. Uwaga Ten problem występuje również użycie Commerce Server API do wykonywania tych czynności.
Przyczyna
Ten problem występuje, ponieważ plik XML wykazu wywożonego produktu wariantu nie zawiera właściwości oryginalnej ceny i cena katalogowa. Po zaimportowaniu pliku XML wykazu przy użyciu Zamień typ formatu oryginalnego produktu ceny właściwości są używane do Wypełnij brakujące właściwości produktu wariantu.
Rozwiązanie
Informacje o poprawce
Obsługiwana poprawka jest udostępniana przez firmę Microsoft. Jednak ta poprawka jest przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Zastosuj poprawkę tylko w systemach, w których występuje problem opisany w tym artykule. Ta poprawka może być wciąż w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę. Jeśli poprawka jest dostępna do pobrania, pojawi się sekcja "Poprawka dostępna do pobrania" na początku tego artykułu z bazy wiedzy Knowledge Base. Jeśli nie ma tej sekcji, skontaktuj się z Obsługą i Wsparciem Klienta Microsoft w celu uzyskania poprawki. Uwaga Jeśli wystąpią dodatkowe błędy lub konieczność rozwiązania problemu, być może trzeba będzie utworzyć osobne zlecenie usługi. Zwykłe koszty obsługi będą zastosowane do dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu określonej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta firmy Microsoft lub utworzyć osobne zlecenie usługi odwiedź następujące witryny firmy Microsoft:
http://support.microsoft.com/contactus/?ws=supportUwaga "Poprawka dostępna do pobrania" zawiera listę języków, dla których dostępna jest poprawka. Jeśli odpowiedni język nie jest widoczny, to dlatego, że poprawka nie jest dostępna dla danego języka.
Uwagi dotyczące instalacji
Jeśli używasz pakietu szablonów programu Commerce Server 2009 dla programu SharePoint 2010, Pobierz i zainstaluj pakiet poprawek, który ma etykietę "CS2009TP_KB2532193". Jeśli używasz Microsoft Commerce Server 2009 RTM, należy pobrać i zainstalować pakiet poprawek, który ma etykietę "CS2009RTM_KB2532193".
Wymagania wstępne
Poniższa lista zawiera wymagania wstępne dotyczące pakietu poprawek:
-
Microsoft Commerce Server 2009
Wymagania dotyczące ponownego uruchamiania
Nie musisz ponownie uruchomiać komputera po zastosowaniu tej poprawki. Jednakże należy ponownie uruchomić usługi Internet Information Services (IIS) i aplikacji Commerce Server Catalog importu hosta COM + po zastosowaniu tej poprawki. Aby ponownie uruchomić usługi IIS, Otwórz okno wiersza polecenia, wpisz następujące polecenie i naciśnij klawisz Enter:
POLECENIE IISRESET/RESTART Uwaga Ta procedura zatrzymuje i ponownie uruchamia wszystkie usługi IIS są uruchomione.
Informacje o zastępowaniu
Ta poprawka nie zastępuje wcześniej wydanej poprawki.
Informacje dotyczące pliku
Wersja globalna tej poprawki używa pakietu Instalator systemu Microsoft Windows, aby zainstalować poprawkę. Daty i godziny odpowiadające tym plikom są wymienione w formacie uniwersalnego czasu koordynowanego (UTC, Coordinated Universal Time) w poniższej tabeli. Po wyświetleniu informacji dotyczących plików są one konwertowane na czas lokalny. Aby zobaczyć różnicę między czasem UTC i czasem lokalnym, należy użyć z karty Strefa czasowa w aplecie Data i godzina w Panelu sterowania.
Dla pakietu szablonów Microsoft Commerce Server 2009 dla programu SharePoint 2010
Nazwa pliku |
Wersja pliku |
Rozmiar pliku |
Data |
Godzina |
Platforma |
---|---|---|---|---|---|
Cspatchhelper.exe |
6.0.4171.513 |
16,224 |
12-Apr-2011 |
14:22 |
x86 |
Microsoft.catalogserver.dll |
6.0.4171.513 |
763,760 |
12-Apr-2011 |
14:22 |
x86 |
Microsoft.commerceserver.runtime.dll |
6.0.4171.513 |
849,792 |
12-Apr-2011 |
14:22 |
x86 |
Microsoft.commerceserver.catalog.dll |
6.0.4171.513 |
960,384 |
12-Apr-2011 |
13:58 |
x86 |
Dla programu Commerce Server 2009
Nazwa pliku |
Wersja pliku |
Rozmiar pliku |
Data |
Godzina |
Platforma |
---|---|---|---|---|---|
Cs2009hotfixhelper.exe |
6.0.4171.46 |
12,136 |
06-Apr-2011 |
12:03 |
x86 |
Microsoft.catalogserver.dll |
6.0.4171.46 |
763,760 |
06-Apr-2011 |
12:03 |
x86 |
Microsoft.commerceserver.runtime.dll |
6.0.4171.46 |
849,792 |
06-Apr-2011 |
12:03 |
x86 |
Microsoft.commerceserver.catalog.dll |
6.0.4171.46 |
960,384 |
06-Apr-2011 |
11:42 |
x86 |
Stan
Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Dotyczy”.