Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Symptomy

Jeśli instalacja aplikacji jest w toku podczas ccmsetup uaktualnia klienta microsoft System Center Configuration Manager, instalacja aplikacji może zakończyć się niepowodzeniem po uaktualnieniu.

Uwaga 16. Nie ma to wpływu na nowe wdrożenia aplikacji.

W przypadku aplikacji, w których dane żądania zawartości zostały usunięte, instalacje aplikacji nie powiodą się, a w pliku AppEnforce.log jest rejestrowany następujący komunikat o błędzie:

++++++ Nie można wymusić aplikacji. 0x87d01106 błędu.
++++++ AppEnforce data godzina 8128 (0x1FC0)

Przyczyna

Ten problem występuje, ponieważ dane żądania zawartości są usuwane podczas uaktualniania z powodu zmiany schematu.

Poniższa klasa śledzi żądania zawartości, które są wprowadzane podczas instalacji aplikacji. Ta klasa jest usuwana podczas uaktualniania klienta:

root\ccm\softmgmtagent:DownloadContentRequestEx2

Czy moje środowisko ma wpływ?

Aby ustalić, czy ten problem występuje w środowisku, uruchom następujące zapytanie w bazie danych serwera witryny:

select cia.AssignmentName, col.CollectionName  from CI_CurrentErrorDetails ced 

join CI_ConfigurationItems ci on ci.CI_ID = ced.CI_ID

join CI_AssignmentTargetedCIs cat on cat.CI_ID = ci.CI_ID

join CI_CIAssignments cia on cia.AssignmentID = cat.AssignmentID

join Collections_G col on col.CollectionID = cia.TargetCollectionID

where ced.ErrorCode in ( -2016407290)

group by cia.AssignmentName, col.CollectionName

Jeśli zapytanie zwraca wyniki podobne do poniższych, wpływa to na środowisko.

Nazwa zadania

Collectionname

Adobe za pośrednictwem CMD_All Systems_Install

Wszystkie systemy

Rozwiązanie

Ten problem został rozwiązany w globalnie dostępnej wersji systemu 1702 i w następującej aktualizacji dla pierwszego etapu 1702:

4018732 Aktualizacja dla System Center Configuration Manager wersji 1702, pierwszy etap

Uwaga 16. Ta aktualizacja zapobiegnie występowaniu problemu wymienionego w sekcji "Symptomy", gdy ccmsetup uaktualnia klienta Configuration Manager. Jeśli jednak problem już wystąpił, ta aktualizacja nie rozwiąże problemu. Aby rozwiązać ten problem po jego wystąpieniu, postępuj zgodnie z instrukcjami wymienionymi w sekcji "Obejście".

Obejście

Aby obejść ten problem, użyj jednej z następujących metod:

  • Untarget i retarget dotkniętych aplikacji.

  • Użyj zadania oczyszczania RunOnce bezpośrednio po zakończeniu uaktualnienia. W tym celu wykonaj następujące czynności:

    1. Utwórz pakiet dystrybucji oprogramowania i program, używając następującego polecenia: powershell -executionpolicy bypass -noprofile -command "& {$query=gwmi -class CCM_CITask -namespace root\ccm\citasks; $query| rwmi}"

    2. Ustaw instalację tak, aby działała jednorazowo (najlepiej, gdy żaden użytkownik nie jest zalogowany).

    3. Wdrożenie we wszystkich systemach, na które ma to wpływ.

Stan

Firma Microsoft potwierdziła, że jest to problem w produktach firmy Microsoft wymienionych w sekcji "Dotyczy".


Produkty, których dotyczy problem

Ten artykuł dotyczy również:

  • Microsoft System Center Configuration Manager (bieżąca gałąź — wersja 1702)

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×