Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Microsoft Business Solutions-Navision i Microsoft Navision są teraz częścią systemu Microsoft Dynamics NAV. Wszystkie nawiązania do programu Microsoft Business Solutions-Navision i Microsoft Navision odnoszą się do systemu Microsoft Dynamics NAV.

Ten artykuł dotyczy systemu Microsoft Dynamics NAV dla wszystkich krajów i ustawień regionalnych języka.

Objawy

Gdy upłynie limit czasu blokady w systemie Microsoft Dynamics NAV, Microsoft Dynamics NAV aplikacji serwera (NAS) nie odpowiada na zdarzenia. Dodatkowo gdy serwer NAS otrzymuje limit czasu blokady, serwer NAS przetwarza tylko co drugi komunikat z kolejki.

Przyczyna

Ten problem występuje, ponieważ serwer NAS traktuje jako błąd sieciowy limit czasu blokady. W związku z tym serwer NAS nie zostaje odłączony od bazy danych, zanim serwer NAS próbuje ponownie ustanowić połączenie z bazą danych.

Rozwiązanie

Informacje o poprawce

Obsługiwana poprawka jest obecnie udostępniana przez firmę Microsoft. Ta poprawka rozwiązuje problem opisany w tym artykule. Tylko w systemach, w których występuje ten problem, należy zastosować poprawkę.

Aby natychmiast rozwiązać ten problem, skontaktuj się z pomocy technicznej dla Microsoft Dynamics i produktów powiązanych w celu uzyskania poprawki. Możesz zalogować się w witrynie Microsoft Dynamics i utworzyć nowe żądanie pomocy technicznej. Aby to zrobić, odwiedź następującą witrynę firmy Microsoft w sieci Web:

https://mbs.microsoft.com/support/newstart.aspxUdzieli pomocy technicznej dotyczącej systemu Microsoft Dynamics i produktów powiązanych telefonicznie pod (888) 477-7877.

Uwaga W wyjątkowych przypadkach opłaty, telefonujący do pomocy technicznej mogą zostać anulowane, jeśli pomocy technicznej dla systemu Microsoft Dynamics i produktów powiązanych Określa, że określonej aktualizacji, można rozwiązać swój problem. Koszty obsługi zwykłych zastosuje się do wszelkich dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu określonej aktualizacji.

Wymagania wstępne

Musi mieć Microsoft Dynamics NAV 4.0 z dodatkiem Service Pack 3 z 6 aktualizacji, aby zastosować tę poprawkę.

Jak uzyskać poprawkę systemu Microsoft Dynamics NAV lub Aktualizuj moje pliki

Po zażądasz pomocy technicznej dotyczącej systemu Microsoft Dynamics o plik aktualizacji lub poprawek systemu Microsoft Dynamics NAV, hiperłącza będą wysyłane do Ciebie w wiadomości e-mail.


Wiadomość e-mail będzie zawierać hiperłącze i hasło. Hiperłącze można użyć do pobrania plików aktualizacji lub poprawek systemu Microsoft Dynamics NAV. Po kliknięciu hiperłącza zostanie otwarte okno dialogowe Pobieranie pliku — ostrzeżenie o zabezpieczeniach . Następnie monit, aby uruchomić, zapisać lub anulować pobieranie.


Jeśli klikniesz przycisk Uruchom, pliki rozpocznie się pobieranie i wyodrębnianie. Musisz określić folder dla nowych plików, a następnie podaj hasło.


Jeśli klikniesz przycisk Zapisz, należy określić ścieżkę do zapisania pliku skompresowanego. Po otwarciu zapisanego pliku są pojawi się monit, aby określić ścieżkę dla plików. Następnie należy podać hasło przesłane w wiadomości e-mail.


Jeśli klikniesz przycisk Anuluj, proces pobierania zostanie przerwany.

Jak zainstalować plik aktualizacji lub poprawek systemu Microsoft Dynamics NAV

Aktualizacje i poprawki dla systemu Microsoft Dynamics NAV są udostępniane jako pojedyncze pliki. Aby zainstalować systemu Microsoft Dynamics NAV poprawkę lub aktualizację, należy zastąpić istniejące pliki instalacji systemu Microsoft Dynamics NAV przy użyciu poprawki lub aktualizacji plików. Aby to zrobić, wykonaj następujące kroki:

  1. Użyj plików aktualizacji lub poprawki na zastępowanie plików w instalacji klienta systemu Microsoft Dynamics NAV, które są wymienione w poniższych tabelach:

    Microsoft Dynamics NAV 2009

    Nazwa pliku

    Wersja pliku

    Rozmiar pliku

    Data

    Godzina

    Platforma

    Dbm.dll

    6.0.30233.0

    444,232

    24-Nov-2009

    17:09

    x86

    Fin.exe

    6.0.30233.0

    12,257,096

    24-Nov-2009

    17:09

    x86

    Finhlink.exe

    6.0.30233.0

    452,432

    24-Nov-2009

    17:09

    x86

    Finsql.exe

    6.0.30233.0

    12,343,120

    24-Nov-2009

    17:09

    x86

    Nc_netb.dll

    6.0.30233.0

    108,368

    24-Nov-2009

    17:09

    x86

    Nc_tcp.dll

    6.0.30233.0

    108,368

    24-Nov-2009

    17:09

    x86

    Nc_tcps.dll

    6.0.30233.0

    153,424

    24-Nov-2009

    17:09

    x86

    Ndbcs.dll

    6.0.30233.0

    1,333,072

    24-Nov-2009

    17:09

    x86

    Slave.exe

    6.0.30233.0

    161,616

    24-Nov-2009

    17:09

    x86


    Microsoft Dynamics NAV 2009 SP1

    Nazwa pliku

    Wersja pliku

    Rozmiar pliku

    Data

    Godzina

    Platforma

    Dbm.dll

    6.0.30232.0

    427,848

    23-Nov-2009

    23:16

    x86

    Fin.exe

    6.0.30232.0

    12,598,600

    23-Nov-2009

    23:17

    x86

    Finhlink.exe

    6.0.30232.0

    452,432

    23-Nov-2009

    23:17

    x86

    Finsql.exe

    6.0.30232.0

    12,713,808

    23-Nov-2009

    23:17

    x86

    Nc_netb.dll

    6.0.30232.0

    96,592

    23-Nov-2009

    23:16

    x86

    Nc_tcp.dll

    6.0.30232.0

    98,640

    23-Nov-2009

    23:17

    x86

    Nc_tcps.dll

    6.0.30232.0

    141,136

    23-Nov-2009

    23:16

    x86

    Ndbcs.dll

    6.0.30232.0

    1,348,944

    23-Nov-2009

    23:16

    x86

    Slave.exe

    6.0.30232.0

    152,400

    23-Nov-2009

    23:16

    x86


    Uwaga Klienta systemu Microsoft Dynamics NAV jest zazwyczaj instalowany w następującym folderze:

    C:\Program Files\Microsoft Business Solutions-Navision\Client\Aby zastąpić istniejące pliki, wykonaj następujące kroki:

    1. Zamknij system Microsoft Dynamics NAV.

    2. Zlokalizuj folder instalacyjny klienta systemu Microsoft Dynamics NAV.

    3. Skopiuj pliki, które można pobrać.

    4. Wklej pliki, które można pobrać do folderu instalacji klienta systemu Microsoft Dynamics NAV.

    5. W oknie dialogowym Potwierdzanie zamiany pliku kliknij przycisk Tak, Aby zastąpić pliki w folderze instalacyjnym.

  2. Zastępowanie plików w instalacji serwera aplikacji Microsoft Dynamics NAV, które są wymienione w poniższej tabeli:

    Microsoft Dynamics NAV 2009

    Nazwa pliku

    Wersja pliku

    Rozmiar pliku

    Data

    Godzina

    Platforma

    Dbm.dll

    6.0.30233.0

    444,232

    24-Nov-2009

    02:13

    x86

    Nas.exe

    6.0.30233.0

    2,082,632

    24-Nov-2009

    02:13

    x86

    Nassql.exe

    6.0.30233.0

    2,168,656

    24-Nov-2009

    02:13

    x86

    Ndbcs.dll

    6.0.30233.0

    1,333,072

    24-Nov-2009

    02:13

    x86

    Slave.exe

    6.0.30233.0

    161,616

    24-Nov-2009

    02:13

    x86


    Microsoft Dynamics NAV 2009 SP1

    Nazwa pliku

    Wersja pliku

    Rozmiar pliku

    Data

    Godzina

    Platforma

    Dbm.dll

    6.0.30232.0

    427,848

    23-Nov-2009

    23:16

    x86

    Nas.exe

    6.0.30232.0

    2,259,784

    23-Nov-2009

    23:16

    x86

    Nassql.exe

    6.0.30232.0

    2,352,464

    23-Nov-2009

    23:16

    x86

    Ndbcs.dll

    6.0.30232.0

    1,348,944

    23-Nov-2009

    23:16

    x86

    Slave.exe

    6.0.30232.0

    152,400

    23-Nov-2009

    23:16

    x86


    Aby zastąpić te pliki, wykonaj następujące kroki.

    1. Zatrzymaj serwer aplikacji systemu Microsoft Dynamics NAV.

    2. Zlokalizuj folder instalacji serwera aplikacji Microsoft Dynamics NAV. Zazwyczaj serwera aplikacji systemu Microsoft Dynamics NAV jest instalowane w następującym folderze:

      C:\Program Files\Microsoft Business Solutions Navision\Application Server\

    3. Skopiuj pliki, które można pobrać.

    4. Wklej pliki, które można pobrać do folderu instalacji serwera aplikacji Microsoft Dynamics NAV.

    5. Kliknij przycisk Tak, Aby zastąpić pliki w tym folderze.

    6. Uruchom serwer aplikacji systemu Microsoft Dynamics NAV.

Stan

Firma Microsoft potwierdziła, że jest to usterka występująca w produktach firmy Microsoft wymienionych w sekcji "Dotyczy".

Więcej informacji

Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

824684 Opis standardowej terminologii używanej do opisywania aktualizacji oprogramowania firmy Microsoft

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×