Importante
O suporte para o Microsoft InfoPath 2013 terminou a 14 de julho de 2026. Recomendamos a migração de formulários e fluxos de trabalho existentes do InfoPath para soluções suportadas do Microsoft 365. Saiba mais sobre a descontinuação do InfoPath.
No Microsoft Office InfoPath, pode utilizar a formatação condicional para especificar diferentes opções de formatação para um controlo baseado em condições que ocorrem no formulário. Se as condições especificadas forem verdadeiras quando um utilizador preencher um formulário baseado no seu modelo de formulário, a formatação condicional é aplicada.
Este artigo explica como utilizar a formatação condicional para alterar a cor de fundo de uma linha numa secção de repetição. É útil se pretender mostrar o estado de um item na secção de repetição. Por exemplo, num modelo de formulário de relatório de estado, pode utilizar a formatação condicional para tornar vermelha a linha de um item atrasado e a linha de um item que está dentro do prazo verde.
Nota
Este artigo utiliza cores para demonstrar um procedimento. No entanto, alguns utilizadores não conseguem distinguir cores. Para criar um modelo de formulário acessível, certifique-se de que também adiciona texto relevante ao seu modelo de formulário para indicar o estado de um item.
Neste artigo
- Passo 1: adicionar os controlos
- Passo 2: especificar a formatação condicional
- Passo 3: pré-visualizar o modelo de formulário
Passo 1: adicionar os controlos do InfoPath
Para concluir este procedimento, o modelo de formulário tem de conter uma secção de repetição, uma caixa de texto e uma caixa de lista pendente. Para adicionar estes controlos, faça o seguinte:
- No modelo de formulário, clique onde pretende inserir uma secção de repetição.
- Se o painel de tarefas Controlos não estiver visível, clique em Mais Controlos no menu Inserir ou prima ALT+I, C
- No painel de tarefas Controlos , selecione a caixa de verificação Criar automaticamente origem de dados .
- Em Inserir controles, clique em Seção de Repetição.
- Coloque o ponto de inserção na secção de repetição.
- Em Inserir controlos no painel de tarefas Controlos , clique em Caixa de Texto.
- Prima ENTER e, em seguida, em Inserir controlos, clique em Caixa de Lista Pendente.
- No modelo de formulário, digite Item de Trabalho: como o rótulo da caixa de texto e digite Status: como o rótulo da caixa de lista suspensa.
- Faça duplo clique na caixa de lista pendente no modelo de formulário.
- Clique no separador Dados.
- Em Entradas da caixa de listagem, clique em Adicionar.
- Na caixa Valor da caixa de diálogo Adicionar Escolha, digite Ativo e clique em OK.
- Repita os passos 11 e 12 para adicionar as opções Resolvido e Fechado na caixa de lista pendente.
Passo 2: especificar a formatação condicional para o InfoPath
Depois de adicionar os controlos ao modelo de formulário, pode especificar a formatação condicional apropriada.
Selecione a seção de repetição no modelo de formulário e, no menu Formatar , clique em Formatação Condicional.
Na caixa de diálogo Formatação Condicional, clique em Adicionar.
Em Se esta condição for verdadeira, na primeira caixa, clique no campo que corresponde à caixa de lista pendente que acabou de inserir.
Na segunda caixa, deixe o valor como é igual a.
Na terceira caixa, clique em Escrever texto e, em seguida, escreva Ativo.
Nota
As expressões são sensíveis às maiúsculas e minúsculas.
Na lista Sombreado, em Em seguida, aplique esta formatação, clique em vermelho e, em seguida, clique em OK.
Repita os passos 2 a 6 para adicionar formatação condicional às duas entradas de lista restantes. Selecione amarelo como a cor de fundo para Resolvido e verde como a cor de fundo para Fechado.
Passo 3: pré-visualizar o modelo de formulário do InfoPath
Depois de adicionar a formatação condicional ao modelo de formulário, recomenda-se que teste as alterações para se certificar de que estão a funcionar corretamente.
- Para testar as suas alterações, clique em Pré-visualizar na barra de ferramentas Padrão ou prima CTRL+SHIFT+B.
- Na janela de pré-visualização, selecione as diferentes opções na lista pendente. Repare que, à medida que seleciona as opções, a cor de fundo na secção muda em conformidade.
- No menu Inserir , aponte para Secção e, em seguida, clique no nome da secção para adicionar mais uma secção. Note que a formatação condicional é aplicada independentemente de ambas as secções.