Reparar um livro danificado

Aplica-se A
Excel para Microsoft 365 Excel 2024 Excel 2021 Excel 2019 Excel 2016

Quando o Microsoft Excel deteta um livro danificado ao abrir, inicia automaticamente o modo de Recuperação de Ficheiros e tenta reparar o livro. Se o modo de Recuperação de Ficheiros não iniciar, experimente utilizar este processo manual para recuperar o livro:

  1. Clique em Abrir Ficheiro>.
  2. Clique na localização e pasta que contêm o livro danificado.
  3. Na caixa de diálogo Abrir , selecione o livro danificado.
  4. Clique na seta junto ao botão Abrir e, em seguida, clique em Abrir e Reparar.
    Comando abrir e reparar
  5. Para recuperar o máximo de dados do livro quanto possível, selecione Reparar.
    Se a ferramenta Reparar não conseguir recuperar os seus dados, selecione Extrair Dados para extrair valores e fórmulas do livro.

Se a reparação automática ou manual não funcionar, existem alguns métodos de recuperação que podem ajudar a recuperar os seus dados. Também pode tomar algumas medidas preventivas para evitar perder o seu trabalho ao guardar automaticamente uma cópia de segurança do seu livro ou ao criar um ficheiro de recuperação de vez em quando.

Recuperar dados de um livro danificado

Escolha um dos seguintes métodos para ajudar a recuperar os seus dados. Se não resultar, tente outro método. Também pode experimentar soluções de software de terceiros para tentar recuperar o livro.

Importante

Se um erro de disco ou de rede o impedir de abrir um livro, mova o livro para uma unidade de disco rígido diferente ou para um disco local antes de experimentar qualquer uma das seguintes opções de recuperação.

Recuperar dados quando o livro está aberto no Excel

  • Reverta o livro para a última versão guardada: Se um livro ficar danificado enquanto trabalha, mas antes de guardar as suas alterações, pode reverter o livro para a última versão guardada:

    1. Clique em Abrir Ficheiro>.
    2. Clique duas vezes no nome do livro que tem aberto no Excel.
    3. Clique em Sim para reabrir o livro.
      O livro é aberto sem quaisquer alterações que tenha feito que possam ter causado danos no livro.

Recuperar dados quando não consegue abrir o livro no Excel

  • Definir a opção de cálculo no Excel como manual: Experimente alterar a definição de cálculo de automática para manual. Uma vez que o livro não será recalculado, é possível que seja aberto.

    1. Clique em Arquivo>Novo.
    2. Em Novo, clique em Livro em branco.
    3. Clique emOpçõesde arquivo>.
    4. Na categoria Fórmulas, em Opções de cálculo, selecione Manual e clique em OK.
    5. Clique em Abrir Ficheiro>.
    6. Localize e faça duplo clique no livro danificado para o abrir.
  • Utilizar referências externas para ligar ao livro danificado: Para obter apenas os dados e não recuperar as fórmulas ou os valores calculados do livro, tente utilizar referências externas para ligar ao livro danificado.

    1. Clique em Abrir Ficheiro>.

    2. Aceda à pasta que contém o livro danificado.

    3. Clique com o botão direito do rato no nome do ficheiro do livro danificado, clique em Copiar e, em seguida, clique em Cancelar.

    4. Clique em Arquivo>Novo.

    5. Em Novo, clique em Livro em branco.

    6. Na célula A1 do novo livro, escreva =Nome do Ficheiro! A1, em que Nome do Ficheiro é o nome do livro danificado que copiou no passo 3 e, em seguida, prima Enter.

      Nota

      Só tem de introduzir o nome do livro, não precisa de introduzir a extensão de nome de ficheiro.

    7. Se a caixa de diálogo Atualizar Valores for exibida, selecione a pasta de trabalho corrompida e clique em OK.

    8. Se a caixa de diálogo Selecionar Folha for apresentada, selecione a folha adequada e, em seguida, clique em OK.

    9. Selecione a célula A1.

    10. Clique em Home>Copy ou prima Ctrl+C.

    11. Selecione uma área, a começar na célula A1, que seja aproximadamente do mesmo tamanho do intervalo de células que contêm dados no livro danificado.

    12. Clique em Base>Colar ou prima Ctrl+V.

    13. Com o intervalo de células selecionado, clique novamente em Cópia Inicial> ou prima Ctrl+C.

    14. Clique em Base> , na seta abaixo de Colar e, em seguida, em Colar Valores, clique em Valores.
      Colar os valores remove as ligações para o livro danificado e deixa apenas os dados.

  • Utilizar uma macro para extrair dados de um livro danificado: Se tiver um gráfico ligado ao livro danificado, experimente utilizar uma macro para extrair os dados de origem do gráfico.

    1. Copie o seguinte código de macro e cole-o numa folha de módulo:
      Sub GetChartValues()
      Dim NumberOfRows As Integer
      Dim X As Object
      Contador = 2
      ' Calcule o número de linhas de dados.
      NumberOfRows = UBound(ActiveChart.SeriesCollection(1). Valores)
      Folhas de cálculo ("ChartData"). Células(1; 1) = "Valores X"
      ' Escreva os valores do eixo x na folha de cálculo.
      Com Folhas de Cálculo ("ChartData")
      . Intervalo(. Células(2; 1); _
      . Células(NúmeroDeLinhas + 1, 1)) = _
      Application.Transpose(ActiveChart.SeriesCollection(1). XValues)
      Terminar com
      ' Loop todas as séries do gráfico e escreva os seus valores
      ' a planilha.
      Para cada x em ActiveChart.SeriesCollection
      Folhas de cálculo ("ChartData"). Células(1; Contador) = X.Name
      Com Folhas de Cálculo ("ChartData")
      . Intervalo(. Células(2; contador), _
      . Células(NúmeroDeLinhas + 1, Contador)) = _
      Application.Transpose(X.Values)
      Terminar com
      Contador = Contador + 1
      Seguinte
      End Sub

    2. Insira ou elimine uma folha de cálculo no seu livro, clique com o botão direito do rato no respetivo separador de folha e, em seguida, mude o nome para ChartData.

    3. Selecione o gráfico a partir do qual pretende extrair os valores dos dados subjacentes.

      Nota

      O gráfico não pode ser incorporado numa folha de cálculo ou numa folha de gráficos em separado.

    4. Execute a macro.

    5. Os dados do gráfico são colocados na folha de cálculo ChartData .

Início da Página

Guardar automaticamente uma cópia de segurança de um livro

Com uma cópia de segurança do seu livro, terá sempre acesso aos seus dados se o livro for eliminado acidentalmente ou ficar danificado.

  1. Clique em Guardar Ficheiro>Como.
  2. Clique no botão Procurar .
    Botão procurar
  3. Na caixa de diálogo Guardar Como , clique na seta junto a Ferramentas e, em seguida, clique em Opções Gerais.
    Opções Gerais no menu Ferramentas
  4. Na caixa de diálogo Opções Gerais , marque a caixa Sempre criar backup .
    Opção Criar sempre cópia de segurança na caixa de diálogo Opções Gerais

Início da Página

Criar automaticamente um ficheiro de recuperação em intervalos definidos

Um ficheiro de recuperação do seu livro também ajuda a garantir que terá acesso aos seus dados se o livro for eliminado acidentalmente ou se ficar danificado.

  1. Clique emOpçõesde arquivo>.
  2. Na categoria Guardar , em Guardar livros, selecione a caixa Guardar informações de Recuperação Automática a cada e, em seguida, introduza um número de minutos. (O valor predefinido é 10.)
    Opção de Recuperação Automática no separador Guardar na caixa de diálogo de Opções do Excel
  3. Na caixa Localização do ficheiro de Recuperação Automática, introduza o local onde pretende guardar o ficheiro de recuperação.
  4. Certifique-se de que a caixa Desativar Recuperação Automática apenas para este livro está desmarcada.

Início da Página