Ocorreu um problema e o Outlook não conseguiu configurar a sua conta

PROBLEMA

Ao adicionar uma conta do Outlook para o Microsoft 365 com um domínio personalizado ou uma conta Outlook.com com um endereço de e-mail personalizado, recebe o seguinte erro:

Ocorreu um problema ao adicionar a sua conta de e-mail ao Outlook.

CAUSA

Este problema ocorre porque o processo de Deteção Automática utilizado pelo Outlook recebe um resultado inesperado de um servidor Web de terceiros quando executa a pesquisa de domínio raiz. Por exemplo, o Outlook pode receber um resultado como https://< RootDomain>/AutoDiscover/AutoDiscover.xml. 

Normalmente, a pesquisa de domínio raiz falharia neste caso e o Outlook efetuaria uma pesquisa de Deteção Automática em relação a https://AutoDiscover.<RootDomain>/AutoDiscover/AutoDiscover.xml. No entanto, uma vez que o Outlook recebe uma resposta de Deteção Automática bem-sucedida da pesquisa de domínio raiz, o Outlook tenta autenticar-se nos protocolos anunciados, como POP e IMAP, e a operação falha.

SOLUÇÃO

Contacte o fornecedor de serviços Web ou o fornecedor de alojamento Web do seu site de domínio e certifique-se de que o servidor Web não está a responder aos pedidos de Deteção Automática.

SOLUÇÃO

Para resolver este problema se o fornecedor de serviços Web ou o fornecedor de alojamento Web não conseguir resolvê-lo, efetue a seguinte ação:

  • Crie chaves de registo do Outlook para excluir as definições Último Bem Conhecido, o domínio de raiz HTTPS e o registo SRV, conforme detalhado abaixo. Assim que as entradas do registo estiverem implementadas, reinicie o Outlook e tente adicionar a conta ou criar um novo perfil novamente.

    • Utilize ExcludeLastKnownGoodUrl para impedir que o Outlook utilize o último URL de Deteção Automática válido conhecido
      HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Autodiscover
      DWORD: ExcludeLastKnownGoodUrl
      Valor: 1

      OU

      HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Autodiscover
      DWORD: ExcludeLastKnownGoodUrl
      Valor: 1

    • Utilizar ExcludeHttpsRootDomain para impedir que o Outlook utilize o domínio de raiz HTTPS
      HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Autodiscover
      DWORD: ExcludeHttpsRootDomain
      Valor: 1

      OU

      HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Autodiscover
      DWORD: ExcludeHttpsRootDomain
      Valor: 1

    • Utilizar ExcludeSrvRecord para impedir que o Outlook utilize o domínio de raiz HTTPS
      HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Autodiscover
      DWORD: ExcludeSrvRecord
      Valor: 1

      OU

      HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Autodiscover
      DWORD: ExcludeSrvRecord
      Valor: 1

Nota

  • O titular da posição x.0 representa a sua versão do Office (16.0 = Office 2016, Office 365 e Office 2019, 15.0 = Office 2013).
  • Quando o valor ExcludeLastKnownGoodUrl está definido como 1, o Outlook não utiliza o último URL de Deteção Automática de trabalho conhecido.

Importante

Excluir o domínio de raiz HTTPS não é uma solução a longo prazo para este problema e não o recomendamos. Esta solução é fornecida como um alívio imediato para o problema. Assim que o fornecedor de serviços Web ou o fornecedor de alojamento Web resolver o problema, a chave de registo do Outlook tem de ser removida.

Para obter mais informações sobre a Deteção Automática e as definições do registo, veja Comportamento inesperado da Deteção Automática quando tem definições de registo na chave \Autodiscover.