Mensagem de erro ao tentar imprimir um relatório no Microsoft Dynamics CRM 4.0: "Não é possível carregar o controlo de impressão do cliente"

Aplica-se A
Dynamics CRM 4.0

Sintomas

Quando tenta imprimir um relatório no Microsoft Dynamics CRM 4.0, recebe a seguinte mensagem de erro:

Nota

Não é possível carregar o controlo de impressão do cliente.

Este problema ocorre se instalar a atualização para SQL Server Versão de Distribuição Geral (GDR) do Service Pack 2 de 2005.

Para obter mais informações sobre a atualização para SQL Server 2005 Service Pack 2 GDR, clique no seguinte número de artigo para ver o artigo na Base de Dados de Conhecimento Microsoft:

954606 MS08-052: Descrição da atualização de segurança para GDI+ para SQL Server 2 GDR do Service Pack 2 de 2005: 9 de setembro de 2008

Causa

Este problema ocorre porque a atualização para SQL Server 2005 Service Pack 2 GDR atualiza o número da versão da classe RSClientPrint. Por conseguinte, o controlo do reportviewer também tem de ser atualizado.

Resolução

Para resolver este problema, utilize um dos seguintes métodos:

  • Instale o Report Viewer Redistributable 2005 Service Pack 1. Para obter o Report Viewer Redistributable 2005 Service Pack 1, visite o seguinte Web site da Microsoft:
    http://www.microsoft.com/download/details.aspx?familyid=82833F27-081D-4B72-83EF-2836360A904D&displaylang=en

  • Instale o pacote de atualização cumulativa 9 para SQL Server Service Pack 2 de 2005.

    Para obter mais informações sobre o pacote de atualização cumulativa 9 para SQL Server Service Pack 2 de 2005, clique no seguinte número de artigo para ver o artigo na Base de Dados de Conhecimento Microsoft:

    953752 Pacote de atualização cumulativa 9 para SQL Server Service Pack 2 de 2005
     

    Se continuar a receber a mensagem de erro mencionada na secção Sintomas depois de instalar o pacote de atualização cumulativa 9, elimine a classe RSClientPrint. Para fazê-lo, siga estes passos:

    1. Inicie o Windows Internet Explorer.

    2. No menu Ferramentas, clique em Opções da Internet.

    3. Siga o passo adequado:

      • No Windows Internet Explorer 7, clique em Definições na área Histórico de navegação e, em seguida, clique em Ver objetos.
      • No Microsoft Internet Explorer 6, clique em Definições na área Ficheiros temporários da Internet e, em seguida, clique em Ver Objetos.
    4. Clique com o botão direito do rato em RSClientPrint Class (Classe RSClientPrint) e, em seguida, clique em Remove (Remover).

Referências

Para obter mais informações, visite o seguinte Web site da Microsoft:

http://blogs.msdn.com/mariae/