São adicionados dois carateres especiais no final do valor quando copia um valor de célula de uma folha de cálculo do Excel para o Microsoft Dynamics NAV 5.0 Service Pack 1

Aplica-se A
Microsoft Dynamics NAV 5.0

Este artigo aplica-se ao Microsoft Dynamics NAV para todos os países e regiões de idioma.

Sintomas

Quando copia um valor de célula de uma folha de cálculo do Excel para o Microsoft Dynamics NAV 5.0 Service Pack 1 (SP1), são adicionados dois carateres especiais no final do valor. Estes carateres especiais são sinais de retângulo como carateres de avanço de linha.

Nota Se executar o Microsoft Dynamics NAV e o Microsoft Excel num computador baseado no Windows 7, estes dois carateres não estarão visíveis. Se executar o Microsoft Dynamics NAV e o Microsoft Excel num computador baseado em Windows Server 2003, os carateres são visíveis.

Estes carateres são adicionados aos campos no Microsoft Dynamics NAV. Por conseguinte, tem de eliminar manualmente os carateres especiais.

Causa

Este problema ocorre porque o caráter de retorno do símbolo (CR) (ASCII 13) ou o caráter de avanço de linha (LF) (ASCII 10) é adicionado quando um valor de célula é copiado de uma folha de cálculo do Excel para uma aplicação. O cliente RoleTailored (RTC) utiliza o controlo de texto, com base no controlo de texto .NET padrão. Se o controlo de texto .NET tiver a propriedade Multiline definida como "Não", quando cola um texto de controlo que contém o caráter CR ou o caráter LF, apenas o texto antes de os carateres serem copiados. Se o controlo de texto tiver a propriedade Multiline definida como "Verdadeiro", pode ser utilizado o caráter "nova linha". Para obter mais informações, visite o seguinte site da Microsoft:
Propriedade TextBoxBase.Multiline
Num cliente clássico, o Microsoft Dynamics NAV tem de implementar um processamento especial para o método Colar dos controlos de edição de texto. Os carateres de "nova linha" têm de ser removidos do fim da linha.

Resolução

Informações de correção

Está disponível uma correção suportada da Microsoft. Existe uma secção "Transferência de correção disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se estiver a deparar-se com um problema ao transferir, instalar esta correção ou tiver outras questões de suporte técnico, contacte o seu parceiro ou, se estiver inscrito num plano de suporte diretamente com a Microsoft, pode contactar o suporte técnico do Microsoft Dynamics e criar um novo pedido de suporte. Para tal, visite o seguinte site da Microsoft:

https://mbs.microsoft.com/support/newst art.aspx Também pode contactar o suporte técnico do Microsoft Dynamics por telefone através destas ligações para números de telefone específicos do país/região. Para tal, visite um dos seguintes sites da Microsoft:

Iniciar sessão no Power BI

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global +Suporte+Contactos Clientes

formação/global_support_contacts_eng.htmhttps://mbs.microsoft.com/customersource/support/information/SupportIn Em casos especiais, os custos normalmente incorridos para chamadas de suporte podem ser cancelados se um Profissional de Suporte Técnico para o Microsoft Dynamics e produtos relacionados determinar que uma atualização específica irá resolver o problema. Os custos de suporte habituais serão aplicados a quaisquer questões e problemas de suporte adicionais que não sejam elegíveis para a atualização específica em questão.

            
          

Como obter a correção do Microsoft Dynamics NAV ou atualizar ficheiros

Depois de pedir uma correção do Microsoft Dynamics NAV, será enviada uma hiperligação para si num e-mail.

O e-mail conterá uma hiperligação e uma palavra-passe. Pode utilizar a hiperligação para transferir a correção do Microsoft Dynamics NAV ou os ficheiros de atualização. Quando clica na hiperligação, é aberta a caixa de diálogo Transferência de Ficheiros – Aviso de Segurança . Em seguida, é-lhe pedido para executar, guardar ou cancelar a transferência.

Se clicar em Executar, os ficheiros iniciam a transferência e o processo de extração. Tem de especificar uma pasta para os novos ficheiros e, em seguida, fornecer a palavra-passe.

Se clicar em Guardar, tem de especificar um caminho para guardar o ficheiro comprimido. Quando abrir o ficheiro que guardou, ser-lhe-á pedido que especifique um caminho para os ficheiros. Em seguida, tem de indicar a palavra-passe fornecida no e-mail.

Se clicar em Cancelar, o processo de transferência para.

Como instalar uma correção do Microsoft Dynamics NAV ou um ficheiro de atualização

As correções e atualizações da plataforma Microsoft Dynamics NAV são disponibilizadas como ficheiros únicos. Para instalar uma correção do Microsoft Dynamics NAV ou uma atualização, tem de substituir os ficheiros de instalação existentes do Microsoft Dynamics NAV pela correção ou pelos ficheiros de atualização. Para tal, siga estes passos.

Passo 1: Substituir o ficheiro de instalação do Cliente Microsoft Dynamics NAV

Na instalação do Cliente Microsoft Dynamics NAV, substitua os seguintes ficheiros com a correção ou o ficheiro de atualização.

Nome de ficheiro Versão do ficheiro Tamanho do ficheiro Data Hora Plataforma
Dbm.dll 5.0.32009.0 434,176 09-Dez-2010 19:53 x86
Fin.exe 5.0.32009.0 10,747,904 09-Dez-2010 19:31 x86
Finhlink.exe 5.0.32009.0 339,968 09-Dez-2010 19:44 x86
Finsql.exe 5.0.32009.0 10,809,344 09-Dez-2010 20:17 x86
Nc_netb.dll 5.0.32009.0 102,400 09-Dez-2010 19:54 x86
Nc_tcp.dll 5.0.32009.0 102,400 09-Dez-2010 19:54 x86
Nc_tcps.dll 5.0.32009.0 147,456 09-Dez-2010 19:55 x86
Ndbcs.dll 5.0.32009.0 1,286,144 09-Dez-2010 20:20 x86
Slave.exe 5.0.32009.0 151,552 09-Dez-2010 19:44 x86

Para substituir os ficheiros existentes do Microsoft Dynamics NAV, siga estes passos:

  1. Feche o Microsoft Dynamics NAV.
  2. Localize o diretório de instalação do Cliente Microsoft Dynamics NAV. Normalmente, o Cliente Microsoft Dynamics NAV é instalado no seguinte diretório:
    C:\Program Files\Microsoft Dynamics NAV\CSIDE Client\
  3. Copie os ficheiros que transferiu.
  4. Cole os ficheiros que transferiu para o diretório de instalação do Cliente Microsoft Dynamics NAV.
  5. Quando lhe for pedido, clique em Sim para substituir os ficheiros no diretório de instalação.

Passo 2: Substituir o ficheiro de instalação do Microsoft Dynamics NAV Application Server

Se tiver o Microsoft Dynamics NAV Application Server instalado, na instalação do Microsoft Dynamics NAV Application Server, substitua os seguintes ficheiros com a correção ou o ficheiro de atualização.

Nome de ficheiro Versão do ficheiro Tamanho do ficheiro Data Hora Plataforma
Dbm.dll 5.0.32009.0 434,176 09-Dez-2010 19:53 x86
Nas.exe 5.0.32009.0 1,859,584 09-Dez-2010 19:41 x86
Nassql.exe 5.0.32009.0 1,916,928 09-Dez-2010 20:19 x86
Ndbcs.dll 5.0.32009.0 1,286,144 09-Dez-2010 20:20 x86
Slave.exe 5.0.32009.0 151,552 09-Dez-2010 19:44 x86

Para substituir os ficheiros, siga estes passos.

  1. Pare o Microsoft Dynamics NAV Application Server.
  2. Localize o diretório de instalação do Microsoft Dynamics NAV Application Server. Normalmente, o Microsoft Dynamics NAV Application Server é instalado no seguinte diretório:
    C:\Program Files\Microsoft Dynamics NAV\Application Server\
  3. Copie os ficheiros que transferiu.
  4. Cole os ficheiros que transferiu para o diretório de instalação do Microsoft Dynamics NAV Application Server.
  5. Quando lhe for pedido, clique em Sim para substituir os ficheiros no diretório de instalação.
  6. Inicie o Microsoft Dynamics NAV Application Server.

Passo 3: Substituir o ficheiro de instalação do controlador ODBC do Microsoft Dynamics NAV

Se tiver o controlador ODBC microsoft Dynamics NAV instalado, substitua os seguintes ficheiros na instalação do controlador ODBC do Microsoft Dynamics NAV.

Nome de ficheiro Versão do ficheiro Tamanho do ficheiro Data Hora Plataforma
Cfront.dll 5.0.32009.0 1,294,336 09-Dez-2010 19:55 x86
Dbm.dll 5.0.32009.0 434,176 09-Dez-2010 19:53 x86
Nc_netb.dll 5.0.32009.0 102,400 09-Dez-2010 19:54 x86
Nc_tcp.dll 5.0.32009.0 102,400 09-Dez-2010 19:54 x86
Nc_tcps.dll 5.0.32009.0 147,456 09-Dez-2010 19:55 x86
Nodbc.dll 5.0.32009.0 2,650,112 09-Dez-2010 19:35 x86
Nodbc.xml Não aplicável 1,209 07-Abr-2008 01:09 Não aplicável
Nodbccfg.cfg 5.0.32009.0 614,400 09-Dez-2010 19:36 Não aplicável
Nodbccfg.xml Não aplicável 2,472 07-Abr-2008 01:09 Não aplicável
Slave.exe 5.0.32009.0 151,552 09-Dez-2010 19:44 x86

Para substituir os ficheiros, siga estes passos.

  1. Localize o diretório de instalação do controlador ODBC do Microsoft Dynamics NAV. O controlador ODBC do Microsoft Dynamics NAV é normalmente instalado no seguinte diretório:
    C:\Program Files\Common Files\Dynamics NAV\NODBC\
  2. Copie os ficheiros que transferiu.
  3. Cole os ficheiros que transferiu para o diretório de instalação do controlador ODBC do Microsoft Dynamics NAV.
  4. Quando lhe for pedido, clique em Sim para substituir os ficheiros no diretório de instalação.

Pré-requisitos

Tem de ter o Microsoft Dynamics NAV 5.0 Service Pack 1 instalado para aplicar esta correção.

Solução

Para contornar, edite a célula e marque a célula como "Apenas Texto".

Estado

A Microsoft confirmou que se trata de um erro nos produtos Microsoft listados na secção "Aplica-se a".

Mais Informações

Para obter mais informações, clique no seguinte número de artigo para ver o artigo na Base de Dados de Conhecimento Microsoft:

824684 Descrição da terminologia padrão utilizada para descrever as atualizações de software da Microsoft

Nota Este é um artigo "PUBLICAÇÃO RÁPIDA" criado diretamente a partir da organização de suporte da Microsoft. As informações aqui contidas são fornecidas tal como estão em resposta a problemas emergentes. Como resultado da velocidade de disponibilização, os materiais podem incluir erros tipográficos e podem ser revistos em qualquer altura sem aviso prévio. Veja Termos de Utilização para outras considerações.