Sintomas
Num ambiente do Microsoft Exchange Server 2016, os utilizadores experimentam o seguinte comportamento quando uma operação FindItems é realizada em chamadas de Exchange Web Services (EWS):
-
A chamada EWS falha com o seguinte erro:
Exceção não tratada: Microsoft.Exchange.WebServices.Data.ServiceResponseException: Ocorreu um erro interno do servidor. A operação falhou., não é possível consultar filas numa mesa.
-
Os registos EWS em C:\Program Files\Microsoft\Exchange Server\V15\Logging\Ews no servidor da função da caixa de correio mostram o seguinte erro:
ExceptionHandler_Execute=Microsoft.Exchange.Data.StoragePermanentExcepção: Não é possível consultar linhas numa tabela. ---> Microsoft.Mapi.MapiExceptionMaxObjsExceeded: MapiExceptionMaxObjsExceeded: Incapaz de consultar linhas de mesa.
Causa
Uma alteração no número de restrições materializadas que podem existir numa caixa de correio foi introduzida no Exchange Server 2016. Esta alteração pode desencadear uma situação em que uma chamada FindItems deve criar uma nova pesquisa materializada na caixa de correio, mas não pode fazê-lo porque a caixa de correio já está no limite.
Resolução
Para resolver o problema, instale o Exchange Server 2016 Cumulativo Update 3 ou posteriormente. No cenário descrito na secção "Sintomas", a pesquisa materializada mais antiga será envelhecida depois de instalar esta atualização. Portanto, uma nova pesquisa pode ser criada sem gerar uma exceção.