Aplica-se A
Dynamics CRM 4.0

Sintomas

Utiliza muitos fluxos de trabalho no Microsoft Dynamics CRM 4.0. As tabelas AsyncOperationBase e WorkflowLogBase crescem muito grandes e ocorrem problemas de desempenho.

Causa

Este problema ocorre porque, quando as regras de fluxo de trabalho são disparadas, uma instância de fluxo de trabalho e um registo de fluxo de trabalho são criados nas tabelas AsyncOperationBase e WorkflowLogBase da base de dados MSCRM. No entanto, quando a instância de fluxo de trabalho estiver concluída, o registo do fluxo de trabalho permanece na base de dados. Por isso, as tabelas AsyncOperationBase e WorkflowLogBase continuam a crescer. Eventualmente, o desempenho diminui. Note A propriedade AsyncOperationType para estes registos está definida para 10.

Resolução

Este problema é corrigido na mais recente atualização cumulativa para o Microsoft Dynamics CRM 4.0. Para mais informações, clique no seguinte número de artigo para ver o artigo na Base de Conhecimento da Microsoft:

949256 Microsoft Dynamics CRM 4.0 atualizações e hotfixes Importante Esta secção, método ou tarefa contém etapas que lhe dizem como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorreta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Para maior segurança, faça uma cópia de segurança do registo antes de o modificar. Deste modo, pode restaurar o registo se ocorrer um problema. Para mais informações sobre como fazer uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para ver o artigo na Base de Dados de Conhecimento Microsoft:

322756 Como fazer o back up e restaurar o registo no Windows Depois de instalar o hotfix, para que possamos ativar este hotfix para si, vá à secção "Fix it for me". Se preferir ativar o hotfix, vá para a secção "Deixe-me consertá-lo eu mesmo".

Corrigir automaticamente

Para ativar o hotfix automaticamente, clique no botão Fix it ou link. Em seguida, clique em Executar na caixa de diálogo 'Descarregar ficheiro' e siga os passos no assistente 'Corrigir-o'.

Notas

  • Este assistente pode estar apenas em inglês. No entanto, a correção automática também funciona para versões do Windows noutros idiomas.

  • Se não estiver no computador que tem o problema, guarde a solução Fix-lo para uma pen ou um CD e, em seguida, execute-a no computador que tem o problema.

Então, vá para a secção"Isto resolveu o problema?".

Deixar-me corrigir o problema

Para ativar este hotfix, siga estes passos:

  1. Clique em Iniciar,clique em Executar,escreva regedit e, em seguida, clique em OK.

  2. No Editor de Registos, localize o seguinte sub-chave:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

  3. Determine se existe uma entrada de registo DWORD que é chamada asyncRemoveCompletedWorkflows. Os dados de valor da entrada no registo de fluxos asyncRemoveCompletedWork devem ser 1.

  4. Se a entrada de registo de fluxos asyncRemoveCompletedWork não existir, adicione a entrada. Para isso, siga estes passos:

    1. Clique com o botão direito MSCRM, aponte para Novo,clique em DWORD Valuee, em seguida, escreva os fluxos de Trabalho AsyncRemoveCompleted Na caixa Nome.

    2. Clique duas vezes em AsyncRemoveCompletedWorkflowse, em seguida, digite 1 na caixa de dados Value.

    3. Clique em Iniciar,clique em Executar,digite o iisreset e, em seguida, clique em OK. Nota Se o valor na caixa de dados de valor para o valor DWORD da AsyncRemoveCompletedWorkflows reverte para 0, o CRM da Microsoft Dynamics continuará a manter os registos do Fluxo de Trabalho na base de dados mesmo que as tarefas estejam concluídas.

Nota Este hotfix é apenas proactivo. Portanto, quando o hotfix é instalado e ativado, apenas novos registos de fluxo de trabalho são eliminados automaticamente. Se as tabelas AsyncOperationBase e WorkflowLogBase já forem grandes devido a estes registos de fluxo de trabalho, deve efetuar uma limpeza destas tabelas utilizando o script de limpeza do Microsoft SQL Server que está incluído no seguinte artigo da Base do Conhecimento do Microsoft:

968520 O desempenho é lento se a tabela AsyncOperationBase se tornar demasiado grande no Microsoft Dynamics CRM 4.0

O problema foi corrigido?

  • Verifique se o problema foi corrigido. Se o problema estiver corrigido, terminou esta secção. Se o problema não estiver corrigido, pode contactar o suporte.

  • Agradecemos o seu feedback. Para fornecer feedback ou para relatar quaisquer problemas com esta solução, por favor deixe um comentário no blog "Fix it for me" ou envie-nos uma mensagem de e-mail.

Mais Informações

Para obter mais informações sobre a terminologia da atualização do software, clique no seguinte número de artigo para ver o artigo na Base de Conhecimento da Microsoft:

824684 Descrição da terminologia padrão que é usada para descrever atualizações de software da Microsoft Para obter mais informações sobre o hotfix de software CRM do Microsoft Business Solutions e a terminologia do pacote de atualização, clique no seguinte número de artigo para ver o artigo na Base de Conhecimento da Microsoft:

887283 Microsoft Business Solutions software HOTfix e atualizar pacote de padrões de nomeação

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