Sintomas
Considere o seguinte cenário:
-
Está a executar o Microsoft Outlook no modo online num ambiente do Office 365 ou 2016 de servidor do Exchange.
-
A codificação preferida para mensagens a enviar opção no Outlook está definida como Cirílico KOI8-R (as predefinições de codificação para a versão russa do Outlook).
-
Criar uma mensagem que contém alguns caracteres russos e, em seguida, guardá-lo como um rascunho.
Neste cenário, o corpo da mensagem é imperceptível depois de enviar este projecto. Pode ver que habitual apenas se pode definir o manualmente o conjunto de caracteres para esta mensagem Cirílico KOI8-R no Outlook.
Causa
Este problema ocorre porque o servidor do Exchange não actualiza o conjunto de caracteres na propriedade PR_BODY_HTML quando o carácter definido na propriedade PR_INTERNET_CPID é alterado no servidor. Por conseguinte, o corpo da mensagem é imperceptível quando o Outlook tenta apresentá-la.
Solução
Configurar o cliente Outlook para utilizar UTF-8 para a opção de codificação preferida para mensagens a enviar. Para tal, siga estes passos:
-
No Outlook, seleccione ficheiro de > opção > Avançadas.
-
Na secção Opções internacionais, defina a codificação preferida para mensagens a enviar de opção para UTF-8.
Resolução
Para corrigir este problema, instale 11 actualização cumulativa para o Exchange Server 2016 ou uma actualização cumulativa posterior de 2016 como servidor de Exchange.
Notas:
-
Antes de efectuar outras definições, deve certificar-se de que especifique as definições de registo seguintes no Editor de registo do Windows versão 5.00.
-
Existe um efeito de desempenho se esta chave de registo é utilizada. Assim, deve ser configurado para utilização apenas em ambientes onde a funcionalidade é necessária.
uma) acção: "Criar" b) o ramo de registo: "HKEY_LOCAL_MACHINE \" caminho da chave c):SOFTWARE\Microsoft\ExchangeServer\v15\Storage\ContentConversiond) nome do valor: AllowRestampCharsetOnInernetCPIDMismatch e) tipo de valor: REG_DWORD f) dados do valor de: 1 g) base: Hexadecimal
Além disso, é necessário criar manualmente a chave de "Storage" e a respectiva chave de sub "ContentConversion" se não conseguir localizá-los sob o caminho da chave.
Mais Informações
Para mais informações sobre conversão de conteúdos, consulte conversão de conteúdos. Para mais informações sobre a PidTagBodyHtmlcanónica propriedade, consulte propriedade canónica PidTagBodyHtml. Para mais informações sobre opções de codificação de mensagens, consulte Opções de codificação de mensagens.
Estado
A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".
Referências
Obter informações sobre a terminologia utilizada pela Microsoft para descrever actualizações de software.