Sintomas
Considere o seguinte cenário:
-
Está a executar o Microsoft System Center Configuration Manager 1511.
-
Pode criar um grande número de pacotes (por exemplo, várias centenas) e distribuí-los por muitos pontos de distribuição (por exemplo, milhares deles).
Quando o DistMgr processa ficheiros .pul dos pontos de distribuição (DPs) neste cenário, o DistMgr executa a seguinte consulta, que demora 3 a 4 segundos a ser executada quando existem muitas linhas na tabela PkgStatus:
select s.ID, s.PkgServer, s.SiteCode, p.StoredPkgVersion, s.Status, r.PkgVersion, r.ActionState, r.ActionData, p.PkgFlags, p.ShareType
from PullDPResponse r
join PkgStatus s on r.PkgStatusID = s.PKID AND r.PkgStatusID = PUL_ID
join SMSPackages p on s.ID = p.PkgID
Causa
Este problema ocorre porque a vista PkgStatus utiliza uma inserção ÉNULO e isto faz com que SQL efetue uma Análise de Índice em vez de uma Pesquisa de Índice.
Resolução
Depois de aplicar esta correção e de o DistMgr processar ficheiros .pul dos DPs pull, DistMgr executa a seguinte consulta, que tem cerca de 28 milissegundos para ser executada:
select s.ID, s.PkgServer, s.SiteCode, p.StoredPkgVersion, s.Status, r.PkgVersion, r.ActionState, r.ActionData, p.PkgFlags, p.ShareType
from PkgStatus2 s
join PullDPResponse r on r.PkgStatusID = s.PKID AND s.PKID = 72057594038363660
join SMSPackages p on s.ID = p.PkgID
Informações de hotfix
Está disponível uma hotfix suportada a partir Suporte da Microsoft. No entanto, esta correção destina-se a corrigir apenas o problema descrito neste artigo. Aplique esta solução apenas aos sistemas que estão com problemas descritos neste artigo. Esta atualização poderá receber testes adicionais. Portanto, se não for afetado gravemente por este problema, recomendamos que aguarde pela próxima atualização de software que contém esta atualização.
Se a hotfix estiver disponível para transferência, existe uma secção "Transferência de ficheiros hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta secção não aparecer, contacte o Suporte e Suporte ao Cliente da Microsoft para obter a hotfix.
Nota Se ocorrerem problemas adicionais ou se for necessária uma remoção de problemas, poderá ter de criar um pedido de serviço separado. Os custos habituais de suporte serão aplicados a perguntas e problemas de suporte adicionais que não são qualificáveis para esta hotfix específica. Para uma lista completa dos números de telefone do Suporte ao Cliente da Microsoft ou para criar um pedido de serviço separado, visite o seguinte Site da Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota: o formulário "Transferência de hotfix disponível" apresenta os idiomas para os quais a hotfix está disponível. Se não vir o seu idioma, significa que não está disponível uma hotfix para esse idioma.
Pré-requisitos
Para aplicar esta hotfix, tem de ter System Center Configuration Manager 1511 instalada.
Informações sobre reinício
Não tem de reiniciar o computador depois de aplicar esta hotfix.
Informações sobre substituição de correções
Esta hotfix não substitui nenhuma hotfix lançada anteriormente.
A versão inglesa desta correção tem os atributos de ficheiro listados na tabela que se segue (ou atributos de ficheiro posteriores). As datas e horas destes ficheiros estão listadas no formato de Hora Universal Coordenada (UTC). Quando visualizar as informações dos ficheiros, estas serão convertidas na hora local. Para encontrar a diferença entre UTC e a hora local, utilize o separador Zona Horário no item Data e Hora na Painel de Controlo.
Nome de ficheiro |
Versão de ficheiro |
Tamanho do ficheiro |
Data |
Hora |
Plataforma |
---|---|---|---|---|---|
Update.sql |
Não aplicável |
2,046 |
24-nov-2015 |
01:00 |
Não aplicável |
Estado
A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".
Referências
Saiba mais sobre a terminologia que a Microsoft utiliza para descrever atualizações de software.