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Recomendação actualizada

Depois de aplicar a correcção na secção "Resolução", o serviço de empresa único Sign-On (ENTSSO) tem uma fuga de memória. Por conseguinte, recomendamos que instale a correcção posterior .

Sintomas

Considere o seguinte cenário:

  • Instalou o componente de versão 5 de empresa único Sign-On (SSO) que é incluído no Microsoft BizTalk Server 2013 R2 ou Host Integration Server 2013.

  • Dos seguintes cenários, é possível restaurar a chave secreta principal de um ficheiro de cópia de segurança:

    • Quando estiver a configurar um cluster de empresa SSO

    • Durante a recuperação de desastres SSO de empresa

    • Quando está a promover um servidor de empresa SSO para o servidor de segredo mestre via satélite (MSS)

    • Durante a migração de uma versão anterior do Enterprise SSO

    • Durante uma actualização directa de uma versão anterior do Enterprise SSO

    • Quando estiver a executar várias empresa SSO V5 restauro e sequências de cópia de segurança

Depois de restaurar a chave secreta principal em qualquer um destes cenários, empresa SSO não é possível desencriptar os dados contidos na base de dados SSO de empresa. Nesta situação, a empresa SSO regista o seguinte evento no registo de aplicações:

ID do evento: 10536
Origem: ENTSSO
Nível: aviso
Função de auditoria de SSO: ID de rastreio de GetConfigInfo ({11111111-6055-4cda-89CD-389E8A2B1640}): computador de cliente b084f15b-43fd-474e-a075-398943753c91: nome (nome do executável: PID) do computador utilizador cliente: nome de utilizador nome de aplicação: nome da aplicação de código de erro: 0x80090005, dados incorrectos.

Além disso, poderá ser registado o seguinte erro de pop-up quando abrir o snap-in MMC de administração do BizTalk Server:

Administração do servidor de BizTalk
Dados inválidos.
(WinMgmt)
Botões:
OK

Causa

Empresa SSO V5 adiciona um carimbo de hora para a chave secreta principal para limitar o período de vida da chave. Além disso, foi adicionada uma marca de verificação para determinar se a chave secreta principal inclui um carimbo de hora. O problema descrito na secção "Sintomas" ocorre porque o serviço SSO empresa determina incorrectamente que o carimbo de hora está em falta quando é restaurada a chave secreta principal. Porque foi adicionado um carimbo de hora para a chave secreta principal restaurada, a chave restaurada não coincide com a chave que é utilizada para encriptar os dados na base de dados SSO de empresa. Por conseguinte, não não possível desencriptar os dados e, deste modo, activará as mensagens de erro descritos anteriormente.

Resolução

Informações sobre correção

Existe uma correção suportada pela Microsoft. No entanto, esta correção destina-se apenas a corrigir o problema descrito neste artigo. Para todos os sistemas de empresa SSO V5 para evitar este problema e para todos os sistemas que já tenham este problema, aplique esta correcção. Esta correcção necessita não existem acções adicionais para impedir e resolver o problema.

Se a correção está disponível para transferência, existe uma secção de "Transferência de Correção Disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta secção não for apresentado, submeta um pedido de suporte e serviço de cliente Microsoft para obter a correcção.

Nota Caso ocorram problemas adicionais ou se for necessária a resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos de normais do suporte serão aplicados a questões de suporte adicional e problemas incluídos nesta correção específica. Para uma lista completa dos números de telefone de suporte e serviço de cliente da Microsoft ou para criar um pedido de assistência separado, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=support

Nota O formulário "Transferência de correcção disponível" apresenta os idiomas nos quais a correcção está disponível. Se não visualizar o seu idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Para aplicar esta correcção, tem de ter empresa única sessão V5 (9.0.2096) instalado.

Informações sobre reinício

Poderá ter de reiniciar o computador depois de aplicar esta correção.

Informações de ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são listadas na hora Universal Coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador Fuso horário no item data e hora no painel de controlo.

versão de 32 bits (x86)

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Infocache.dll

9.0.2187.0

130,536

01-Oct-2014

22:00

x86

Microsoft.enterprisesinglesignon.systemmmc.dll

9.0.2187.0

198,632

01-Oct-2014

22:00

x86

Ssoss.dll

9.0.2187.0

113,128

01-Oct-2014

22:00

x86

versão de 64 bits (x64)

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Infocache.dll

9.0.2187.0

130,536

01-Oct-2014

22:00

x86

Microsoft.enterprisesinglesignon.systemmmc.dll

9.0.2187.0

198,632

01-Oct-2014

22:00

x86

Ssoss.dll

9.0.2187.0

113,128

01-Oct-2014

22:00

x86

Infocache.dll

9.0.2187.0

151,528

01-Oct-2014

22:00

x64

Microsoft.enterprisesinglesignon.systemmmc.dll

9.0.2187.0

198,632

01-Oct-2014

22:00

x86

Ssoss.dll

9.0.2187.0

124,392

01-Oct-2014

22:00

x64


Nota devido a um dependências de ficheiros, a correcção mais recente que contém estes ficheiros também poderão conter ficheiros adicionais.

Estado

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais informações

Pode aplicar esta actualização de qualquer servidor SSO da empresa que está com problemas sem necessidade de quaisquer alterações adicionais. Além disso, esta actualização deve ser aplicada a todos os sistemas de empresa SSO V5 para evitar o problema quando efectuar uma operação de restauro de chave secreta principal.

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