Iniciar sessão com a Microsoft
Iniciar sessão ou criar uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Selecione a conta com a qual pretende iniciar sessão.

Sintomas

Considere o seguinte cenário:

  • Tiver um documento de especificação XML para papel electrónico (XPS) que está alojado num Web site.

  • O Web site está configurado para utilizar a autenticação base ou autenticação por formulários com um cookie de sessão.

  • Execute XPSViewer.exe para aceder ao documento XPS num computador que esteja a executar o .NET Framework 3.5 Service Pack 1 (SP1).

Neste cenário, XPSViewer.exe falha. Além disso, recebe a seguinte mensagem de erro:

XPSViewer.exe encontrou um problema e vai ser encerrado. Lamentamos qualquer incómodo.

Causa

Este problema ocorre devido a um erro em XPSViewer.exe. Este erro faz com que o erro ocorre quando o Visualizador XPS pede-lhe para introduzir uma credencial de utilizador.

Resolução

Informações sobre correção

Existe uma correção suportada pela Microsoft. No entanto, esta correção destina-se apenas a corrigir o problema descrito neste artigo. Aplique esta correção apenas em sistemas que tenham o problema descrito neste artigo. Esta correcção poderá ser submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afetado por este problema, recomendamos que aguarde pela próxima atualização de software que contenha esta correção.

Se a correcção estiver disponível para transferência, existirá uma secção de "Transferência de correcção disponível" na parte superior deste artigo da Base de dados de conhecimento. Se esta secção não for apresentada, contacte o Suporte ao Cliente da Microsoft para obter a correção.

Nota Caso ocorram problemas adicionais ou se for necessária a resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos de normais do suporte serão aplicados a questões de suporte adicional e problemas incluídos nesta correção específica. Para uma lista completa dos números de telefone de suporte e serviço de cliente da Microsoft ou para criar um pedido de assistência separado, visite o seguinte Web site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota O formulário "Transferência de correcção disponível" apresenta os idiomas nos quais a correcção está disponível. Se não visualizar o seu idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Tem de ter o .NET Framework 3.5 SP1 instalado para aplicar esta correcção.

Requisito de reinício

Não é necessário reiniciar o computador depois de aplicar esta correcção se nenhuma instância do .NET Framework está a ser utilizada.

Informações sobre substituição da correção

Esta correcção não substitui outras correcções.

Informações de ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são listadas na hora Universal Coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador Fuso horário no item data e hora no painel de controlo.

Para todas as versões baseadas em x86 do Windows Server 2000, Windows Server 2003 e Windows XP

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Xpsviewer.exe

3.0.6920.4008

298,304

25-Sep-2009

01:54

x86


Solução alternativa

Para contornar este problema, utilize um dos seguintes métodos:

  • Não utilize a autenticação para o Web site.

  • Utilize a autenticação integrada do Windows, tais como a autenticação NTLM ou autenticação Kerberos. Certifique-se de que o documento pode ser acedido sem credenciais de utilizador. Por exemplo, os Web sites numa zona da intranet ou de sites fidedignos podem ser acedidos sem credenciais de utilizador.

  • Utilize a autenticação de formulários juntamente com um cookie persistente.

  • Utilize o Microsoft XPS Viewer Essentials Pack (programa Alargado) em vez de XPSViewer.exe para abrir o documento.

Estado

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais informações

Para obter o Microsoft XPS Essentials Pack, visite o seguinte site da Web do Centro de transferência Microsoft:

http://www.microsoft.com/downloads/details.aspx?FamilyId=B8DCFFDD-E3A5-44CC-8021-7649FD37FFEE

Precisa de mais ajuda?

Quer mais opções?

Explore os benefícios da subscrição, navegue em cursos de formação, saiba como proteger o seu dispositivo e muito mais.

As comunidades ajudam-no a colocar e a responder perguntas, a dar feedback e a ouvir especialistas com conhecimentos abrangentes.

Estas informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?
Ao selecionar submeter, o seu feedback será utilizado para melhorar os produtos e serviços da Microsoft. O seu administrador de TI poderá recolher estes dados. Declaração de Privacidade.

Obrigado pelo seu feedback!

×