Sintomas
Um dispositivo de Thunderbolt poderá deixar de funcionar correctamente no Windows 10 nos seguintes cenários:
o cenário 1: Quando rápida e repetidamente inserir e remover um dispositivo de Thunderbolt, a porta de Thunderbolt poderá deixar de responder. Depois da porta de Thunderbolt neste estado, já não reconhece qualquer dispositivo ligado.
Cenário 2: Quando dois dispositivos de Thunderbolt se trocar enquanto o PC está num Estado de hibernação, os dispositivos ligados do Thunderbolt poderão não funcionar correctamente depois do computador retoma do modo de hibernação. O Gestor de dispositivos indica que os dispositivos não estão a funcionar com um ponto de exclamação amarelo e o código de erro 31.
Causa
o cenário 1: Este problema ocorre porque o controlador de Thunderbolt não está acessível no momento que o controlador tenta aceder a ele.
Cenário 2: Este cenário pode resultar em portas de Thunderbolt incorrectamente configuradas.
Resolução
Para resolver estes problemas, desligue todos os dispositivos ligados às portas Thunderbolt, aguarde 5 segundos e, em seguida, volte a ligar os dispositivos.
Cenário 2 é resolvido na actualização de criadores de diminuição de 10 Windows (versão 1709). Para verificar que instalou as actualizações mais recentes do Windows, Seleccione Iniciar botão, em seguida, seleccione Definições > actualização & segurança > Windows Update . Em seguida, seleccione verificar se existem actualizações.