Applies ToDynamics NAV 2009

ARTIGOS DE PUBLICAÇÃO RÁPIDA FORNECEM INFORMAÇÕES DIRETAMENTE A PARTIR DA ORGANIZAÇÃO DE SUPORTE DA MICROSOFT. AS INFORMAÇÕES CONTIDAS NESTE DOCUMENTO SÃO CRIADAS EM RESPOSTA A EMERGENTES OU EXCLUSIVO TÓPICOS, OU SE DESTINE A COMPLEMENTAR OUTRAS INFORMAÇÕES DE BASE DE DADOS DE CONHECIMENTO.

Este artigo aplica-se para o Microsoft Dynamics NAV para todos os países e todos os idiomas.

Sintomas

Quando imprime relatórios classic a partir do cliente Perfil personalizado (RTC) no Microsoft Dynamics NAV 2009 Service Pack 1 em rápida sucessão, recebe a seguinte mensagem de erro:

Não é possível utilizar o ficheiro zup porque já está em utilização.

Nota Os relatórios ainda são impressos.

Causa

Este problema ocorre porque os relatórios clássicos não tem um esquema de Visual Studio. O Microsoft Dynamics NAV utiliza o motor de relatório do cliente classic, para imprimir estes relatórios. Este problema ocorre quando o Microsoft Dynamics NAV abre e fecha-se o motor de relatório clássico em rápida sucessão. Quando fechar o Microsoft Dynamics NAV classic client, o arquivo zup é actualizado. Por conseguinte, se um motor de relatórios clássico tentar fechar antes do motor de relatório anterior estiver concluído, este problema ocorre.

Resolução

Informações sobre correção

Existe uma correção suportada pela Microsoft. Existe uma secção de "Transferência de correcção disponível" na parte superior deste artigo da Base de dados de conhecimento. Se encontrar um problema a transferir, instalar esta correcção, ou se tiver outras questões de suporte técnico, contacte o seu parceiro ou, se inscrito num plano de suporte directamente com a Microsoft, pode contactar o suporte técnico para o Microsoft Dynamics e criar um novo pedido de suporte. Para tal, visite o seguinte Web site da Microsoft:

https://mbs.microsoft.com/support/newstart.aspxTambém pode contactar o suporte técnico para o Microsoft Dynamics por telefone utilizar estas hiperligações para números de telefone específicos do país. Para tal, visite um dos seguintes Web sites da Microsoft:Parceiros

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+ContactsClientes

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmEm casos especiais, os custos normalmente inerentes para suporte chamadas poderão ser anuladas se um técnico de suporte técnico do Microsoft Dynamics e produtos relacionados determina que uma actualização específica resolverá o problema. Os custos normais do suporte serão aplicada a quaisquer questões de suporte adicionais e problemas que não se enquadrem na atualização específica em questão.

Como obter o hotfix do Microsoft Dynamics NAV ou actualizar ficheiros

Após solicitar um hotfix do Microsoft Dynamics NAV, será enviada para si uma hiperligação na mensagem de correio electrónico.Mensagem de correio electrónico conterá uma hiperligação e uma palavra-passe. Pode utilizar a hiperligação para transferir a correcção do Microsoft Dynamics NAV ou os ficheiros de actualização. Quando clica na hiperligação, abre a caixa de diálogo Transferência de ficheiros – Aviso de segurança . Em seguida, lhe for pedido para executar, guardar ou cancelar a transferência.Se clicar em Executar, os ficheiros de iniciar a transferência e o processo de extracção. Tem de especificar uma pasta para os novos ficheiros e, em seguida, forneça a palavra-passe.Se clicar em Guardar, tem de especificar um caminho para guardar o ficheiro comprimido. Quando abre o ficheiro que guardou, lhe for pedido para especificar um caminho para os ficheiros. Em seguida, tem de fornecer a palavra-passe fornecida na mensagem de correio electrónico.Se clicar em Cancelar, pára o processo de transferência.

Como instalar um hotfix do Microsoft Dynamics NAV ou um ficheiro de actualização

As actualizações e correcções de plataforma do Microsoft Dynamics NAV ficam disponíveis como ficheiros único. Para instalar um hotfix do Microsoft Dynamics NAV ou uma actualização, tem de substituir os ficheiros de instalação existentes do Microsoft Dynamics NAV com a correcção ou os ficheiros de actualização. Para tal, siga estes passos.

Passo 1: Substituir os ficheiros na instalação do cliente Microsoft Dynamics NAV Classic

A instalação de cliente do Microsoft Dynamics NAV Classic, substitua os seguintes ficheiros utilizando a correcção ou o ficheiro de actualização.

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Dbm.dll

6.0.30677.0

427,848

24-Feb-2010

15:16

x86

Fin.exe

6.0.30677.0

12,597,064

24-Feb-2010

15:17

x86

Finhlink.exe

6.0.30677.0

452,432

24-Feb-2010

15:17

x86

Finsql.exe

6.0.30677.0

12,718,928

24-Feb-2010

15:17

x86

Nc_netb.dll

6.0.30677.0

96,592

24-Feb-2010

15:16

x86

Nc_tcp.dll

6.0.30677.0

98,640

24-Feb-2010

15:16

x86

Nc_tcps.dll

6.0.30677.0

141,136

24-Feb-2010

15:16

x86

Ndbcs.dll

6.0.30677.0

1,348,944

24-Feb-2010

15:16

x86

Slave.exe

6.0.30677.0

152,400

24-Feb-2010

15:16

x86

Para substituir os ficheiros existentes do Microsoft Dynamics NAV, siga estes passos:

  1. Feche o Microsoft Dynamics NAV Classic Client.

  2. Localize o directório de instalação de cliente do Microsoft Dynamics NAV Classic. O cliente do Microsoft Dynamics NAV Classic é normalmente instalado no seguinte directório:

    C:\Program Files\Microsoft Dynamics NAV\60\Classic

  3. Copie os ficheiros que transferiu.

  4. Cole os ficheiros que transferiu para o directório de instalação de cliente do Microsoft Dynamics NAV Classic.

  5. Clique em Sim para substituir os ficheiros no directório.

Passo 2: Substituir os ficheiros na instalação de cliente Perfil Personalizado do Microsoft Dynamics NAV

A instalação do cliente Perfil Personalizado do Microsoft Dynamics NAV, substitua os seguintes ficheiros utilizando a correcção ou o ficheiro de actualização.

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Microsoft.dynamics.framework.patterns.dll

1.3.10803.137

71,656

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.dll

1.3.10803.137

698,328

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.mapping.dll

1.3.10803.137

104,424

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.navigation.dll

1.3.10803.137

34,800

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.ux2006.dll

1.3.10803.137

88,040

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.ux2006.winforms.dll

1.3.10803.137

63,480

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.windows.dll

1.3.10803.137

83,944

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.winforms.controls.dll

1.3.10803.137

2,111,488

24-Feb-2010

06:30

x86

Microsoft.dynamics.framework.ui.winforms.dll

1.3.10803.137

690,152

24-Feb-2010

06:30

x86

Microsoft.dynamics.nav.client.builder.dll

6.0.30677.0

198,544

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.client.exe

6.0.30677.0

149,376

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.client.interop.communicator.dll

1.0.559.183

75,688

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.client.serviceconnection.dll

6.0.30677.0

104,352

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.client.ui.dll

6.0.30677.0

505,728

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.client.winforms.dll

6.0.30677.0

337,808

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.client.winforms.tlb

Não aplicável

2,644

24-Feb-2010

12:05

Não aplicável

Microsoft.dynamics.nav.language.dll

6.0.30677.0

1,992,576

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.types.dll

6.0.30677.0

567,160

24-Feb-2010

15:06

x86

Microsoft.office.interop.outlook.dll

10.0.4504.0

395,136

24-Feb-2010

15:17

x86

Para substituir estes ficheiros, siga estes passos:

  1. Feche o cliente Perfil Personalizado do Microsoft Dynamics NAV.

  2. Localize o directório de instalação do cliente Perfil Personalizado do Microsoft Dynamics NAV. O cliente Perfil Personalizado do Microsoft Dynamics NAV é normalmente instalado no seguinte directório:

    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored cliente

  3. Copie os ficheiros que transferiu.

  4. Cole os ficheiros que transferiu o directório de instalação do cliente Perfil Personalizado do Microsoft Dynamics NAV.

  5. Clique em Sim para substituir os ficheiros no directório.

Passo 3: Substituir os ficheiros na instalação do Microsoft Dynamics NAV Server

A instalação do Microsoft Dynamics NAV Server, substitua os seguintes ficheiros utilizando a correcção ou o ficheiro de actualização.

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Httpcfg.exe

5.2.3790.0

22,352

24-Feb-2010

15:17

x86

Microsoft.dynamics.nav.language.dll

6.0.30677.0

1,992,576

24-Feb-2010

15:06

x86

Microsoft.dynamics.nav.ncl.dll

6.0.30677.0

608,120

24-Feb-2010

15:06

x86

Microsoft.dynamics.nav.server.exe

6.0.30677.0

141,184

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.service.dll

6.0.30677.0

145,280

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.service.runtime.dll

6.0.30677.0

75,664

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.service.webservices.dll

6.0.30677.0

145,304

24-Feb-2010

15:05

x86

Microsoft.dynamics.nav.types.dll

6.0.30677.0

567,160

24-Feb-2010

15:06

x86

Microsoft.dynamics.nav.watson.dll

6.0.30677.0

42,880

24-Feb-2010

15:05

x86

Nclcsrt.etx

Não aplicável

89,525

24-Feb-2010

08:28

Não aplicável

Nclcsrt.stx

Não aplicável

91,724

24-Feb-2010

08:28

Não aplicável

Nclcsrts.dll

6.0.30677.0

1,473,872

24-Feb-2010

15:17

x86

Ndbcs.dll

6.0.30677.0

1,348,944

24-Feb-2010

15:17

x86

Para substituir estes ficheiros, siga estes passos:

  1. Pare de o Microsoft Dynamics NAV Server.

  2. Localize o directório de instalação do Microsoft Dynamics NAV Server. O Microsoft Dynamics NAV Server é normalmente instalado no seguinte directório:

    C:\Program Files\Microsoft Dynamics NAV\60\Service

  3. Copie os ficheiros que transferiu.

  4. Cole os ficheiros que transferiu para o directório de instalação do Microsoft Dynamics NAV Server.

  5. Clique em Sim para substituir os ficheiros no directório.

  6. Inicie de Microsoft Dynamics NAV Server.

Passo 4: Substituir os ficheiros na instalação do Microsoft Dynamics NAV Application Server

Se tiver o Microsoft Dynamics NAV Application Server instalada, substitua os seguintes ficheiros na instalação do Microsoft Dynamics NAV Application Server utilizando o hotfix ou os ficheiros de actualização.

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Dbm.dll

6.0.30677.0

427,848

24-Feb-2010

15:16

x86

Nas.exe

6.0.30677.0

2,259,784

24-Feb-2010

15:17

x86

Nassql.exe

6.0.30677.0

2,358,096

24-Feb-2010

15:17

x86

Ndbcs.dll

6.0.30677.0

1,348,944

24-Feb-2010

15:16

x86

Slave.exe

6.0.30677.0

152,400

24-Feb-2010

15:16

x86

Para substituir os ficheiros, siga estes passos.

  1. Pare o Microsoft Dynamics NAV Application Server.

  2. Localize o directório de instalação do Microsoft Dynamics NAV Application Server. O Microsoft Dynamics NAV Application Server é normalmente instalado no seguinte directório:

    C:\Program Files\Microsoft Dynamics NAV\60\Application servidor

  3. Copie os ficheiros que transferiu.

  4. Cole os ficheiros que transferiu para o directório de instalação do Microsoft Dynamics NAV Application Server.

  5. Clique em Sim para substituir os ficheiros no directório.

  6. Inicie o Microsoft Dynamics NAV Application Server.

Depois de aplicar esta correcção, o RTC primeiro irá tentar fechar o motor de relatório. Se o motor de relatório não pode ser fechado, o RTC irá aguardar um segundo e tente novamente até 30 horas.

Pré-requisitos

Tem de ter o Microsoft Dynamics NAV 2009 Service Pack 1 instalado para aplicar esta correcção.

Estado

A Microsoft confirmou que este é um erro nos produtos da Microsoft listados na secção "Aplica-se a".

Mais informações

Para mais informações, clique no número de artigo seguinte para visualizar o artigo na Base de Dados de Conhecimento Microsoft

824684 descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

MICROSOFT E/OU OS SEUS FORNECEDORES FAZEM NENHUMA AFIRMAÇÃO NEM GARANTIAS SOBRE A ADEQUAÇÃO, FIABILIDADE OU A EXACTIDÃO DAS INFORMAÇÕES CONTIDAS NOS DOCUMENTOS E OS GRÁFICOS RELACIONADOS PUBLICADOS NESTE WEB SITE (OS "MATERIAIS") PARA QUALQUER FINALIDADE.OS MATERIAIS PODERÃO INCLUIR IMPRECISÕES TÉCNICAS OU ERROS TIPOGRÁFICOS E PODEM SER REVISTOS EM QUALQUER ALTURA SEM AVISO PRÉVIO. PARA A EXTENSÃO MÁXIMA PERMITIDA PELA LEI APLICÁVEL, MICROSOFT E/OU OS SEUS FORNECEDORES ISENTAM EM EXCLUEM TODAS AS REPRESENTAÇÕES, GARANTIAS E CONDIÇÕES, QUER EXPRESSAS, IMPLÍCITAS OU LEGAIS, INCLUINDO MAS NÃO LIMITADO REPRESENTAÇÕES, GARANTIAS OU CONDIÇÕES DE TÍTULO, A CONDIÇÃO DE NÃO INFRACÇÃO, SATISFATÓRIA OU QUALIDADE, COMERCIALIZAÇÃO E ADEQUAÇÃO A UM FIM ESPECÍFICO, NO QUE RESPEITA AOS MATERIAIS.

Precisa de mais ajuda?

Quer mais opções?

Explore os benefícios da subscrição, navegue em cursos de formação, saiba como proteger o seu dispositivo e muito mais.

As comunidades ajudam-no a colocar e a responder perguntas, a dar feedback e a ouvir especialistas com conhecimentos abrangentes.