Mensagem de erro quando instala um pacote de actualização. msu num computador com o Windows: "O Instalador de Módulos do Windows deve ser atualizado antes de poder instalar este pacote"

Sintomas

Quando instala um pacote de actualização. msu num computador com o Windows, poderá receber a seguinte mensagem de erro:

O instalador de Módulos do Windows tem de ser atualizado antes de poder instalar este pacote. Actualizar o instalador de módulos do Windows no computador, em seguida, tente novamente o programa de configuração.

Quando utilizar um script para instalar o pacote de actualizações. msu, a instalação falha. Quando este problema ocorre, o processo de Wusa.exe devolve o código de erro 0x800f0823.

Causa

Este problema ocorre porque a instalação requer uma nova versão do instalador de módulos do Windows ou pilha de manutenção.

Resolução

Para resolver este problema, utilize o Windows Update para actualizar o instalador de módulos do Windows ou pilha de manutenção. Ou, transfira as actualizações que estão listadas na seguinte tabela do Microsoft Download Center.

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft insiders

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×