Sintomas
Tem um computador baseado no Windows Server 2008 ou Windows Server 2003 R2 com Microsoft Services para o sistema de ficheiros de rede (MSNFS) instalado e que as exportações partilhas NFS para clientes do NFS. Quando os pedidos de e/s excessivos gerados pelos clientes NFS em partilhas NFS, poderá detectar os seguintes problemas:
-
Se utilizar a captura de rede, poderá encontrar-se de que o tamanho da janela para uma ligação de TCP é reduzido para 0, o que é designado por uma condição de TCPZeroWindow.
-
Se tentar aceder as partilhas NFS, pode encontrar erros de e/s para a ligação correspondente que é semelhante ao seguinte:
Erro de entrada/saída
-
A ligação de NFS não reiniciar como é esperado. Eventualmente, todas as ligações de NFS para o servidor de ir para o mesmo Estado.
Causa
Este problema ocorre porque o controlador de representação de dados externos de chamada (RPC) de procedimento remoto (Rpcxdr.sys) não consegue reiniciar fiavelmente ligações TCP quando existem muitos pedidos de e/s.
Resolução
Informações sobre a correcção para Windows Server 2003
Existe uma correção suportada pela Microsoft. No entanto, esta correção destina-se apenas a corrigir o problema descrito neste artigo. Aplique esta correção apenas em sistemas que tenham o problema descrito neste artigo. Esta correcção poderá ser submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afetado por este problema, recomendamos que aguarde pela próxima atualização de software que contenha esta correção.
Se a correcção estiver disponível para transferência, existirá uma secção de "Transferência de correcção disponível" na parte superior deste artigo da Base de dados de conhecimento. Se esta secção não for apresentada, contacte o Suporte ao Cliente da Microsoft para obter a correção. Nota Caso ocorram problemas adicionais ou se for necessária a resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos de normais do suporte serão aplicados a questões de suporte adicional e problemas incluídos nesta correção específica. Para uma lista completa dos números de telefone de suporte e serviço de cliente da Microsoft ou para criar um pedido de assistência separado, visite o seguinte Web site da Microsoft:Nota O formulário "Transferência de correcção disponível" apresenta os idiomas nos quais a correcção está disponível. Se não visualizar o seu idioma, é porque uma correcção não está disponível para esse idioma.
Pré-requisitos
Não tem pré-requisitos.
Requisito de reinício
Não é necessário reiniciar o computador depois de aplicar esta correcção.
Informações sobre substituição da correção
Esta correcção não substitui quaisquer outras correcções disponibilizadas anteriormente.
Informações de registo
Para utilizar esta correcção, não é necessário efectuar alterações ao registo.
Informações de ficheiro
A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são listadas na hora Universal Coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador Fuso horário no item data e hora no painel de controlo.