Sintomas
Depois de instalar uma atualização para o Microsoft Exchange Server 2019, poderá obter resultados incompletos ao procurar itens numa caixa de correio.
Causa
Durante cada Exchange Server atualização, a Microsoft Search Foundation é reinstalada. Embora este processo nem sempre seja concluído com êxito, tal falha não impede que a atualização Exchange Server seja concluída.
Nesta situação, o servidor atualizado parece estar totalmente funcional. No entanto, vários problemas afetarão os serviços associados ao Microsoft Search Foundation. Por exemplo, o Serviço de pesquisa do Microsoft Exchange está desativado ou o processo de Noderunner.exe é interrompido. Devido a estes problemas, o servidor que está a executar Exchange Server deixa de indexar itens de caixa de correio. Se a falha de indexação continuar por um período prolongado, os itens da caixa de correio que não estão indexados entrarão num estado de falha permanente.
A qualquer momento após os itens entrarem neste estado de falha, se os problemas que afetam os processos de pesquisa forem corrigidos, o servidor retomará a indexação de itens. No entanto, por predefinição, o servidor não tentará indexar os itens que entraram num estado de falha permanente. Por conseguinte, esses itens não serão apresentados nos resultados da pesquisa.
Resolução
Para resolver este problema, crie uma nova substituição para os itens que estão num estado de falha permanente e, em seguida, reindexe os itens. Siga estes passos:
-
Crie uma substituição de definição ao executar o seguinte cmdlet:New-SettingOverride -Name "Big Funnel Permanent Retry" -Component "BigFunnel" -Section "BigFunnelFailedItemsQuerySettings" -Parameters @("ExcludePermanentFailures=false") -Reason "Re-Index Messages" -MinVersion "<Build Number>" -MaxVersion "<Build Number>"Nota Neste cmdlet, substitua <Número de Compilação> pelo número da compilação Exchange Server que está a ser executada no servidor que contém a caixa de correio afetada.
-
Atualize a configuração ao executar o seguinte cmdlet:Get-ExchangeDiagnosticInfo -Process Microsoft.Exchange.Directory.TopologyService -Component VariantConfiguration -Argument Refresh Depois de executar este cmdlet, deverá ver o ficheiro BigFunnel.Overrides.ini no diretório %ExchangeInstallPath%\v15\config.
-
Acionar Exchange Server para indexar os itens da caixa de correio que não foram indexados anteriormente. Para tal, execute o seguinte cmdlet:Start-MailboxAssistant -Identity <mailbox ID> -AssistantName BigFunnelRetryFeederTimeBasedAssistant
Notas:
-
Neste cmdlet, substitua <ID da caixa de correio> pelo nome da caixa de correio afetada.
-
O nome do assistente utilizado no cmdlet (BigFunnelRetryFeederTimeBasedAssistant) é sensível às maiúsculas e minúsculas.
-
O cmdlet está disponível no Exchange Server atualização cumulativa 11 e versões posteriores de 2019.
Este cmdlet não resolve todos os problemas relacionados com o índice. Em vez disso, lembra a Serviço de pesquisa do Exchange para indexar itens que nunca foram indexados e que estão no estado NãoExed.
-
Nota: A substituição da definição ajuda-o a evitar ter de mover caixas de correio para reindexar itens. No entanto, recomendamos que não deixe a substituição definida no ambiente permanentemente porque pode causar um aumento da utilização da CPU. Após a reindexação dos itens, remova a substituição com o cmdlet Remove-SettingOverride .