Sintomas
Após instalar uma atualização para o Microsoft Exchange Server 2019, poderá obter resultados incompletos quando procurar itens numa caixa de correio.
Causa
Durante cada Exchange Server de atualização, a Microsoft Pesquisa Foundation é reinstalada. Embora este processo nem sempre seja concluído com êxito, tal falha não impede que a atualização Exchange Server seja concluída.
Nesta situação, o servidor atualizado parece estar totalmente funcional. No entanto, vários problemas irão afetar os serviços associados à Microsoft Pesquisa Foundation. Por exemplo, o serviço Microsoft Exchange Pesquisa está desativado ou o Noderunner.exe de pesquisa é interrompido. Devido a estes problemas, o servidor que está a executar o Exchange Server a indexação de itens de caixa de correio. Se a falha de indexação continuar durante um período prolongado, os itens da caixa de correio que não são indexados entrarão em estado de falha permanente.
A qualquer momento após os itens entrarem neste estado de falha, se os problemas que afetam os processos de pesquisa estiverem corrigidos, o servidor retomará os itens de indexação. No entanto, por predefinição, o servidor não tentará indexar os itens que entraram num estado de falha permanente. Por essa razão, esses itens não serão apresentados nos resultados da pesquisa.
Resolução
Para resolver este problema, crie uma nova autorização para os itens que estão num estado de falha permanente e, em seguida, reindexe os itens. Siga estes passos:
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Crie uma substituição de definição ao executar o seguinte cmdlet:New-SettingOverride -Name "Big Funnel Permanent Retry" -Component "BigFunnel" -Section "BigFunnelFailedItemsQuerySettings" -Parameters @("ExcludePermanentFailures=false") -Reason "Re-Index Messages" -MinVersion "<Build Number>" -MaxVersion "<Build Number>"Nota Neste cmdlet, substitua um <Número de Compor> pelo número da compor do Exchange Server que está a ser executada no servidor que contém <caixa de correio afetada.
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Atualize a configuração executando o seguinte cmdlet:Get-ExchangeDiagnosticInfo -Process Microsoft.Exchange.Directory.TopologyService -Component VariantConfiguration -Argument Refresh Após executar este cmdlet, deverá ver o BigFunnel.Overrides.ini no diretório %ExchangeInstallPath%\v15\config.
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Aciona Exchange Server para indexar os itens da caixa de correio que não foram indexados anteriormente. Para fazê-lo, execute o seguinte cmdlet:Start-MailboxAssistant -Identity <mailbox ID> -AssistantName BigFunnelRetryFeederTimeBasedAssistant
Notas:
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Neste cmdlet, substitua o ID <caixa de correio> pelo nome da caixa de correio afetada.
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O nome do assistente utilizado no cmdlet (BigFunnelRetryFeederTimeBasedAssistant) é sensível às caixas.
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O cmdlet está disponível na atualização cumulativa 11 e versões posteriores Exchange Server cumulativa de 2019.
Este cmdlet não aborda todos os problemas relacionados com índices. Em vez disso, relembra Exchange serviço de Pesquisa para indexar itens que nunca foram indexados e que estão no estado Não Indexado.
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Nota: A override de definições ajuda-o a evitar ter de mover caixas de correio para reindexar itens. No entanto, recomendamos que não deixe o conjunto de permanências no ambiente permanentemente, uma vez que pode aumentar a utilização da CPU. Depois de os itens voltarem a ser reinexados, remova a override ao utilizar o cmdlet Remove-SettingOverride .