Software antivírus baseado no VSAPI faz com que a resposta retardada num ambiente do Exchange Server 2010

Sintomas

Considere o seguinte cenário:

  • Utilizar software baseado no Microsoft Exchange Virus Scanning API VSAPI num ambiente Microsoft Exchange Server 2010.

  • Caixa de correio de um utilizador que está protegida pelo software antivírus contém várias mensagens.

  • O utilizador efectua uma determinada operação na caixa de correio para ligar a um servidor de correio. Por exemplo, o utilizador activa a funcionalidade de pré-visualização automática para ver várias mensagens, utilizando o Microsoft Outlook no modo online.

Neste cenário, existe uma longo atrasada resposta do servidor da caixa de correio. Além disso, este problema poderá impedir que novos clientes liguem ao servidor do Exchange, ou poderá accionar uma activação pós-falha de bases de dados para servidores em modo inactivo.

Causa

Este problema ocorre porque a operação que o utilizador efectuado acciona uma promoção de propriedades que activa pedidos para cada item de mensagem de detecção de vírus. Quando existem muitos itens o fila de detecção de vírus, todas as ligações de chamada (RPC) de procedimento remoto para o servidor de correio estão esgotadas como novos clientes, aguarde o conclusão da operação de detecção de vírus. Por conseguinte, o servidor de correio não é possível responder a quaisquer pedidos RPC. Em seguida, monitorização detecta que o Exchange server não está a responder e inicia uma activação pós-falha.

Resolução

Para resolver este problema, instale o update rollup seguinte:

Descrição de do conjunto de actualizações 1 para o Exchange Server 2010 Service Pack 3

Estado

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais informações

Para mais informações sobre como activar a funcionalidade pré-visualização automática, consulte o seguinte Web site da Microsoft:

Para mais informações sobre a promoção de propriedades, consulte o seguinte Web site da Microsoft:

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft insiders

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×