Войти с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Select a different account.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой вы хотите войти.

С помощью OLE можно включать контент из других программ, таких как Word или Excel.

OLE поддерживается многими различными программами, а OLE используется для того, чтобы содержимое, созданное в одной программе, было доступно в другой программе. Например, можно вставить документ Office Word в книгу Office Excel. Чтобы узнать, какие типы содержимого можно вставить, на вкладке Вставка в группе Текст нажмитекнопку Объект. В поле Тип объекта отображаются только программы, которые установлены на компьютере и поддерживают объекты OLE.

При копировании данных между Excel или любой программой, которая поддерживает OLE, например Word, вы можете скопировать их как связанный объект или внедренный объект. Основные различия между связанными и внедренными объектами заключается в том, где хранятся данные и как обновляется объект после его конечный файл. Внедренные объекты хранятся в книге, в которую они вставляются, и не обновляются. Связанные объекты остаются отдельными файлами, и их можно обновлять.

Связанные и внедренные объекты в документе

Связанные и внедренные объекты в документе Office для Windows

1. Внедренный объект не имеет подключения к исходным файлам.

2. Связанный объект связан с исходным файлом.

3. Исходный файл обновляет связанный объект.

Когда использовать связанные объекты

Если вы хотите, чтобы данные в конечный файл обновлялись при исходный файл изменения, используйте связанные объекты.

При связываемом объекте исходные данные сохраняются в исходном файле. В конечном файле отображается представление связанных данных, но хранится только расположение исходных данных (и размер, если объект является объектом диаграммы Excel). Исходный файл должен оставаться доступным на компьютере или в сети, чтобы сохранить связь с исходными данными.

Связанные данные могут обновляться автоматически при изменении исходных данных в исходном файле. Например, если вы вы выбрали абзац в документе Word, а затем вклеили его как связанный объект в книгу Excel, то при изменении сведений в документе Word сведения могут обновляться в Excel.

Когда использовать внедренные объекты

Если вы не хотите обновлять скопированные данные при их внесении в исходный файл, используйте внедренный объект. Версия источника полностью внедрена в книгу. При копировании данных как внедренных объектов в файле назначения требуется больше места на диске, чем при связываи.

Когда пользователь открывает файл на другом компьютере, он может просмотреть внедренный объект, не имея доступа к исходным данным. Поскольку внедренный объект не имеет ссылок на исходный файл, он не обновляется при изменении исходных данных. Чтобы изменить внедренный объект, дважды щелкните его, чтобы открыть и изменить в программе-источнике. На компьютере должна быть установлена программа-источник (или другая программа, которая может редактировать объект).

Изменение способа отображения объекта OLE

Вы можете отобразить связанный объект или внедренный объект в книге точно так же, как в программа-источник или в качестве значка. Если книга будет просмотрена в Интернете и вы не собираетесь ее печатать, вы можете отобразить объект в виде значка. Таким образом уменьшается объем отображаемого пространства, занимаемого объектом. Пользователи, которые хотят отобразить сведения, могут дважды щелкнуть значок.

Внедрение объекта на лист

  1. Щелкните ячейку листа, в которую вы хотите вставить объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект Значок объекта на ленте.
    Вставка объекта

  3. В диалоговом окне Объект перейдите на вкладку Создание из файла.

  4. Нажмите кнопку Обзор и выберите файл, который вы хотите вставить.

  5. Если вы хотите вставить в электронную таблицу значок, а не содержимое файла, установите флажок В виде значка. Если флажки не установлены, Excel выводит первую страницу файла. В обоих случаях при двойном щелчке открывается полный файл. Нажмите кнопку ОК.

    Примечание: После добавления значка или файла его можно перетащить в любое место на нем. Кроме того, вы можете с помощью химок и химок переумноовать значок или файл. Чтобы найти их, щелкните файл или значок один раз.

Вставка ссылки на файл

Иногда нужно просто добавить ссылку на объект, а не внедрять его. Это можно сделать, если книга и объект, который вы хотите добавить, хранятся на сайте SharePoint, общем сетевом диске или в аналогичном постоянном расположении. Это удобно, если связанный объект изменяется, так как ссылка всегда будет открывать его последнюю версию.

Примечание: Если связанный файл переместить, ссылка не будет работать.

  1. Щелкните ячейку листа, в которую вы хотите вставить объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект Значок объекта на ленте.
    Вставка объекта

  3. Перейдите на вкладку Создание из файла.

  4. Нажмите кнопку Обзор, а затем выберите файл, на который вы хотите создать ссылку.

  5. Установите флажок Связь с файлом, а затем нажмите кнопку ОК.

Создание объекта в Excel

Вы можете создать объект с помощью другой программы, не выходя из книги. Например, если вы хотите добавить более подробное описание в диаграмму или таблицу, вы можете создать в Excel внедренный документ, например Word или PowerPoint. Можно вставить объект непосредственно на лист или добавить значок для открытия файла.

Внедренный объект является документом Word.
  1. Щелкните ячейку листа, в которую вы хотите вставить объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект Значок объекта на ленте.
    Вставка объекта

  3. На вкладке Новый выберите в списке тип объекта, который вы хотите вставить. Если вы хотите вставить в электронную таблицу значок, а не сам объект, установите флажок В виде значка.

  4. Нажмите кнопку ОК. В зависимости от типа вставляемого файла откроется новое окно программы или появится окно редактирования.

  5. Создайте объект, который вы хотите вставить.

    Если Excel открыл новое окно программы для создания объекта, вы можете работать непосредственно в нем.

    Вы можете редактировать внедренный документ Word прямо в Excel.

    Когда вы закончите работу в этом окне, вы можете перейти к другим задачам, не сохраняя внедренный объект. При закрытии книги новые объекты будут сохранены автоматически.

    Примечание: После добавления объекта его можно перетащить в любое место на Excel. Вы также можете с помощью химок переуравнять размер объекта. Чтобы найти их, щелкните объект один раз.

Внедрение объекта на лист

  1. Щелкните ячейку листа, в которую вы хотите вставить объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект.

    Элемент "Объект" находится на вкладке "Вставка".
  3. Откройте вкладку Из файла.

    Вкладка "Создать из файла" в диалоговом окне "Объект"
  4. Нажмите кнопку Обзор и выберите файл, который вы хотите вставить.

  5. Если вы хотите вставить в электронную таблицу значок, а не содержимое файла, установите флажок В виде значка. Если флажки не установлены, Excel выводит первую страницу файла. В обоих случаях при двойном щелчке открывается полный файл. Нажмите кнопку ОК.

    Примечание: После добавления значка или файла его можно перетащить в любое место на нем. Кроме того, вы можете с помощью химок и химок переумноовать значок или файл. Чтобы найти их, щелкните файл или значок один раз.

Вставка ссылки на файл

Иногда нужно просто добавить ссылку на объект, а не внедрять его. Это можно сделать, если книга и объект, который вы хотите добавить, хранятся на сайте SharePoint, общем сетевом диске или в аналогичном постоянном расположении. Это удобно, если связанный объект изменяется, так как ссылка всегда будет открывать его последнюю версию.

Примечание: Если связанный файл переместить, ссылка не будет работать.

  1. Щелкните ячейку листа, в которую вы хотите вставить объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект.

    Элемент "Объект" находится на вкладке "Вставка".
  3. Откройте вкладку Из файла.

  4. Нажмите кнопку Обзор, а затем выберите файл, на который вы хотите создать ссылку.

  5. Установите флажок Связь с файлом, а затем нажмите кнопку ОК.

    На вкладке "Создать из файла" установите флажок "Связать с файлом".

Создание объекта в Excel

Вы можете создать объект с помощью другой программы, не выходя из книги. Например, если вы хотите добавить более подробное описание в диаграмму или таблицу, вы можете создать в Excel внедренный документ, например Word или PowerPoint. Можно вставить объект непосредственно на лист или добавить значок для открытия файла.

Внедренный объект является документом Word.
  1. Щелкните ячейку листа, в которую вы хотите вставить объект.

  2. На вкладке Вставка в группе Текст нажмите кнопку Объект.

    Элемент "Объект" находится на вкладке "Вставка".
  3. На вкладке Новый выберите в списке тип объекта, который вы хотите вставить. Если вы хотите вставить в электронную таблицу значок, а не сам объект, установите флажок В виде значка.

    Вкладка "Создать" в диалоговом окне "Объект"
  4. Нажмите кнопку ОК. В зависимости от типа вставляемого файла откроется новое окно программы или появится окно редактирования.

  5. Создайте объект, который вы хотите вставить.

    Если Excel открыл новое окно программы для создания объекта, вы можете работать непосредственно в нем.

    Вы можете редактировать внедренный документ Word прямо в Excel.

    Когда вы закончите работу в этом окне, вы можете перейти к другим задачам, не сохраняя внедренный объект. При закрытии книги новые объекты будут сохранены автоматически.

    Примечание: После добавления объекта его можно перетащить в любое место на Excel. Вы также можете с помощью химок переуравнять размер объекта. Чтобы найти их, щелкните объект один раз.

Изменение способа отображения объекта OLE

  1. Щелкните правой кнопкой мыши значок или объект, выберите тип объекта(например,Документ) и нажмите кнопку Преобразовать.

  2. Выполните одно из указанных ниже действий.

    • Чтобы отобразить содержимое, разо убедитесь, что он отображается в значке.

    • Чтобы отобразить значок, выберите его. При желании вы можете изменить изображение или метку значка по умолчанию. Для этого нажмите кнопку Изменить значоки выберите нужный значок в списке Значки или введите подпись в поле Подпись.

Редактирование содержимого в программе OLE

Находясь в Excel, вы можете изменить контент, связанный или внедренный из другой программы.

Изменение связанного объекта в программе-источнике

  1. На вкладке Данные в группе Подключения нажмите кнопку Изменить связи.

    Изображение ленты Excel

    Примечание: Отсутствие команды Изменить связи означает, что файл не содержит связанных данных.

  2. В списке Исходный файл выберите источник файла связанный объект и нажмите кнопку С открытым кодом.

  3. Внести нужные изменения в связанный объект.

  4. Зайдите программа-источник, чтобы вернуться к файлу назначения.

Изменение внедренного объекта в программе-источнике

  1. Дважды щелкните внедренный объект, чтобы открыть его.

  2. Внести в объект нужные изменения.

  3. Если вы редактируете объект на месте в открытой программе, щелкните в любом месте за пределами объекта, чтобы вернуться к конечный файл.

    Если вы редактируете внедренный объект в программе-источнике в отдельном окне, зайдите из программы-источника, чтобы вернуться к файлу назначения.

Примечание: При двойном щелчке внедренных объектов, таких как видеоклипы и звуковые клипы, объект воспроизводится, а не открывается программа. Чтобы изменить один из внедренных объектов, щелкните правой кнопкой мыши значок или объект, выберите тип объекта(например,Объект клипа мультимедиа) и нажмите кнопку Изменить.

Изменение внедренного объекта в программе, которая не является программой-источником

  1. Выберите внедренный объект, которую вы хотите изменить.

  2. Щелкните правой кнопкой мыши значок или объект, выберите тип объекта(например,Документ) и нажмите кнопку Преобразовать.

  3. Выполните одно из указанных ниже действий.

    • Чтобы преобразовать внедренный объект в тип, который вы указали в списке, нажмите кнопку Преобразовать в.

    • Чтобы открыть внедренный объект с типом, который вы указываете в списке, не изменяя тип внедренного объекта, нажмите кнопку Активировать.

Выбор объекта OLE с помощью клавиатуры

  1. Нажмите CTRL+G, чтобы отобразить диалоговое окно Перейти.

  2. Нажмите кнопкуСпециальный, выберите объектыи нажмите кнопку ОК.

  3. Нажимая tab, выберите нужный объект.

  4. Нажмите shift+F10.

  5. Найдите пункт Объект или Объект диаграммыи нажмите кнопку Изменить.

Проблема: при двойном щелчке связанного или внедренного объекта появляется сообщение "Не удается изменить"

Это сообщение появляется, исходный файл или программа-источник не открывается.

Убедитесь, что доступна программа-источник     Если программа-источник не установлена на компьютере, преобразуйте объект в формат файла установленного приложения.

Обеспечение достаточной памяти     Убедитесь, что у вас достаточно памяти для запуска программы-источника. Закроем другие программы, чтобы освободить память.

Закрыть все диалоговое окно     Если исходная программа запущена, убедитесь, что в ней нет открытых диалогов. Переключиться в программу-источник и закрыть все открытые диалоговое окно.

Закрыть исходный файл     Если исходный файл является связанным объектом, убедитесь, что он не открыт другим пользователем.

Убедитесь, что имя файла не изменилось     Если исходный файл, который вы хотите изменить, является связанным объектом, убедитесь, что он имеет то же имя, что и при ее создания, и что он не был перемещен. Выберите связанный объект и нажмите кнопку Изменить связи в группе Подключения на вкладке Данные, чтобы увидеть имя источника. Если исходный файл переименован или перемещен, используйте кнопку Изменить источник в диалоговом окне Изменение связей, чтобы найти исходный файл и повторно подключить ссылку.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?

Спасибо за ваш отзыв!

×