Использование вложенных функций в формуле

Использование функции в качестве одного из аргументов в формуле, использующей функцию, называется вложением, и мы будем ссылаться на эту функцию как на вложенную функцию. Например, если в аргументе функции если указана функция СРЗНАЧ и сумм, следующая формула суммирует набор чисел (G2: G5) только в том случае, если среднее значение другого набора чисел (F2: F5) превышает 50. В противном случае она возвращает значение 0.

Вложенные функции

Функции СРЗНАЧ и СУММ вложены в функцию ЕСЛИ.

В формулу можно вложить до 64 уровней функций.

  1. Щелкните ячейку, в которую нужно ввести формулу.

  2. Чтобы начать формулу с функции, нажмите кнопку Вставить функцию , Значок кнопки в строке формул Изображение кнопки .

    Знак равенства (=) будет вставлен автоматически.

  3. В поле Категория выберите пункт Все.

    Если вы знакомы с категориями функций, можно также выбрать категорию.

    Если вы не знаете, какую функцию использовать, можно ввести вопрос, описывающий необходимые действия, в поле Поиск функции (например, при вводе "добавить числа" возвращается функция СУММ).

  4. Чтобы ввести другую функцию в качестве аргумента, введите функцию в поле этого аргумента.

    Части формулы, отображенные в диалоговом окне Аргументы функции, отображают функцию, выбранную на предыдущем шаге.

    Если щелкнуть элемент ЕСЛИ, в диалоговом окне Аргументы функции отображаются аргументы для функции ЕСЛИ. Чтобы вложить другую функцию, можно ввести ее в поле аргумента. Например, можно ввести СУММ(G2:G5) в поле Значение_если_истина функции ЕСЛИ.

  5. Введите дополнительные аргументы, необходимые для завершения формулы.

    Вместо того, чтобы вводить ссылки на ячейки, можно также выделить ячейки, на которые нужно сослаться. Нажмите кнопку Изображение кнопки , чтобы свернуть диалоговое окно, выделите ячейки, на которые вы хотите добавить ссылку, и нажмите кнопку Изображение кнопки , чтобы развернуть диалоговое окно еще раз.

    Совет: Для получения дополнительных сведений о функции и ее аргументах щелкните ссылку Справка по этой функции.

  6. Завершив ввод аргументов формулы, нажмите кнопку ОК.

  1. Щелкните ячейку, в которую нужно ввести формулу.

  2. Чтобы начать формулу с функции, нажмите кнопку Вставить функцию , Значок кнопки в строке формул Изображение кнопки .

  3. В диалоговом окне Вставка функции в поле выберите категорию выберите все.

    Если вы знакомы с категориями функций, можно также выбрать категорию.

  4. Чтобы ввести другую функцию в качестве аргумента, введите ее в поле аргумент в построителе формул или прямо в ячейку.

  5. Введите дополнительные аргументы, необходимые для завершения формулы.

  6. По завершении ввода аргументов для формулы нажмите клавишу ВВОД.

Примеры

Ниже приведен пример использования вложенных функций ЕСЛИ для назначения буквенных категорий числовым результатам тестирования.

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. При необходимости измените ширину столбцов, чтобы видеть все данные.

Оценка

45

90

78

Формула

Описание

Результат

'=ЕСЛИ(A2>89,"A",ЕСЛИ(A2>79,"B", ЕСЛИ(A2>69,"C",ЕСЛИ(A2>59,"D","F"))))

Использует вложенные функции ЕСЛИ для назначения буквенной категории оценке в ячейке A2.

=ЕСЛИ(A2>89;"A";ЕСЛИ(A2>79;"B"; ЕСЛИ(A2>69;"C";ЕСЛИ(A2>59;"D";"F"))))

'=ЕСЛИ(A3>89,"A",ЕСЛИ(A3>79,"B", ЕСЛИ(A3>69,"C",ЕСЛИ(A3>59,"D","F"))))

Использует вложенные функции ЕСЛИ для назначения буквенной категории оценке в ячейке A3.

=ЕСЛИ(A3>89,"A",ЕСЛИ(A3>79,"B",ЕСЛИ(A3>69,"C",ЕСЛИ(A3>59,"D","F"))))

'=ЕСЛИ(A4>89,"A",ЕСЛИ(A4>79,"B", ЕСЛИ(A4>69,"C",ЕСЛИ(A4>59,"D","F"))))

Использует вложенные функции ЕСЛИ для назначения буквенной категории оценке в ячейке A4.

=ЕСЛИ(A4>89,"A",ЕСЛИ(A4>79,"B",ЕСЛИ(A4>69,"C",ЕСЛИ(A4>59,"D","F"))))

Советы: 

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

См. также

Видео: вложенные функции ЕСЛИ

Примечание:  Эта страница переведена автоматически, поэтому ее текст может содержать неточности и грамматические ошибки. Для нас важно, чтобы эта статья была вам полезна. Была ли информация полезной? Для удобства также приводим ссылку на оригинал (на английском языке).

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×