При работе с функциями разлитого массива, такими как SEQUENCE,можно ссылаться на весь диапазон, поместив после него оператор "пролитый диапазон" (#). В следующем примере в ячейке A2 есть =ПОСЛЕВЕ(10), которая передается в A2:A11. В ячейке C2 содержится формула =СУММ(A2#), эквивалентная формуле =СУММ(A2:A11), так как A2:A11 — это диапазон перелива формулы в ячейке A2. Возвращает значение 55, то есть сумму всех значений в пролитом диапазоне массива.

Если диапазон утечки растет или срыв, например путем изменения формулы в диапазоне A2 на =SEQUENCE(20), формула СУММ автоматически отразит это. Если это обычный диапазон, потребуется ввести =СУММ(A2:A11) и обновить его вручную в случае изменения диапазона. Часто бывает, что вы не знаете, изменился ли диапазон, поэтому это может привести к удалению многих трудоемких работы с предположениями.

Оператор пролитого диапазона для ссылки на весь пролитый диапазон массива с помощью =СУММ(A2#).

Вот еще один пример использования оператора различенного диапазона в нескольких формулах, где мы создаем уникальный список из списка имен, сортировать список и фильтруем имена длиной более 3 знаков. В ячейке E2 есть =СОРТ(C2#), а в ячейке G2 — =ФИЛЬТР(C2#;LEN(C2#)>3).

Оператор пролитого диапазона (#) для ссылки на весь пролитый диапазон массива с помощью =ФИЛЬТР(C2#,LEN(C2#)>3)

Известные ограничения

Оператор пролитого диапазона не поддерживает ссылки на закрытые книги. Вместо этого он возвращает #REF! значение ошибки #ЗНАЧ!. При открытии книги, на которые ссылается ссылка, эта проблема будет устраниться.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

См. также

Функция ФИЛЬТР

Функция СЛУЧМАССИВ

Функция ПОСЛЕДОВ

Функция СОРТ

Функция СОРТПО

Функция УНИК

Ошибки #ПЕРЕНОС! в Excel

Динамические массивы и поведение рассеянного массива

Оператор неявного пересечения: @

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединение к программе предварительной оценки Майкрософт

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?

Спасибо за ваш отзыв!

×