Фильтрация задач и ресурсов

Применяется к
Классический клиент Project Online Project стандартный 2024 Project профессиональный 2021 Project стандартный 2021 Project профессиональный 2019 Project стандартный 2019 Project профессиональный 2016 Project стандартный 2016

В приложении Project вы можете отфильтровать представление, чтобы видеть только критические задачи, вехи и другие наиболее важные сведения. Существует три способа фильтрации задач или ресурсов в проекте. В них представлены готовые фильтры для просмотра определенных аспектов задач и ресурсов. Если ни один из этих фильтров вам не подходит, можно создать новый фильтр или изменить существующий.

  • Предопределенные фильтры Это фильтры, которые поставляются с Project. Они используются для быстрой фильтрации задач или ресурсов, например незавершенных задач или ресурсов с превышением доступности.
  • Настраиваемые фильтры Это фильтры, которые вы разрабатываете для собственных нужд проекта.
  • Автофильтры Если они включены, они отображаются в виде стрелок вверху каждого столбца в представлении листа. Используйте их для быстрой фильтрации элементов в столбце.

В этой статье

Фильтрация задач и ресурсов

Бывают случаи, когда нужно просмотреть в проекте только определенный тип информации. Например, вам может потребоваться просмотреть только вехи проекта или задачи, которые еще не начаты. Если ваш проект содержит много задач и задействовано много ресурсов, фильтры могут быть очень полезны для просмотра определенного диапазона информации. Фильтры позволяют отображать только интересующую вас информацию и скрывать остальное.

Вы можете фильтровать данные о задаче или ресурсе с помощью предварительно определенных фильтров Project. Если ни один из фильтров вам не подходит, можно создать новый фильтр или изменить существующий.

Применение и удаление фильтра

  1. На вкладке " Вид " в группе " Данные " выберите фильтр в списке фильтров.

    Команда
    Чтобы применить фильтр, которого нет в списке, выберите "Другие фильтры" и выполните одно из следующих действий:

    • Чтобы выбрать фильтр задачи, выберите "Задача", затем выберите имя фильтра в списке "Фильтры " и нажмите кнопку "Применить".

    • Чтобы выбрать фильтр ресурса, нажмите "Ресурс", выберите имя фильтра в списке "Фильтры " и нажмите кнопку "Применить".

      Примечание

      Фильтры задач нельзя применять к представлениям ресурсов или фильтры ресурсов к представлениям задач.

  2. Если применен интерактивный фильтр, введите требуемые значения и нажмите кнопку "ОК".

  3. Чтобы отключить фильтр, выберите в списке фильтров пункт "Нет фильтра ".

Применение цвета к отфильтрованным задачам с помощью выделения

При фильтрации задач или ресурсов можно применить выделение. При выделенных задачах или ресурсах отображаются неотфильтрованные задачи, которые будут выделены другим цветом.

  1. На вкладке " Вид " в группе "Данные " выберите фильтр в списке фильтров и нажмите кнопку "Другие фильтры".
  2. Выберите фильтр в списке фильтров и нажмите кнопку "Выделить".

Совет

Чтобы применить к выделенным задачам другой цвет, используйте другой стиль текста. Откройте вкладку "Формат " и выберите "Стили текста". В списке "Элементы, которые нужно изменить " выберите "Выделенные задачи", а затем нажмите "Параметры форматирования".

Создание настраиваемого фильтра

  1. На вкладке " Вид " в группе "Данные " щелкните стрелку рядом с кнопкой "Фильтр" и выберите пункт "Другие фильтры".
    Как создать настраиваемый фильтр с помощью ленты Project.
  2. Выберите "Задача" или "Ресурс" (в зависимости от того, какой тип фильтра вы хотите создать) и нажмите кнопку "Создать".
  3. Введите имя нового фильтра. Выберите пункт "Показать в меню ", если вы хотите включить этот фильтр в список группы данных .
  4. В столбце И (или ) выберите И , чтобы отобразить результаты, соответствующие нескольким условиям фильтра. Выберите "Или", чтобы отобразить строки, соответствующие одной или другой категории.
    Выбор
  5. В столбце "Имя поля " выберите поле, которое нужно отфильтровать.
  6. В столбце "Тест" решите, как согласовать столбец " Имя поля " со столбцом "Значения" на следующем шаге.
  7. В столбцах " Значения " выберите требуемое значение или введите новое.
    Если в столбце "Тест"выбрано значение "равно" или "Не равно", можно ввести подстановочный знак в столбце "Значения" (вместо выбора варианта из списка). Например, при вводе вопросительного знака (?) будут найдены отдельные символы. При вводе звездочки (*) будут найдены любые символы. Если вы используете подстановочные знаки, убедитесь, что выбранный столбец " Имя поля " содержит текст (например, "Имя"), а не числа (например, "Длительность").
  8. Чтобы добавить еще одну строку в фильтр (и выбрать другое имя поля для фильтрации), нажмите кнопку Вставить строку. Вы можете сгруппировать строки, добавив пустую строку. Добавьте оператор "И" или "Или" в пустую строку, чтобы отфильтровать одну группу относительно другой.
  9. Закончив, нажмите кнопку "Сохранить".

Совет

Чтобы быстро удалить все фильтры, нажмите клавишу F3. Помните, что фильтры задач работают только с представлениями задач, а фильтры ресурсов — только с представлениями ресурсов.

Изменение существующего фильтра

  1. На вкладке " Вид " в группе "Данные " выберите список фильтров и нажмите кнопку "Другие фильтры".

  2. Выполните одно из следующих действий:

    • Чтобы изменить фильтр задач, выберите " Задача", выберите фильтр, который требуется изменить, и нажмите кнопку "Изменить".
    • Чтобы изменить фильтр ресурсов, выберите ресурс, выберите фильтр, который требуется изменить, и нажмите кнопку Изменить.
  3. Измените параметры фильтра с помощью элементов управления в диалоговом окне "Определение фильтра ".

Использование автофильтров

Применить автофильтр можно к полям в любом представлении листа. Помимо стандартных фильтров, в Project предусмотрены автофильтры, видимые в верхней части каждого столбца в представлениях листа.

Применение и удаление автофильтров

  1. На вкладке " Вид " в группе " Данные " щелкните стрелку для списка фильтров и выберите пункт "Отображать автофильтр".
    Команда

  2. Щелкните стрелку автофильтра рядом с заголовком столбца, содержащего сведения, которые вы хотите отобразить, а затем выберите значение для фильтрации таблицы.
    Стрелка автофильтра и заголовок поля станут синими.

  3. Чтобы применить дополнительное условие на основе значения в другом столбце, повторите действие 2 для другого столбца.

  4. Чтобы удалить фильтрацию для определенной строки, выберите команду Очистить все фильтры в списке автофильтра для этого поля.

  5. Чтобы отключить автофильтры, снова выберите "Отображать автофильтр ".

    Примечание

    Если сведения в одной из строк представления меняются, можно обновить параметры автофильтра, щелкнув стрелку и повторно выбрав значения фильтрации.

Создание настраиваемого автофильтра

  1. Отображение автофильтров.

  2. Нажмите стрелку автофильтра, наведите указатель мыши на пункт "Фильтр", а затем выберите "Настраиваемый".

  3. Выберите нужный оператор в первом поле, а затем введите или выберите значение, которое нужно сопоставить во втором.
    Например, чтобы сопоставить определенную дату в поле даты, в первом поле нажмите оператор равенства и выберите нужную дату во втором.

  4. Чтобы применить два условия к автофильтру, выполните одно из указанных ниже действий.

    • Чтобы отобразить в представлении строки, удовлетворяющие обоим условиям, выберите оператор и значение во второй строке полей, затем нажмите кнопку И.
    • Чтобы отобразить в представлении строки, соответствующие тому или иному условию, выберите оператор и значение во второй строке полей, затем нажмите кнопку Or.
  5. Чтобы сохранить параметры автофильтра, нажмите кнопку "Сохранить".
    Если к представлению уже применен предопределенный фильтр, то условия, заданные для автофильтра, включаются в текущий фильтр в качестве дополнительных условий. При сохранении параметра автофильтра он сохраняется вместе с другими фильтрами в файле и доступен только в диалоговом окне "Другие фильтры ".

Автоматическое включение автофильтров для новых проектов

  1. На вкладке Файл выберите Параметры.
  2. Выберите "Дополнительно", а затем в разделе "Общие" установите флажок "Включить автофильтр для новых проектов" проверка.

К началу страницы