Устранение неполадок обновления для Microsoft Security Essentials
Примечание
- Поддержка Windows 7 закончилась 14 января 2020 года.
- Чтобы продолжить получать обновления системы безопасности от Майкрософт, мы рекомендуем перейти на Windows 11.
Microsoft Security Essentials автоматически работает с Центром обновления Майкрософт, чтобы обеспечить актуальность ваших определений вирусов и шпионских программ.
Проблема
Вот некоторые распространенные проблемы с автоматическими обновлениями:
- Отображаются сообщения о том, что не удалось выполнить обновления.
- При проверке наличия обновлений отображается сообщение об ошибке, в котором говорится, что не удается проверить наличие определений вирусов и программ-шпионов или скачать и установить их.
- Несмотря на то, что ваш компьютер подключен к Интернету, не удается выполнить обновления.
- Обновления не устанавливаются автоматически, как запланировано.
Причина
Самые распространенные причины проблем при обновлениях — это проблемы с подключением к Интернету. Если вы находитесь в сети, проблема может быть вызвана конфликтами с вашими настройками в Windows Internet Explorer.
Решение
Примечание
Чтобы выполнить эти действия, вам придется выйти из Internet Explorer. Поэтому распечатайте или запишите их либо скопируйте в другой файл, а затем поместите данную страницу в закладки, чтобы потом можно было легко найти ее.
Действие 1. Сбросьте параметры Internet Explorer.
Закройте все работающие программы, включая Internet Explorer.
Примечание
При сбросе этих параметров в Internet Explorer будут удалены временные файлы, файлы cookie, журнал браузера и ваши пароли в Интернете. Тем не менее избранные элементы не будут удалены.
Нажмите кнопку Пуск, в поле Начать поиск введите inetcpl.cpl, а затем нажмите клавишу ВВОД.
В диалоговом окнеСвойства: Интернет откройте вкладку Дополнительно.
В разделе Сброс параметров настройки Internet Explorer нажмите кнопку Сброс, а затем еще раз нажмите кнопку Сброс.
Подождите, пока Internet Explorer завершит сброс параметров, а затем нажмите кнопку ОК.
Откройте Internet Explorer.
Откройте Microsoft Security Essentials, перейдите на вкладку Обновление, а затем щелкните Обновить. Если ошибка повторится, перейдите к следующему действию.
Действие 2. Назначьте Internet Explorer браузером, используемым по умолчанию.
- Закройте все работающие программы, включая Internet Explorer.
- Нажмите кнопку Пуск, в поле Начать поиск введите inetcpl.cpl, а затем нажмите клавишу ВВОД.
- В диалоговом окне Свойства: Интернет откройте вкладку Программы.
- В разделе Веб-браузер по умолчанию щелкните Использовать по умолчанию. Нажмите кнопку ОК.
- Откройте Microsoft Security Essentials. Откройте вкладку Обновление и выберите Обновить. Если ошибка повторится, перейдите к следующему действию.
Действие 3. Убедитесь, что на компьютере правильно настроены дата и время.
- Откройте Microsoft Security Essentials.
- Если в отобразившемся сообщении об ошибке есть код 0x80072f8f, то проблема скорее всего вызвана неправильной датой или временем на компьютере.
- Чтобы сбросить настройку даты или времени на компьютере, выполните действия, описанные в разделе Исправление неработающих ярлыков на рабочем столе и общие задачи по обслуживанию системы.
Действие 4. Измените имя папки "Распространение программного обеспечения" на компьютере.
Останов службы автоматического обновления
- Нажмите кнопку Пуск, щелкните Выполнить, введите services.msc, а затем нажмите кнопку ОК.
- Щелкните правой кнопкой мыши службу Автоматическое обновление и выберите Остановить.
- Сверните оснастку "Службы".
Если в отобразившемся сообщении об ошибке есть код 0x80072f8f, то проблема скорее всего вызвана неправильной датой или временем на компьютере.
Переименуйте каталог SoftwareDistribution указанным ниже образом.
- Нажмите кнопку Пуск, щелкните Выполнить, введите cmd, а затем нажмите кнопку ОК.
- Введите cd %windir%, а затем нажмите клавишу ВВОД.
- Введите ren SoftwareDistribution SDTemp, а затем нажмите клавишу Ввод.
- Введите exit и нажмите клавишу ВВОД.
Запустите службу автоматического обновления указанным ниже образом.
- Разверните оснастку "Службы".
- Щелкните правой кнопкой мыши службу Автоматическое обновление и выберите Запустить.
- Закройте окно оснастки "Службы".
Действие 5. Сбросьте модуль обновления антивирусной программы Майкрософт на компьютере.
Нажмите кнопку Пуск, последовательно щелкните Все программы и Стандартные, правой кнопкой мыши щелкните Командная строка, а затем выберите Запуск от имени администратора.
В окне Командная строка введите указанные ниже команды, нажимая клавишу ВВОД после каждой команды.
- Cd\
- cd program files\microsoft security essentials
- Mpcmdrun –removedefinitions –all
- Выход
Перезагрузите компьютер.
Откройте Microsoft Security Essentials, перейдите на вкладку Обновление, а затем щелкните Обновить. Если ошибка повторится, перейдите к следующему действию.
Действие 6. Вручную установите обновления определений вирусов и программ-шпионов
- Если вы используете 32-разрядную операционную систему Windows, скачайте последние обновления вручную на http://go.microsoft.com/fwlink/?LinkID=87342.
- Если вы используете 64-разрядную операционную систему Windows, скачайте последние обновления вручную на http://go.microsoft.com/fwlink/?LinkID=87341.
Щелкните Выполнить. Последние обновления будут установлены на вашем компьютере.
Действие 7. Обращение в службу поддержки.
Если указанные выше действия не помогли, обратитесь в службу поддержки. Дополнительные сведения см. в разделе Служба поддержки клиентов.