Проблема
Рассмотрим следующий сценарий.
- Вы используете BizTalk ESB Toolkit.
- Вы используете параметр "ВСЕ. Исключения" отправляют порт для обработки и отправки двоичных сообщений в базу данных ESB Exception.
- MIME-тип сообщений — "application/octet-stream".
В этом сценарии вы заметите, что некоторые сообщения приостанавливаются и не отправляются в базу данных исключений ESB. Кроме того, возвращается следующее сообщение об ошибке:
Примечание
- Произошла ошибка при выполнении конвейера отправки: "Microsoft.Practices.ESB.ExceptionHandling.Pipelines.ESBFaultProcessor, Microsoft.Practices.ESB.ExceptionHandling.Pipelines, Version=2.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Источник: "ESB Transform" Порт отправки: "ALL. Исключения" URI: "<UriPath>"
- Причина. Ошибка 175002: при попытке создания карты произошла непредвиденная ошибка: 'Microsoft.Practices.ESB.ExceptionHandling.Maps.FaultMessage_to_ExceptionSql, Microsoft.Practices.ESB.ExceptionHandling.Maps, Version=2.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.
Состояние
Корпорация Майкрософт подтвердила, что это проблема продуктов Microsoft, перечисленных в разделе «Относится к».
Решение
Эта проблема устранена в следующем накопительном пакете обновления для BizTalk Server:
- Накопительный пакет обновления 3 для BizTalk Server 2020
Ссылки
Сведения о пакетах обновления и списке накопительных пакетов обновления для BizTalk Server см. в следующей статье базы знаний Майкрософт:
2555976 Пакет обновления и накопительный пакет обновления для BizTalk Server
Дополнительные сведения об исправлениях BizTalk Server см. в следующей статье базы знаний Майкрософт:
2003907 Сведения об исправлениях BizTalk и поддержке накопительных пакетов обновления