Проблема
В Microsoft Dynamics CRM 4.0 используется множество рабочих процессов. Таблицы AsyncOperationBase и WorkflowLogBase растут очень большими, и возникают проблемы с производительностью.
Причина
Эта проблема возникает из-за того, что при срабатывании правил рабочего процесса экземпляр рабочего процесса и запись рабочего процесса создаются в таблицах AsyncOperationBase и WorkflowLogBase базы данных MSCRM. Однако по завершении экземпляра рабочего процесса запись рабочего процесса остается в базе данных. Поэтому таблицы AsyncOperationBase и WorkflowLogBase продолжают расти. В конечном итоге производительность снижается.
Примечание. Свойство AsyncOperationType для этих записей имеет значение 10.
Решение
Эта проблема устранена в последнем накопительном пакете обновления для Microsoft Dynamics CRM 4.0.
Для получения дополнительных сведений щелкните следующий номер статьи, чтобы просмотреть статью в базе знаний Майкрософт:
обновления и исправления 949256 Microsoft Dynamics CRM 4.0
Важно! В этом разделе, методе или задаче содержатся инструкции по изменению реестра. Однако ошибки при изменении реестра могут привести к серьезным проблемам. Поэтому будьте внимательны, выполняя описанные действия. В качестве дополнительной меры предосторожности перед внесением изменений создайте резервную копию реестра. Тогда в случае возникновения проблемы вы сможете восстановить реестр. Дополнительные сведения о том, как создать резервную копию и восстановить реестр, щелкните следующий номер статьи, чтобы просмотреть статью в базе знаний Майкрософт:
322756 Резервное копирование и восстановление реестра в Windows
После установки исправления, чтобы включить это исправление для вас, перейдите к разделу "Исправление для меня". Если вы предпочитаете самостоятельно включить исправление, перейдите к разделу "Самостоятельное исправление".
Помощь в решении проблемы
Чтобы включить исправление автоматически, нажмите кнопку или ссылку Исправить . Затем нажмите кнопку Выполнить в диалоговом окне Скачивание файла и выполните действия, описанные в мастере исправления .
Заметки
- Возможно, этот мастер будет доступен только на английском языке. Тем не менее, автоматическое исправление подходит также для версий Windows на других языках.
- Если вы не используете компьютер, на который возникла проблема, сохраните решение Исправить на флэш-памяти или компакт-диске, а затем запустите его на компьютере, где возникла проблема.
Затем перейдите к разделу "Устранена проблема?".
Позвольте мне исправить это самостоятельно
Чтобы включить это исправление, выполните следующие действия.
Нажмите кнопку Пуск, нажмите кнопку Выполнить, введите regedit и нажмите кнопку
Хорошо.В редакторе реестра найдите следующий подраздел:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRMОпределите, существует ли запись реестра DWORD с именем AsyncRemoveCompletedWorkflows. Значения для записи реестра AsyncRemoveCompletedWorkflows должны иметь значение 1.
Если запись реестра AsyncRemoveCompletedWorkflows не существует, добавьте запись. Для этого выполните указанные ниже действия.
Щелкните правой кнопкой мыши MSCRM, наведите указатель на
Создать, щелкните Значение DWORD и введите
AsyncRemoveCompletedWorkflows в
Поле "Имя ".двойным щелчком
AsyncRemoveCompletedWorkflows, а затем введите
1 в поле Данные значения .Нажмите кнопку Пуск, нажмите кнопку
Запустите, введите iisreset и нажмите кнопку
Хорошо.Примечание. Если значение в поле "Значение" для значения DWORD AsyncRemoveCompletedWorkflows возвращается к 0, Microsoft Dynamics CRM продолжит сохранять записи рабочего процесса в базе данных, даже если задачи завершены.
Примечание. Это исправление предназначено только для упреждающего действия. Поэтому при установке и активации исправления автоматически удаляются только новые записи рабочего процесса. Если таблицы AsyncOperationBase и WorkflowLogBase уже большие из-за этих записей рабочего процесса, необходимо выполнить очистку этих таблиц с помощью скрипта очистки Microsoft SQL Server, который включен в следующую статью базы знаний Майкрософт:
968520 Производительность снижается, если таблица AsyncOperationBase становится слишком большой в Microsoft Dynamics CRM 4.0
Устранена ли проблема?
- Проверьте, устранена ли проблема. Если проблема устранена, вы закончите работу с этим разделом. Если проблема не устранена, вы можете обратиться в службу поддержки.
- Мы будем признательны за ваши отзывы. Чтобы оставить отзыв или сообщить о проблемах с этим решением, оставьте комментарий в блоге "Исправление для меня" или отправьте нам сообщение электронной почты .
Дополнительные сведения
Чтобы получить дополнительные сведения о терминологии обновлений программного обеспечения, щелкните следующий номер статьи, чтобы просмотреть статью в базе знаний Майкрософт:
824684 Описание стандартной терминологии, используемой для описания обновлений программного обеспечения Майкрософт. Дополнительные сведения об исправлении программного обеспечения Microsoft Business Solutions CRM и терминологии пакетов обновлений щелкните следующий номер статьи, чтобы просмотреть статью в базе знаний Майкрософт:
887283 исправление программного обеспечения Microsoft Business Solutions CRM и обновление стандартов именования пакетов