ИСПРАВЛЕНИЕ. Результаты GetNonHostedApplications усекаются, когда метод получает список всех не размещенных приложений в CCF 2009.

Применяется к
Microsoft Customer Care Framework 2008 Microsoft Customer Care Framework 2009

Проблема

Рассмотрим следующий сценарий.

  • Вы устанавливаете Microsoft Customer Care Framework (CCF) 2009 на компьютере.
  • Вы вызываете метод Microsoft.Ccf.Csr.WebSerices.ContactCenter/NonHostedApplication::GetNonHostedApplications, чтобы получить список не размещенных приложений, определенных в CCF 2009.

В этом сценарии метод GetNonHostedApplications возвращает усеченные результаты.

Примечание. Эта проблема также возникает в CCF 2008. Однако пакет исправлений для CCF 2008 в настоящее время недоступен.

Причина

Эта проблема возникает из-за того, что результаты, возвращаемые методом GetNonHostedApplications, превышают 2033 символов. 

Когда метод GetNonHostedApplications использует следующий запрос для получения списка приложений из базы данных CCFInfrastructure , команда Raw возвращает данные в больших двоичных объектах с 2033 символами:

Select * from NonHostedApplications for xml raw

Однако метод GetNonHostedApplications удаляет все, что было за первой строкой символов 2033. Поэтому результаты усечены.

Решение

Сведения об исправлении

Поддерживаемое исправление теперь доступно в корпорации Майкрософт. Однако он предназначен для устранения только проблемы, описанной в этой статье. Применяйте его только к системам, в которых возникла эта конкретная проблема. Это исправление может пройти дополнительное тестирование. Поэтому, если эта проблема не затрагивает вас, рекомендуется подождать следующего, содержащего это исправление.

Чтобы немедленно устранить эту проблему, обратитесь в службу поддержки майкрософт, чтобы получить исправление. Полный список телефонных номеров служб поддержки майкрософт и сведения о расходах на поддержку см. на следующем веб-сайте Майкрософт:

http://support.microsoft.com/contactus/?ws=support Примечание. В особых случаях плата, которая обычно взимается за звонки в службу поддержки, может быть отменена, если служба поддержки Майкрософт Professional определит, что конкретное обновление решит проблему. Обычные расходы на поддержку будут применяться к дополнительным вопросам и проблемам поддержки, которые не относятся к конкретному обновлению.

Необходимые условия

Чтобы применить это исправление, необходимо установить Microsoft Customer Care Framework (CCF) 2009 с пакетом обновления 1 (SP1). 

Необходимость перезапуска

Если затронутые файлы не используются, перезагружать компьютер после применения этого исправления не требуется.  

Сведения о замене исправлений

Это исправление не заменяет ранее выпущенное исправление.  

Сведения о файлах

В английской версии этого исправления есть атрибуты файла (или более поздние атрибуты файлов), перечисленные в следующей таблице. Значения даты и времени для этих файлов указаны в формате UTC. При просмотре сведений о файлах они преобразуются в местное время. Чтобы найти разницу между временем в формате UTC и местным временем, используйте вкладку Часовой пояс в элементе Дата и время в панель управления.

Имя файла Версия файла Размер файла Дата Время Платформа
Microsoft.ccf.csr.webservices.providers.dll 4.1.10326.1 210,832 23 ноября 2010 г. 16:13 x86

Временное решение

Чтобы обойти эту проблему, вызовите метод GetShortDetails в веб-службе AdminConsole\NonHostedAppWS .

Состояние

Корпорация Майкрософт подтвердила, что это проблема продуктов Microsoft, перечисленных в разделе «Относится к».