Вы не можете определить, какие поля доступны, а какие — недоступны при открытии диалогового окна в Microsoft Dynamics NAV

Microsoft Business Solutions-Navision 4.0 и Microsoft Navision 4.0 теперь являются частью Microsoft Dynamics NAV 4.0. Все ссылки на Microsoft Business Solutions-Navision или Microsoft Navision 4.0 относятся к Microsoft Dynamics NAV.

Эта статья относится к Microsoft Dynamics NAV 4.0 для всех регионов.

Проблема

При открытии диалогового окна в Microsoft Dynamics NAV невозможно определить, какие поля доступны, а какие — недоступны, так как все поля кажутся доступными. Эта проблема возникает, если выполняются следующие условия:

  • Вы используете Microsoft Dynamics NAV на компьютере под управлением Windows Vista.
  • На компьютере включена цветовая схема Windows Aero.

Например, эта проблема возникает при открытии диалогового окна Карточка клиента в Microsoft Dynamics NAV. При этом поля Баланс и Кредитный лимит имеют одинаковый цвет. Однако поле Баланс должно отображаться неактивно, так как оно недоступно.

Причина

Эта проблема возникает из-за того, что Microsoft Dynamics NAV использует элементы управления Windows, которые имеют другой внешний вид, когда компьютер работает под управлением Windows Vista.

Решение

Сведения об исправлении

Поддерживаемое исправление теперь доступно в корпорации Майкрософт. Исправление устраняет проблему, описанную в этой статье. Примените исправление только к системам, в которых возникла эта проблема.

Чтобы немедленно устранить эту проблему, обратитесь в службу технической поддержки Microsoft Dynamics и связанных продуктов, чтобы получить исправление. Вы можете войти на сайт Microsoft Dynamics и создать новый запрос на поддержку. Для этого посетите следующий веб-сайт Майкрософт:

https://mbs.microsoft.com/support/newstart.aspx Вы также можете обратиться в службу технической поддержки Microsoft Dynamics и связанных продуктов по телефону (888) 477-7877.

Примечание. В особых случаях плата, которая обычно взимается за звонки в службу поддержки, может быть отменена, если специалист по технической поддержке Microsoft Dynamics и связанных продуктов определит, что конкретное обновление поможет устранить вашу проблему. Обычные расходы на поддержку будут применяться к любым дополнительным вопросам и проблемам, которые не относятся к конкретному обновлению.

Как получить файлы исправлений или обновлений Microsoft Dynamics NAV

После запроса исправления Microsoft Dynamics NAV или файла обновления в службе технической поддержки Microsoft Dynamics вам будет отправлена гиперссылка по электронной почте.

Сообщение электронной почты будет содержать гиперссылку и пароль. С помощью гиперссылки можно скачать исправление Microsoft Dynamics NAV или файлы обновления. Щелкнув гиперссылку, откроется диалоговое окно Скачивание файла — предупреждение системы безопасности . Затем вам будет предложено выполнить, сохранить или отменить скачивание.

Если нажать кнопку Выполнить, файлы запускают процесс скачивания и извлечения. Необходимо указать папку для новых файлов, а затем введите пароль.

Если нажать кнопку Сохранить, необходимо указать путь для сохранения сжатого файла. При открытии сохраненного файла вам будет предложено указать путь к файлам. Затем необходимо указать пароль, указанный в сообщении электронной почты.

Если нажать кнопку Отмена, процесс скачивания останавливается.

Установка или обновление файла исправления Microsoft Dynamics NAV

Исправления и обновления платформы Microsoft Dynamics NAV предоставляются в виде отдельных файлов. Чтобы установить исправление или обновление Microsoft Dynamics NAV, необходимо заменить существующие установочные файлы Microsoft Dynamics NAV на исправления или файлы обновления. Для этого выполните указанные ниже действия.

Microsoft Dynamics NAV 4.0 с пакетом обновления 3 (SP3)

Шаг 1. Замена файла установки клиента Microsoft Dynamics NAV

В установке клиента Microsoft Dynamics NAV замените следующие файлы с помощью исправления или файла обновления.

Имя файла Версия файла Размер файла Дата Время Платформа
Dbm.dll 4.0.3.25206 345,208 13 сентября 2007 г. 20:18 x86
Fin.exe 4.0.3.25206 8,119,416 13 сентября 2007 г. 20:18 x86
Fin.exe.manifest Неприменимо 711 11 сентября 2007 г. 21:13 Неприменимо
Finhlink.exe 4.0.3.25206 119,928 13 сентября 2007 г. 20:17 x86
Finsql.exe 4.0.3.25206 8,168,568 13 сентября 2007 г. 20:18 x86
Finsql.exe.manifest Неприменимо 714 14 декабря 2006 г. 16:41 Неприменимо
Nc_netb.dll 4.0.3.25206 78,968 13 сентября 2007 г. 20:17 x86
Nc_tcp.dll 4.0.3.25206 83,064 13 сентября 2007 г. 20:17 x86
Nc_tcps.dll 4.0.3.25206 91,256 13 сентября 2007 г. 20:17 x86

Чтобы заменить существующие файлы Microsoft Dynamics NAV, выполните следующие действия.

  1. Закройте клиент Microsoft Dynamics NAV.

  2. Найдите каталог установки клиента Microsoft Dynamics NAV.

    Примечание. Как правило, клиент Microsoft Dynamics NAV устанавливается в следующем каталоге:
    C:\Program Files\Microsoft Business Solutions-Navision\Client\

  3. Скопируйте скачанные файлы.

  4. Вставьте скачанные файлы в каталог установки клиента Microsoft Dynamics NAV.

  5. В
    Диалоговое окно Подтверждение замены файла нажмите кнопку Да , чтобы перезаписать файлы в каталоге установки.

Microsoft Dynamics NAV 2009

Шаг 1. Замена файлов установки классического клиента Microsoft Dynamics NAV

В классической установке клиента Microsoft Dynamics NAV замените следующие файлы с помощью исправления или файла обновления.

Имя файла Версия файла Размер файла Дата Время Платформа
Dbm.dll 6.0.29415.0 444,232 1 июля 2009 г. 9:19 x86
Fin.exe 6.0.29415.0 12,244,792 1 июля 2009 г. 9:19 x86
Finhlink.exe 6.0.29415.0 452,432 1 июля 2009 г. 9:19 x86
Finsql.exe 6.0.29415.0 12,330,832 1 июля 2009 г. 9:19 x86
Nc_netb.dll 6.0.29415.0 108,352 1 июля 2009 г. 9:19 x86
Nc_tcp.dll 6.0.29415.0 108,368 1 июля 2009 г. 9:19 x86
Nc_tcps.dll 6.0.29415.0 153,408 1 июля 2009 г. 9:19 x86
Ndbcs.dll 6.0.29415.0 1,333,072 1 июля 2009 г. 9:19 x86
Slave.exe 6.0.29415.0 161,616 1 июля 2009 г. 9:19 x86

Чтобы заменить существующие файлы Microsoft Dynamics NAV, выполните следующие действия.

  1. Закройте клиент Microsoft Dynamics NAV.

  2. Найдите каталог установки классического клиента Microsoft Dynamics NAV.

    Примечание. Как правило, классический клиент Microsoft Dynamics NAV устанавливается в следующем каталоге:
    C:\Program Files\Microsoft Dynamics NAV\60\CSIDE Client\

  3. Скопируйте скачанные файлы.

  4. Вставьте скачанные файлы в каталог установки классического клиента Microsoft Dynamics NAV.

  5. В
    Диалоговое окно Подтверждение замены файла нажмите кнопку Да , чтобы перезаписать файлы в каталоге установки.

Шаг 2. Замена файлов установки Microsoft Dynamics NAVTailored Client

В установке microsoft Dynamics NAV RoleTailored Client замените следующие файлы с помощью исправления или файла обновления.

Имя файла Версия файла Размер файла Дата Время Платформа
Dundaswinchart.dll 5.0.0.1692 2,733,904 1 июля 2009 г. 9:19 x86
Microsoft.dynamics.framework.patterns.dll 1.2.10579.173 71,648 30 июня 2009 г. 7:21 x86
Microsoft.dynamics.framework.ui.dll 1.2.10579.173 654,280 30 июня 2009 г. 7:21 x86
Microsoft.dynamics.framework.ui.mapping.dll 1.2.10579.173 101,336 30 июня 2009 г. 7:21 x86
Microsoft.dynamics.framework.ui.navigation.dll 1.2.10579.173 22,496 30 июня 2009 г. 7:21 x86
Microsoft.dynamics.framework.ui.ux2006.dll 1.2.10579.173 93,064 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll 1.2.10579.173 39,840 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.framework.ui.windows.dll 1.2.10579.173 84,952 30 июня 2009 г. 7:21 x86
Microsoft.dynamics.framework.ui.winforms.controls.dll 1.2.10579.173 2,067,440 30 июня 2009 г. 7:21 x86
Microsoft.dynamics.framework.ui.winforms.dll 1.2.10579.173 633,824 30 июня 2009 г. 7:21 x86
Microsoft.dynamics.nav.client.builder.dll 1.2.10579.173 166,792 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.client.exe 6.0.29415.0 142,200 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.client.interop.communicator.dll 6.0.29415.0 76,704 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.client.serviceconnection.dll 6.0.29415.0 76,704 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.client.ui.dll 6.0.29415.0 428,920 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.client.winforms.dll 6.0.29415.0 277,384 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.client.winforms.tlb 6.0.29415.0 2,652 1 июля 2009 г. 4:37 Неприменимо
Microsoft.dynamics.nav.language.dll Неприменимо 1,866,616 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.types.dll 6.0.29415.0 383,856 1 июля 2009 г. 9:08 x86
Microsoft.office.interop.outlook.dll 10.0.4504.0 396,152 1 июля 2009 г. 9:08 x86

Чтобы заменить существующие файлы, выполните следующие действия.

  1. Закройте роль Microsoft Dynamics NAVTailored Client.
  2. Найдите каталог установки Microsoft Dynamics NAV RoleTailored Client. Как правило, клиент Microsoft Dynamics NAV RoleTailored устанавливается в следующем каталоге:
    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client
  3. Скопируйте скачанные файлы.
  4. Вставьте скачанные файлы в каталог установки Microsoft Dynamics NAV RoleTailored Client.
  5. При появлении запроса нажмите кнопку Да , чтобы перезаписать файлы в каталоге установки.

Шаг 3. Замена установочных файлов microsoft Dynamics NAV Server

В установке microsoft Dynamics NAV Server замените следующие файлы с помощью исправления или файла обновления.

Имя файла Версия файла Размер файла Дата Время Платформа
Httpcfg.exe 5.2.3790.0 22,352 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.language.dll 6.0.29415.0 1,865,600 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.ncl.dll 6.0.29415.0 489,336 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.server.exe 6.0.29415.0 137,088 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.server.exe.config Неприменимо 211 17 июня 2009 г. 3:29 Неприменимо
Microsoft.dynamics.nav.service.dll 6.0.29415.0 120,704 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.service.runtime.dll 6.0.29415.0 63,376 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.service.webservices.dll 6.0.29415.0 128,920 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.types.dll 6.0.29415.0 382,840 1 июля 2009 г. 9:08 x86
Microsoft.dynamics.nav.watson.dll 6.0.29415.0 38,784 1 июля 2009 г. 9:08 x86
Nclcsrt.etx Неприменимо 87,279 1 июля 2009 г. 12:52 Неприменимо
Nclcsrt.stx Неприменимо 81,083 1 июля 2009 г. 12:52 Неприменимо
Nclcsrts.dll Неприменимо 1,394,512 1 июля 2009 г. 9:19 x86
Ndbcs.dll 6.0.29415.0 1,333,072 1 июля 2009 г. 9:19 x86

Чтобы заменить файлы, выполните следующие действия:

  1. Остановите службу сервера Microsoft Dynamics NAV.

  2. Найдите каталог установки сервера Microsoft Dynamics NAV.

    Примечание. Как правило, служба сервера Microsoft Dynamics NAV устанавливается в следующем каталоге:

    C:\program files\Microsoft Dynamics NAV\60\Service

  3. Скопируйте скачанные файлы.

  4. Вставьте скачанные файлы в каталог установки сервера Microsoft Dynamics NAV.

  5. Нажмите кнопку Да , чтобы перезаписать файлы в каталоге.

  6. Запустите службу сервера Microsoft Dynamics NAV.

Шаг 4. Замена файлов common Files

В папке Common Files замените следующие файлы.

Имя файла Версия файла Размер файла Дата Время Платформа
Customization.xml Неприменимо 1,115 17 июня 2009 г. 3:24 Неприменимо
Msoutl.olb 11.0.5510.0 200,248 17 июня 2009 г. 3:24 Неприменимо

Чтобы заменить существующие файлы, выполните следующие действия.

  1. Найдите каталог Common Files:

    C:\Program Files\Common Files\Microsoft Dynamics NAV\OLSync

  2. Скопируйте скачанные файлы.

  3. Вставьте скачанные файлы в каталог Common Files.

  4. При появлении запроса нажмите кнопку Да , чтобы перезаписать файлы в каталоге установки.

Шаг 5. Замена файлов Windows\System32

В папке Windows\System32 замените следующие файлы.

Имя файла Версия файла Размер файла Дата Время Платформа
Cdo.dll 6.5.7940.0 775,480 1 июля 2009 г. 9:19 x86
Gapi32.dll 6.5.7940.0 71,488 1 июля 2009 г. 9:19 x86

Чтобы заменить существующие файлы, выполните следующие действия.

  1. Найдите каталог Windows\System32:

    C:\Windows\System32

  2. Скопируйте скачанные файлы.

  3. Вставьте скачанные файлы в каталог Common Files.

  4. При появлении запроса нажмите кнопку Да , чтобы перезаписать файлы в каталоге установки.

Необходимые условия

Для применения этого исправления необходимо установить один из следующих продуктов:

  • Microsoft Dynamics NAV 4.0 с пакетом обновления 3 (SP3) с исправлением KB 940718

  • Microsoft Dynamics NAV 2009

Сведения об удалении

Удалить это исправление невозможно.

Необходимость перезапуска

Если появится запрос на перезагрузку компьютера, необходимо перезагрузить компьютер после применения этого исправления.

Состояние

Корпорация Майкрософт подтвердила, что это проблема продуктов Microsoft, перечисленных в разделе «Относится к».

Дополнительные сведения

Чтобы получить дополнительные сведения о терминологии обновлений программного обеспечения, щелкните следующий номер статьи, чтобы просмотреть статью в базе знаний Майкрософт:

824684 Описание стандартной терминологии, используемой для описания обновлений программного обеспечения Майкрософт