Сообщение об ошибке "Невозможно использовать файл C:\Users[User]\AppData\Roaming\fin.zup, так как он уже используется" при печати нескольких классических отчетов из клиента RoleTailored в Microsoft Dynamics NAV 2009 с пакетом обновления 1 (SP1)

Применяется к
Dynamics NAV 2009

Эта статья относится к Microsoft Dynamics NAV для всех стран и языковых стандартов.

Проблема

При печати нескольких классических отчетов из клиента RoleTailored (RTC) в Microsoft Dynamics NAV 2009 с пакетом обновления 1 (SP1) появляется следующее сообщение об ошибке:

Примечание

Невозможно использовать файл C:\Users\User\AppData\Roaming\fin.zup, так как он уже используется.

Эта проблема возникает, если выполняются следующие условия:

  • В отчетах не определен макет. Таким образом, отчеты выполняются в классическом подсистеме отчетов из RTC.
  • По крайней мере два отчета печатаются быстро подряд.

Причина

Эта проблема возникает из-за того, что RTC запускает классическую подсистему отчетов для запуска отчета. При печати отчета классическая подсистема пытается сохранить ZUP-файл. При быстром запуске нескольких отчетов несколько классических обработчиков перезаписывают другие ZUP-файлы.

Решение

Сведения об исправлении

Поддерживаемое исправление доступно в корпорации Майкрософт. В верхней части этой статьи базы знаний есть раздел "Доступно скачивание исправлений". Если у вас возникла проблема с загрузкой, установкой этого исправления или возникли другие вопросы о технической поддержке, обратитесь к партнеру или, если вы зарегистрировались в плане поддержки непосредственно в корпорации Майкрософт, вы можете обратиться в службу технической поддержки Microsoft Dynamics и создать новый запрос на поддержку. Для этого посетите следующий веб-сайт Майкрософт:

https://mbs.microsoft.com/support/newstart.aspx Вы также можете обратиться в службу технической поддержки Microsoft Dynamics по телефону, используя эти ссылки для номеров телефонов для конкретной страны. Для этого посетите один из следующих веб-сайтов Майкрософт:

Партнеры

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+Contacts Клиентов

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htm В особых случаях плата, которая обычно взимается за звонки в службу поддержки, может быть отменена, если специалист по технической поддержке Microsoft Dynamics и связанных продуктов определит, что конкретное обновление решит проблему. Обычные расходы на поддержку будут применяться к любым дополнительным вопросам и проблемам, которые не относятся к конкретному обновлению.

            
          

Как получить файлы исправлений или обновлений Microsoft Dynamics NAV

После запроса исправления Microsoft Dynamics NAV вам будет отправлена гиперссылка по электронной почте.

Сообщение электронной почты будет содержать гиперссылку и пароль. С помощью гиперссылки можно скачать исправление Microsoft Dynamics NAV или файлы обновления. Щелкнув гиперссылку, откроется диалоговое окно Скачивание файла — предупреждение системы безопасности . Затем вам будет предложено выполнить, сохранить или отменить скачивание.

Если нажать кнопку Выполнить, файлы запускают процесс скачивания и извлечения. Необходимо указать папку для новых файлов, а затем введите пароль.

Если нажать кнопку Сохранить, необходимо указать путь для сохранения сжатого файла. При открытии сохраненного файла вам будет предложено указать путь к файлам. Затем необходимо указать пароль, указанный в сообщении электронной почты.

Если нажать кнопку Отмена, процесс скачивания останавливается.

Установка исправления Microsoft Dynamics NAV или файла обновления

Исправления и обновления платформы Microsoft Dynamics NAV предоставляются в виде отдельных файлов. Чтобы установить исправление или обновление Microsoft Dynamics NAV, необходимо заменить существующие установочные файлы Microsoft Dynamics NAV на исправления или файлы обновления. Для этого выполните указанные ниже действия.

Шаг 1. Замена файлов в классической установке клиента Microsoft Dynamics NAV

В классической установке клиента Microsoft Dynamics NAV замените следующие файлы с помощью исправления или файла обновления.

Имя файла Версия файла Размер файла Дата Время Платформа
Dbm.dll 6.0.31587.0 427,848 30 августа 2010 г. 16:28 x86
Fin.exe 6.0.31587.0 12,632,904 30 августа 2010 г. 16:28 x86
Finhlink.exe 6.0.31587.0 452,432 30 августа 2010 г. 16:28 x86
Finsql.exe 6.0.31587.0 12,754,768 30 августа 2010 г. 16:28 x86
Nc_netb.dll 6.0.31587.0 96,592 30 августа 2010 г. 16:28 x86
Nc_tcp.dll 6.0.31587.0 98,640 30 августа 2010 г. 16:28 x86
Nc_tcps.dll 6.0.31587.0 141,136 30 августа 2010 г. 16:28 x86
Ndbcs.dll 6.0.31587.0 1,350,480 30 августа 2010 г. 16:28 x86
Slave.exe 6.0.31587.0 152,400 30 августа 2010 г. 16:28 x86

Чтобы заменить существующие файлы Microsoft Dynamics NAV, выполните следующие действия.

  1. Закройте классический клиент Microsoft Dynamics NAV.

  2. Найдите каталог установки классического клиента Microsoft Dynamics NAV. Классический клиент Microsoft Dynamics NAV обычно устанавливается в следующем каталоге:

    C:\Program Files\Microsoft Dynamics NAV\60\Classic

  3. Скопируйте скачанные файлы.

  4. Вставьте скачанные файлы в каталог установки классического клиента Microsoft Dynamics NAV.

  5. Нажмите кнопку Да , чтобы перезаписать файлы в каталоге.

Шаг 2. Замена файлов в установке клиента Microsoft Dynamics NAV RoleTailored

В установке клиента Microsoft Dynamics NAV RoleTailored замените следующие файлы с помощью исправления или файла обновления.

Имя файла Версия файла Размер файла Дата Время Платформа
Microsoft.dynamics.framework.patterns.dll 1.3.10803.301 71,656 23 августа 2010 г. 06:30 x86
Microsoft.dynamics.framework.ui.dll 1.3.10803.301 698,328 23 августа 2010 г. 06:30 x86
Microsoft.dynamics.framework.ui.mapping.dll 1.3.10803.301 104,424 23 августа 2010 г. 06:30 x86
Microsoft.dynamics.framework.ui.navigation.dll 1.3.10803.301 34,800 23 августа 2010 г. 06:30 x86
Microsoft.dynamics.framework.ui.ux2006.dll 1.3.10803.301 88,040 23 августа 2010 г. 06:30 x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll 1.3.10803.301 63,480 23 августа 2010 г. 06:30 x86
Microsoft.dynamics.framework.ui.windows.dll 1.3.10803.301 83,944 23 августа 2010 г. 06:30 x86
Microsoft.dynamics.framework.ui.winforms.controls.dll 1.3.10803.301 2,115,584 23 августа 2010 г. 06:30 x86
Microsoft.dynamics.framework.ui.winforms.dll 1.3.10803.301 694,248 23 августа 2010 г. 06:30 x86
Microsoft.dynamics.nav.client.builder.dll 6.0.31587.0 198,544 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.client.exe 6.0.31587.0 149,376 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.client.interop.communicator.dll 1.0.559.183 75,688 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.client.serviceconnection.dll 6.0.31587.0 104,352 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.client.ui.dll 6.0.31587.0 509,824 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.client.winforms.dll 6.0.31587.0 341,904 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.client.winforms.tlb Неприменимо 2,680 30 августа 2010 г. 12:11 Неприменимо
Microsoft.dynamics.nav.language.dll 6.0.31587.0 2,000,768 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.types.dll 6.0.31587.0 567,160 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.watson.dll 6.0.31587.0 42,880 30 августа 2010 г. 16:10 x86
Microsoft.office.interop.outlook.dll 10.0.4504.0 395,136 30 августа 2010 г. 16:28 x86

Чтобы заменить эти файлы, выполните следующие действия.

  1. Закройте клиент Microsoft Dynamics NAV RoleTailored.

  2. Найдите каталог установки клиента Microsoft Dynamics NAV RoleTailored. Клиент Microsoft Dynamics NAV RoleTailored обычно устанавливается в следующем каталоге:

    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client

  3. Скопируйте скачанные файлы.

  4. Вставьте скачанные файлы в каталог установки клиента Microsoft Dynamics NAV RoleTailored.

  5. Нажмите кнопку Да , чтобы перезаписать файлы в каталоге.

Шаг 3. Замена файлов в установке microsoft Dynamics NAV Server

В установке microsoft Dynamics NAV Server замените следующие файлы с помощью исправления или файла обновления.

Имя файла Версия файла Размер файла Дата Время Платформа
Httpcfg.exe 5.2.3790.0 22,352 30 августа 2010 г. 16:28 x86
Microsoft.dynamics.nav.language.dll 6.0.31587.0 2,000,768 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.ncl.dll 6.0.31587.0 608,120 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.server.exe 6.0.31587.0 141,184 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.service.dll 6.0.31587.0 145,280 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.service.runtime.dll 6.0.31587.0 75,664 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.service.webservices.dll 6.0.31587.0 145,304 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.types.dll 6.0.31587.0 567,160 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.watson.dll 6.0.31587.0 42,880 30 августа 2010 г. 16:10 x86
Nclcsrt.etx Неприменимо 89,525 30 августа 2010 г. 08:31 Неприменимо
Nclcsrt.stx Неприменимо 91,724 30 августа 2010 г. 08:31 Неприменимо
Nclcsrts.dll 6.0.31587.0 1,485,648 30 августа 2010 г. 16:27 x86
Ndbcs.dll 6.0.31587.0 1,350,480 30 августа 2010 г. 16:27 x86

Чтобы заменить эти файлы, выполните следующие действия.

  1. Остановите сервер Microsoft Dynamics NAV.

  2. Найдите каталог установки Сервера Microsoft Dynamics NAV. Сервер Microsoft Dynamics NAV обычно устанавливается в следующем каталоге:

    C:\Program Files\Microsoft Dynamics NAV\60\Service

  3. Скопируйте скачанные файлы.

  4. Вставьте скачанные файлы в каталог установки Microsoft Dynamics NAV Server.

  5. Нажмите кнопку Да , чтобы перезаписать файлы в каталоге.

  6. Запустите microsoft Dynamics NAV Server.

Шаг 4. Замена файлов в установке сервера приложений Microsoft Dynamics NAV

Если у вас установлен сервер приложений Microsoft Dynamics NAV, замените следующие файлы в установке сервера приложений Microsoft Dynamics NAV с помощью исправлений или файлов обновления.

Имя файла Версия файла Размер файла Дата Время Платформа
Dbm.dll 6.0.31587.0 427,848 30 августа 2010 г. 16:28 x86
Nas.exe 6.0.31587.0 2,271,560 30 августа 2010 г. 16:28 x86
Nassql.exe 6.0.31587.0 2,370,384 30 августа 2010 г. 16:28 x86
Ndbcs.dll 6.0.31587.0 1,350,480 30 августа 2010 г. 16:28 x86
Slave.exe 6.0.31587.0 152,400 30 августа 2010 г. 16:28 x86

Чтобы заменить файлы, выполните следующие действия.

  1. Остановите сервер приложений Microsoft Dynamics NAV.

  2. Найдите каталог установки сервера приложений Microsoft Dynamics NAV. Сервер приложений Microsoft Dynamics NAV обычно устанавливается в следующем каталоге:

    C:\Program Files\Microsoft Dynamics NAV\60\Application Server

  3. Скопируйте скачанные файлы.

  4. Вставьте скачанные файлы в каталог установки сервера приложений Microsoft Dynamics NAV.

  5. Нажмите кнопку Да , чтобы перезаписать файлы в каталоге.

  6. Запустите сервер приложений Microsoft Dynamics NAV.

Шаг 5. Замена файлов в установке пакета SDK Microsoft Dynamics NAV

Если у вас установлен пакет SDK Microsoft Dynamics NAV, замените следующие файлы.

Имя файла Версия файла Размер файла Дата Время Платформа
Cf.h Неприменимо 57,736 30 августа 2010 г. 12:11 Неприменимо
Cfront.dll 6.0.31587.0 1,577,808 30 августа 2010 г. 16:28 x86
Cfront.ocx 6.0.31587.0 111,952 30 августа 2010 г. 16:28 x86
Cfrontsql.dll 6.0.31587.0 1,787,736 30 августа 2010 г. 16:28 x86
Libload.c Неприменимо 31,718 30 августа 2010 г. 06:51 Неприменимо
Microsoft.dynamics.nav.cfront.cfrontdotnet.dll 6.0.31587.0 182,168 30 августа 2010 г. 16:10 x86
Microsoft.dynamics.nav.cfront.cfrontdotnet.xml Неприменимо 442,447 30 августа 2010 г. 07:12 Неприменимо
Sample.c Неприменимо 28,718 30 августа 2010 г. 06:51 Неприменимо
Sample.exe 6.0.31587.0 152,400 30 августа 2010 г. 16:28 x86

Чтобы заменить файлы, выполните следующие действия.

  1. Найдите каталоги установки пакета SDK microsoft Dynamics NAV. Пакет SDK Microsoft Dynamics NAV обычно устанавливается в следующих каталогах:

    C:\Program Files\Microsoft Dynamics NAV\60\SDK\CFRONT
    C:\Program Files\Microsoft Dynamics NAV\60\SDK\Communication Components
    C:\Program Files\Common Files\Microsoft Dynamics NAV\Communication Component

  2. Выберите пакет SDK для обновления: C/Front или Communication Components.

  3. Скопируйте скачанные файлы.

  4. Вставьте скачанные файлы в соответствующий каталог установки пакета SDK Microsoft Dynamics NAV.

  5. Нажмите кнопку Да , чтобы перезаписать файлы в каталоге.

Примечание. Если вы загрузили исправление или обновление для компонентов связи, необходимо зарегистрировать файлы .dll по отдельности.

Шаг 6. Замена файлов в установке драйвера ODBC ДЛЯ Microsoft Dynamics NAV

Если у вас установлен драйвер ODBC Microsoft Dynamics NAV, замените следующие файлы в установке драйвера ODBC Microsoft Dynamics NAV.

Имя файла Версия файла Размер файла Дата Время Платформа
Cfront.dll 6.0.31587.0 1,577,808 30 августа 2010 г. 16:28 x86
Dbm.dll 6.0.31587.0 427,848 30 августа 2010 г. 16:28 x86
Nc_netb.dll 6.0.31587.0 96,592 30 августа 2010 г. 16:28 x86
Nc_tcp.dll 6.0.31587.0 98,640 30 августа 2010 г. 16:28 x86
Nc_tcps.dll 6.0.31587.0 141,136 30 августа 2010 г. 16:28 x86
Nodbc.dll 6.0.31587.0 2,141,008 30 августа 2010 г. 16:28 x86
Nodbc.xml Неприменимо 1,209 25 августа 2009 г. 16:43 Неприменимо
Nodbccfg.cfg 6.0.31587.0 724,480 30 августа 2010 г. 08:05 Неприменимо
Nodbccfg.xml Неприменимо 2,472 25 августа 2009 г. 16:43 Неприменимо
Slave.exe 6.0.31587.0 152,400 30 августа 2010 г. 16:28 x86

Чтобы заменить файлы, выполните следующие действия.

  1. Найдите каталог установки драйвера ODBC MICROSOFT Dynamics NAV. Драйвер ODBC MICROSOFT Dynamics NAV обычно устанавливается в следующем каталоге:

    C:\Program Files\Microsoft Dynamics NAV\60\ODBC

  2. Скопируйте скачанные файлы.

  3. Вставьте скачанные файлы в каталог установки драйвера ODBC MICROSOFT Dynamics NAV.

  4. Нажмите кнопку Да , чтобы перезаписать файлы в каталоге.

Необходимые условия

Для применения этого исправления необходимо установить Microsoft Dynamics NAV 2009 с пакетом обновления 1 (SP1).

Временное решение

Чтобы обойти эту проблему, определите макет для отчетов, которые выполняются в быстрой последовательности из RTC. Если макет отчета определен, RTC будет запускать отчет с помощью собственного обработчика отчетов. Таким образом, RTC не запускает несколько сеансов классического обработчика отчетов.

Состояние

Корпорация Майкрософт подтвердила, что это ошибка в продуктах Майкрософт, перечисленных в разделе "Применимо к".

Дополнительные сведения

Для получения дополнительных сведений щелкните следующий номер статьи, чтобы просмотреть статью в базе знаний Майкрософт:

824684 Описание стандартной терминологии, используемой для описания обновлений программного обеспечения Майкрософт

Примечание. Это статья "FAST PUBLISH", созданная непосредственно в организации поддержки Майкрософт. Информация, содержащаяся в настоящем документе, предоставляется как есть в ответ на возникающие проблемы. В результате быстрой доступности материалы могут содержать опечатки и могут быть пересмотрены в любое время без уведомления. Дополнительные рекомендации см. в разделе Условия использования .