Проблема
Почтовые ящики на недавно восстановленном многоролевом сервере (клиентский доступ и почтовые ящики), на котором работает Microsoft Exchange Server 2013, не могут получить доступ к службе занятости.
При возникновении этой проблемы в журнал записываются следующие ошибки.
Журналы Outlook (ETL-файлы):
Получатель: user@contoso.com
Исключение: ошибка веб-запроса прокси-сервера. , внутреннее исключение: Сбой запроса с состоянием HTTP 404: Не найдено.
Имя сервера: < проблемный сервер>
Тип исключения: ProxyWebRequestProcessingException
Код ответа: ErrorProxyRequestProcessingFailed
Журналы IIS на проблемном сервере:
POST /ews/exchange.asmx - 443 – <Client-IP> ExchangeInternalEwsClient-AuditLog - 404 0 0 15
POST /ews/exchange.asmx - 443 - <Client-IP> ExchangeInternalEwsClient-AuditLog - 404 0 0 15
POST /ews/exchange.asmx - 443 - <ASProxy-IP-адрес> клиента/CrossSite/Directory/EXCH/15.00.0847.030 - 404 0 0 0
POST /ews/exchange.asmx - 443 - <ASProxy-IP-адрес> клиента/CrossSite/Directory/EXCH/15.00.0847.030 - 404 0 0 0
Причина
Эта проблема возникает из-за неправильного изменения значения InternalNLBBypassUrl после выполнения операции аварийного восстановления на этом многоrole-сервере Exchange 2013.
Решение
Чтобы устранить эту проблему, исправьте значение InternalNLBBypassUrl для веб-служб Exchange (EWS) на проблемном сервере. Правильное значение InternalNLBBypassUrl должно быть следующим:
https://< Полное доменное имя> сервера: 444/ews/exchange.asmx
Для этого используется один из следующих способов.
Способ 1
Используйте ADSIEdit для изменения значения InternalNLBBypassUrl для EWS для этого проблемного сервера. Затем повторно запустите пул приложений MSExchangeServicesAppPool в IIS. После перезагрузки пула приложений EWS должен работать должным образом.
Способ 2
Используйте Windows PowerShell, чтобы изменить эти параметры.
Примечание. Windows PowerShell возвращает сообщение об ошибке «Не в допустимой области записи сервера».
Запустите Windows PowerShell.
Добавьте оснастку Exchange. Чтобы сделать это, выполните следующую команду:
Add-PSSnapin *обмен*
Выполните следующую команду:
Set-WebServicesVirtualDirectory -Identity "<проблемный сервер>\EWS (серверная часть Exchange)" -InternalNLBBypassUrl https://< полное доменное имя проблемного сервера>:444/ews/exchange.asmx