Исключение "0xe0434f4d" и сообщение об ошибке "0xC001000A" при создании плана обслуживания на сервере MSX

Применяется к
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2012 Web

Проблема

Рассмотрим следующий сценарий.

  • В качестве сервера master (MSX) вы используете Microsoft SQL Server 2012, Microsoft SQL Server 2008, Microsoft SQL Server 2008 R2 или Microsoft SQL Server 2005.
  • В качестве целевого сервера (TSX) используется SQL Server 2012.
  • Вы создаете многосерверный план обслуживания на сервере MSX.

В этом сценарии план обслуживания не реплицируется на сервер TSX. Кроме того, в журналах агент SQL Server на сервере TSX регистрируется сообщение об исключении, похожее на следующее:

Примечание

[073] Исключение (0xe0434f4d) произошло в подсистеме планов обслуживания

Примечание. В этом сообщении об ошибке "Имя плана субплана обслуживания" является заполнителем для плана субплана обслуживания.

Задания, связанные с планом обслуживания, реплицируются. Если вы попытаетесь выполнить задание на сервере TSX, появится сообщение об ошибке, похожее на следующее:

Примечание

Не удалось выполнить задание "Имя плана обслуживания клиента". Подробности см. в журнале.

Кроме того, в журнале заданий регистрируется информация, похожая на следующую:

Примечание

Не удалось загрузить пакет "Пакет планов обслуживания" из-за ошибки 0xC001000A. Описание: не удалось загрузить указанный пакет из базы данных SQL Server.

Примечание. В этом сообщении об ошибке вместо имени пакета плана подписки указано "Пакет плана обслуживания".

Причина

Эта проблема возникает из-за того, что агенту SQL Server не удается найти сборки Microsoft .NET Framework 2.0 задач плана обслуживания базы данных на сервере TSX.

Примечание. Сборки задач плана обслуживания баз данных обновляются до Microsoft платформа .NET Framework 4.0 в SQL Server 2012.

Состояние

Корпорация Майкрософт подтвердила, что это проблема продуктов Microsoft, перечисленных в разделе «Относится к».

Решение

Сведения о накопительном пакете обновления

Накопительный пакет обновления 2 для SQL Server 2012 с пакетом обновления 1 (SP1)

Исправление для этой проблемы впервые выпущено в накопительном пакете обновления 2. Дополнительные сведения о том, как получить этот накопительный пакет обновления для SQL Server 2012 SP1, см. в следующей статье базы знаний Майкрософт:

2790947 Накопительный пакет обновления 2 для SQL Server 2012 с пакетом обновления 1 (SP1) Так как сборки являются накопительными, каждый новый выпуск исправления содержит все исправления и исправления для системы безопасности, которые вошли в предыдущий выпуск исправления SQL Server 2012 с пакетом обновления 1 (SP1). Рекомендуется рассмотреть возможность применения последнего выпуска исправления, содержащего это исправление. Для просмотра статьи в базе знаний Майкрософт щелкните следующий номер статьи:

2772858 Сборки SQL Server 2012 г., выпущенные после выпуска SQL Server 2012 с пакетом обновления 1 (SP1)

Накопительный пакет обновления 5 для SQL Server 2012

Исправление этой проблемы впервые выпущено в накопительном пакете обновления 5. Для получения дополнительных сведений о том, как получить этот накопительный пакет обновления для SQL Server 2012, откройте статью со следующим номером в базе знаний Майкрософт:

2777772 Накопительный пакет обновления 5 за SQL Server 2012 г. Заметка Поскольку сборки являются накопительными, каждый новый выпуск исправления содержит все исправления и исправления для системы безопасности, включенные в предыдущий выпуск исправления SQL Server 2012 г. Рекомендуется рассмотреть возможность применения последнего выпуска исправления, содержащего это исправление. Для просмотра статьи в базе знаний Майкрософт щелкните следующий номер статьи:

2692828 Сборки SQL Server 2012 г., выпущенные после SQL Server 2012 г.
Чтобы устранить эту проблему, можно также создать файл конфигурации для агента SQL Server на сервере TSX. Для этого выполните указанные ниже действия.

  1. Удалите все существующие распределенные планы обслуживания на сервере MSX, которые не были реплицированы на сервер TSX.

  2. Создайте файл с именем SQLAGENT.EXE.CONFIG в следующей папке на сервере TSX SQL Server 2012:
    %Program Files%\Microsoft SQL Server\MSSQL11. MSSQLSERVER\MSSQL\Binn

  3. Добавьте в файл SQLAGENT.EXE.CONFIG следующее содержимое:

    <?xml version ="1.0"?>
    <configuration> 
    <startup useLegacyV2RuntimeActivationPolicy="true"> 
    <supportedRuntime version="v4.0"/> 
    </startup>
    </configuration>
    
  4. Перезапустите агент SQL Server на сервере TSX.

  5. Создайте новые планы обслуживания для нескольких серверов, предназначенные для сервера TSX.

Дополнительные сведения

Дополнительные сведения о совместимости серверов MSX и TSX можно найти на следующих веб-сайтах корпорации Майкрософт:

Создание многосерверной среды