Использование функции слияния в Word для создания и печати букв форм, использующих данные из листа Excel

Сводка

В этой статье объясняется, как использовать функцию слияния в Microsoft Word для создания и печати писем с форм с помощью данных на листе Microsoft Excel.

 При использовании функции Word слияния Word объединяет основной документ со списком получателей для создания набора выходных документов:

  • Основной документ содержит базовый текст, одинаковый во всех выходных документах. Он может содержать бланк, текст и инструкции в полях слияния для вставки текста (например, имен получателей и адресов), которые отличаются от одного выходного документа к другому.

  • Список получателей — это база данных, содержащая данные, которые должны быть объединены в выходные документы. Например, список получателей — это файл базы данных Microsoft Access или лист Excel.

    Эта база данных обычно представляет собой список имен, адресов, номеров телефонов и других категорий персональных данных.

  • Выходные документы являются результатом слияния. Текст в выходном документе может быть одинаковым во всех выходных документах, но форматирование можно применять к определенным документам.

Шаг 1. Настройка файла данных Excel

Прежде чем приступить к работе с мастером слияния, убедитесь, что лист Excel хорошо структурирован для этой цели. Обратите внимание на следующие требования к таблице данных:

  • Первая строка должна содержать имена полей для каждого столбца, например Title, Salutation, First Name, Middle Name, Last Name, Address1 и Address2.
  • Имя каждого поля должно быть уникальным.
  • Каждая строка должна содержать сведения о конкретном элементе. Например, в списке рассылки каждая строка может содержать сведения о конкретном получателе.
  • Таблица не должна содержать пустых строк.

Создайте файл данных Excel, а затем расположите его с помощью полей, которые вы хотите использовать для письма, как показано в следующем примере файла данных.

  После создания файла данных Excel сохраните его, а затем закройте файл данных.

Чтобы получить дополнительные сведения о создании списка адресов для слияния, щелкните следующий номер статьи, чтобы просмотреть статью в базе знаний Майкрософт:

294688 Создание и настройка списка адресов слияния в Word 2002 г. и более поздних версиях Word

Шаг 2. Настройка основного документа

  1. В Microsoft Office Word 2003 и более ранних версиях Word в меню Сервис наведите указатель мыши на пункт Письма и рассылки, а затем выберите Мастер слияния.

    В Microsoft Office Word 2007 нажмите кнопку Начать слияние в группе Начать слияние на вкладке Рассылки, а затем щелкните Мастер пошагового слияния.

  2. В разделе Выберите тип документа щелкните Буквы.

    Активный документ становится основным документом. Основной документ содержит текст и графику, одинаковые для каждой версии объединенного документа. Например, возвращаемый адрес и приветствие в букве формы одинаковы для каждой версии.

  3. Нажмите кнопку Далее: начальный документ.

  4. Используйте один из следующих методов:

    • Начните с документа, который в настоящее время отображается в окне документа. Для этого щелкните Использовать текущий документ.

       Затем можно ввести букву в окне документа или подождать, пока мастер не предложит сделать это позже.

    • Начните с шаблона. Для этого выполните указанные ниже действия.

      1. Нажмите кнопку Начать из шаблона.

      2. Щелкните Выбрать шаблон.

      3. На вкладке Слияние выберите нужный шаблон в диалоговом окне Выбор шаблона и нажмите кнопку ОК.

    • Начните с существующего документа. Для этого выполните указанные ниже действия.

      1. Щелкните Начать из существующего документа.
      2. В поле Начать с существующего выберите нужный документ и нажмите кнопку Открыть.
      3. Если документ не отображается, щелкните Другие файлы и нажмите кнопку Открыть. В диалоговом окне Открыть найдите нужный документ и нажмите кнопку Открыть.
  5. Щелкните Далее: Выбор получателей.

Шаг 3. Указание источника данных Excel

  1. В разделе Выберите получателей щелкните Использовать существующий список.

  2. Нажмите кнопку Обзор.

  3. В диалоговом окне Выбор источника данных найдите и щелкните лист Excel, который вы хотите использовать.

     По умолчанию Word открывает папку "Мои источники данных".

  4. Нажмите кнопку Открыть.

  5. Если лист Excel содержит сведения о нескольких вкладках, выберите вкладку, содержащую нужные сведения, и нажмите кнопку ОК.

  6. Все записи в источнике данных отображаются в диалоговом окне Получатели слияния. Здесь можно уточнить список получателей для включения в слияние.

Шаг 4. Выбор получателей

  1. В диалоговом окне Получатели слияния выберите получателей, которые нужно включить. Для этого используйте один из следующих методов:

    • Используйте поля проверка для назначения получателей.

       Этот метод целесообразно использовать, если список достаточно короткий. Щелкните, чтобы выбрать поля проверка рядом с получателями, которые вы хотите включить, а затем щелкните, чтобы очистить поля проверка рядом с получателями, которые нужно исключить.

      Примечание. Если вы хотите включить большую часть списка в слияние, нажмите кнопку Выбрать все, а затем — для очистки определенных записей. Аналогичным образом, если вы хотите включить в список только несколько записей, нажмите кнопку Очистить все, а затем выберите нужные записи.

    • Сортировка элементов в списке.

       Этот метод удобен, если вы хотите видеть элементы в алфавитном или числовом порядке. Щелкните заголовок столбца элемента, по которому требуется отсортировать. Например, чтобы отсортировать его в алфавитном порядке по фамилии, щелкните заголовок Фамилия.

    • Фильтрация элементов в списке.

       Этот метод полезен, если список содержит записи, которые, как вы знаете, не хотите видеть или включать в слияние. После фильтрации списка можно использовать поля проверка для включения и исключения записей, как описано выше. Чтобы отфильтровать список, выполните следующие действия.

      1. Щелкните стрелку рядом с заголовком столбца элемента, по которому требуется отфильтровать.

      2. Выберите один из следующих пунктов:

        • (Пустые). Этот параметр отображает все записи, в которых соответствующее поле пусто.
        • (Nonblanks). Этот параметр отображает все записи, в которых соответствующее поле содержит сведения.
        • Если источник данных содержит записи, которые содержат одну и ту же информацию, и если в столбце содержится 10 или меньше уникальных значений, можно выполнить фильтрацию по определенным сведениям. Например, если существует несколько адресов, в которых Австралия указана в качестве страны, можно выполнить фильтрацию по Австралии.
    • В диалоговом окне Получатели слияния отобразятся только записи, соответствующие условиям. Чтобы снова отобразить все записи, нажмите (Все).

    Заметки

    • Для расширенной сортировки и фильтрации щелкните стрелку рядом с именем любого столбца, а затем щелкните (Дополнительно). Используйте вкладки Фильтрация записей и Сортировать записи, чтобы настроить нужный запрос сортировки или фильтрации.
    • Если у вас установлено программное обеспечение для проверки адресов, нажмите кнопку Проверить в диалоговом окне Получатели слияния, чтобы проверить адреса получателей.
  2. Нажмите кнопку ОК, чтобы вернуться к мастеру слияния.

     Word использует получателей, назначенных для слияния.

  3. Нажмите кнопку Далее: напишите письмо.

Шаг 5. Заполнение полей "Буква" и "Добавление полей слияния"

Если вы еще не сделали этого, введите текст, который должен отображаться в каждой букве формы в основном документе.

Вставка полей слияния

Вставьте поля слияния, в которые нужно объединить имена, адреса и другие сведения из источника данных. Чтобы вставить поля слияния, выполните следующие действия.

  1. В основном документе щелкните место, куда нужно вставить поле.

  2. Вставьте любой из следующих элементов:

    • Блок адреса с именем, почтовым адресом и прочими сведениями

      1. Выберите команду Блок адреса.

      2. В диалоговом окне Вставка блока адреса выберите элементы адреса, которые требуется включить, и нужные форматы. Затем нажмите кнопку ОК. Для получения справки по параметру щелкните вопросительный знак, а затем выберите параметр .

      3. Для получения справки по параметру щелкните вопросительный знак, а затем выберите параметр . Если появится диалоговое окно Поля сопоставления, Word может не найти некоторые сведения, необходимые для блока адресов. Щелкните стрелку рядом с
        (недоступно), а затем выберите поле из источника данных, соответствующее полю, необходимому для слияния.

    • Строка приветствия:

      1. Щелкните Строка приветствия.

      2. Выберите формат строки приветствия, формат имени и последующие знаки препинания.

      3. Выделите текст, который должен отображаться в тех случаях, когда Word не могут интерпретировать имя получателя. Например, Word не может интерпретировать имя, если источник данных не содержит имени или фамилии получателя, а только название компании.

      4. Нажмите кнопку "ОК".

      5. Если появится диалоговое окно Поля совпадения, Word может не найти некоторые сведения, необходимые для строки приветствия. Щелкните стрелку рядом с элементом (недоступно), а затем выберите поле из источника данных, соответствующее полю, необходимому для слияния.

    • Другие поля информации:

      1. Щелкните Другие элементы.

      2. Используйте один из следующих методов:

        • Щелкните Поля адреса, чтобы выбрать поля адресов, которые будут автоматически сопоставляться с соответствующими полями в источнике данных, даже если поля источника данных не имеют того же имени, что и ваши поля.
        • Щелкните Поля базы данных, чтобы выбрать поля, которые всегда принимают данные непосредственно из столбца в базе данных.
      3. В списке Поля выберите нужное поле.

      4. Нажмите кнопку Вставить, а затем кнопку Закрыть.

      5. Если появится диалоговое окно Совпадение полей, Word может не найти некоторые сведения, необходимые для вставки поля. Щелкните стрелку рядом с элементом (недоступно) и выберите поле из источника данных, соответствующее полю, необходимому для слияния.

        Примечание. Если вы вставляете поле из списка Поля базы данных, а затем переключитесь на источник данных, который не содержит столбец с таким же именем, Word не сможет вставить сведения о поле в объединенный документ.

    • Электронная почта:

      Чтобы добавить электронную почту, необходимо сначала установить электронную почтовую программу, например, ту, которую можно приобрести у стороннего поставщика в Интернете. Чтобы использовать электронную почту, выполните следующие действия:

      1. Щелкните Электронная почта.

         Если у вас не установлена электронная почтовая программа, Word предложит установить ее и предложит подключиться к следующему веб-сайту Microsoft Office:
        Печать онлайн-почты
        http://office.microsoft.com/services/service.aspx?sid=2.4

      2. Вставьте почтовый запрос в соответствии с инструкциями программы.

    • Чтобы добавить электронную почту, необходимо сначала установить электронную почтовую программу, например, ту, которую можно приобрести у стороннего поставщика в Интернете. Чтобы использовать электронную почту, выполните следующие действия: Почтовый штрихкод. Необходимо выбрать тип письма или конверта, который поддерживает линейчатый код POSTNET. Чтобы использовать почтовый линейчатый код, выполните следующие действия.

      1. Щелкните Почтовый штрихкод.

      2. В диалоговом окне Вставка почтового линейчатого кода выберите соответствующие поля адреса.

        Примечание. Параметр Почтовый штрихкод отображается только в том случае, если вы используете версию Word на языке США.

      3. Повторите шаги a и b для всех полей, которые требуется вставить. Примечания.

        • Невозможно ввести символы поля слияния (" ") или вставить их с помощью команды Символ в меню Вставка.
        • Если поля слияния отображаются внутри фигурных скобок, например { MERGEFIELD City }, Word отображает коды полей вместо результатов полей. Это не влияет на слияние, но если вы хотите вместо этого отобразить результаты, щелкните правой кнопкой мыши код поля и выберите пункт Переключить коды полей в контекстном меню.

      Например, при использовании примера базы данных, показанного ранее, письмо может содержать поля AddressBlock и GreetingLine, поэтому первая страница будет выглядеть примерно так:
      26 февраля 2002 г.

      AddressBlock

      GreetingLine

      Введите письмо здесь.

      С уважением,

      Введите здесь свое имя.

    Примечание. Панель инструментов слияния также можно использовать для вставки полей слияния, работы с основным документом слияния или выполнения слияния. Чтобы отобразить панель инструментов Слияние, в меню Сервис наведите указатель мыши на пункт Письма и рассылки , а затем выберите пункт Показать панель инструментов слияния.

    На панели инструментов Слияния содержатся дополнительные команды, которые не включены в области задач мастера слияния. Например, можно использовать меню Вставка поля Word на панели инструментов слияния, чтобы вставить Word поля для управления процессом слияния. Например, можно вставить поле IF, которое вставляет текст только в том случае, если определенное поле слияния имеет указанное значение.

    Кроме того, можно нажать кнопку Проверить наличие ошибок, чтобы Word выполнить слияние и сообщить об ошибках, содержащихся в основном документе.

Изменение формата объединенных данных

Чтобы отформатировать объединенные данные, необходимо отформатировать поля слияния в основном документе. Не форматируйте данные в источнике данных, так как их форматирование не сохраняется при слиянии данных с документом. Чтобы изменить формат объединенных данных, выполните следующие действия.

  1. В основном документе выберите поле, содержащее сведения, которые нужно отформатировать, включая вложенные символы поля слияния (<<>>).

  2. В Word 2003 и более ранних версиях Word в меню Формат выберите пункт Шрифт, а затем выберите нужные параметры.

    В Word 2007 выберите нужный параметр в поле Шрифты темы в группе Шрифты на вкладке Главная.

Форматирование с помощью кодов полей

Чтобы управлять другими аспектами форматирования, нажмите клавиши ALT+F9, чтобы отобразить коды полей, а затем добавьте переключатели в поля слияния. При работе с полями переключатель — это специальная инструкция, которая вызывает определенное действие. Как правило, переключатель добавляется в поле для изменения результата.

Ниже приведены примеры использования коммутаторов.

  • Чтобы отобразить число 34987.89 как 34 987,89 долл. США, добавьте переключатель Числовое изображение (\#).
  • Чтобы напечатать имена клиентов прописными буквами, добавьте параметр Формат (\*).
  • Чтобы убедиться, что объединенные сведения имеют тот же шрифт и размер точки, что и к полю слияния, добавьте параметр Charformat (\*).

Шаг 6. Сохранение документа

После завершения основного документа и вставки всех полей слияния убедитесь, что документ сохранен, прежде чем продолжить. Для этого выполните указанные ниже действия.

  1. В Word 2003 и более ранних версиях Word в меню Файл выберите команду Сохранить как.

    В Word 2007 нажмите кнопку Microsoft Office и нажмите кнопку Сохранить как.

  2. Присвойте документу имя и нажмите кнопку Сохранить.

  3. Нажмите кнопку Далее: предварительный просмотр писем.

Шаг 7. Предварительный просмотр букв и Fine-Tune списка получателей

Когда мастер отображает область задач "Шаг 5 Слияние", мастер заменяет каждое из полей слияния в основном документе, который содержит фактический текст из первой записи списка получателей. Таким образом, вы можете увидеть, как будет выглядеть первый выходной документ.

 Например, если вы продолжите использовать пример базы данных, показанный ранее, после нажатия кнопки Далее: Предварительный просмотр букв первая страница должна выглядеть так:

26 февраля 2002 г.

Эндрю Фуллер
908 W. Capital Way
Такома 98401

 Уважаемый Эндрю Фуллер,

Введите письмо здесь.

С уважением,

Введите свое имя здесь. Чтобы просмотреть дополнительные записи, используйте один из следующих методов:

  • Чтобы просмотреть элементы по порядку, нажмите кнопки со стрелками влево или вправо.
  • Чтобы найти и просмотреть определенный элемент, щелкните Найти получателя, а затем введите условия поиска в диалоговом окне Поиск записи.

При необходимости настройте список получателей. Для этого используйте один из следующих методов:

  • Чтобы исключить конкретного получателя из операции слияния, щелкните Исключить этого получателя.
  • Чтобы изменить список получателей, нажмите Изменить список получателей и внесите нужные изменения в диалоговом окне Получатели слияния.

Шаг 8. Завершение слияния

Чтобы завершить слияние, используйте любой из следующих методов.

Персонализация отдельных писем

Чтобы персонализировать отдельные элементы, вы фактически завершите слияние, а затем измените нужные сведения в итоговом объединенном документе. Для этого выполните указанные ниже действия.

  1. Щелкните Изменить отдельные буквы.

  2. В диалоговом окне Слияние с новым документом выберите записи, которые нужно объединить.

  3. Нажмите кнопку "ОК".

     Word создает и открывает новый объединенный документ. Основной документ также остается открытым, и вы можете вернуться к нему, если хотите изменить все документы.

  4. Прокрутите страницу до сведений, которые нужно изменить, а затем внесите изменения.

  5. Распечатайте или сохраните документ так же, как и любой обычный документ.

Чтобы распечатать буквы, используйте один из следующих методов:

  • Если вы персонализированы элементы и если объединенный документ активен, выполните следующие действия:

    1. В Word 2003 г. и в более ранних версиях Word в меню Файл щелкните Печать.

      В Word 2007 нажмите кнопку Microsoft Office и нажмите кнопку Печать.

    2. Выберите нужные параметры.

  • Если вы хотите распечатать непосредственно из мастера слияния, выполните следующие действия.

    1. На шаге 6 мастера слияния (завершение слияния) нажмите кнопку Печать.

    2. В диалоговом окне Слияние с принтером используйте один из следующих методов и нажмите кнопку ОК:

      • Чтобы распечатать все документы, нажмите кнопку Все.
      • Чтобы распечатать документ, который отображается в окне документа, щелкните Текущая запись.
      • Чтобы распечатать диапазон документов, нажмите кнопку От, а затем введите номера записей в поля От и По.
    3. В диалоговом окне Печать выберите нужные параметры.

Сохранение объединенных букв для последующего использования

Если вы хотите изменить объединенные буквы или сохранить их для последующего использования, их можно собрать в один документ. Для этого выполните указанные ниже действия.

  1. Щелкните Изменить отдельные буквы.

  2. В диалоговом окне Слияние с новым документом используйте один из следующих методов и нажмите кнопку ОК:

    • Чтобы объединить все документы, нажмите кнопку Все.
    • Чтобы объединить только документ, который отображается в окне документа, щелкните Текущая запись.
    • Чтобы объединить диапазон документов, нажмите кнопку От, а затем введите номера записей в поля От и По.
  3. Word открывает один новый документ, содержащий все отдельные буквы. Затем документ можно сохранить для последующего использования, как и любой обычный документ.

Ссылки

Для получения дополнительных сведений щелкните следующие номера статей, чтобы просмотреть статьи в базе знаний Майкрософт:

318117 Использование адресов с листа Excel для создания меток в Word

318115 Создание письма формы с использованием сведений из базы данных Access в Word 2002 г.

318112 Использование адресов из базы данных Access 2002 для создания меток в Word 2002

294686 Как использовать слияние для создания списка, отсортированного по категориям в Word 2002 и более поздних версиях Word

290408 часто задаваемые вопросы о слиянии в Word 2002

294688 Создание и настройка списка адресов слияния в Word 2002 г. и более поздних версиях Word

294693 Как использовать слияние для создания каталога в Word 2002 и более поздних версиях Word

294683 Использование слияния для создания писем форм в Word 2002 и более поздних версиях Word