Перейти к основному контенту
Поддержка
Войдите с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Выберите другую учетную запись.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой нужно войти.

Проблемы

Рассмотрим следующий сценарий.

  • NetBIOS-имя домена Active Directory содержит символ в среде Microsoft Exchange Server 2010 амперсанда (&).

  • При попытке установить Пакет обновления 1 (SP1) для Exchange Server 2010 на сервере в среде.

В этом случае происходит сбой установки. Кроме того, появляется приведенное ниже сообщение об ошибке:

Произошла ошибка при разборе EntityName. Line7, положение 12.

Причина

Эта проблема возникает, поскольку знак амперсанда является зарезервированным знаком в XML. Таким образом символ приводит анализ текущего пользователя входа в систему к сбою.

Решение

Чтобы решить проблему, выполните описанные ниже действия. Примечание. Эта проблема решена в накопительный пакет обновления 4 для Exchange Server 2010 Пакет обновления 1. Дополнительные сведения см. в следующей статье базы знаний Майкрософт:

2579150 Описание накопительного пакета обновления 4 для Exchange Server 2010 Пакет обновления 1

  1. Скопировать файлы установки с компакт-диска на жесткий диск, а затем откройте файл ManageScheduledTask.ps1 в папку «скрипты».

  2. Найдите следующие строки:

    function Get-CurrentUserName { [System.Security.Principal.WindowsIdentity]$id = [System.Security.Principal.WindowsIdentity]::GetCurrent() $id.Name }
  3. Измените строки следующим образом:

    function Get-CurrentUserName{ [System.Security.Principal.WindowsIdentity]$id = [System.Security.Principal.WindowsIdentity]::GetCurrent() [System.String]$fixedName = $id.Name.Replace('&','`&') return $fixedName }
  4. Сохраните файл и повторно попробуйте установить Exchange Server 2010 с пакетом обновления 1 с жесткого диска.

  5. Установите следующие обновления:

    2579150 Описание накопительного пакета обновления 4 для Exchange Server 2010 Пакет обновления 1

Статус

Корпорация Майкрософт подтверждает наличие этой проблемы в своих продуктах, которые перечислены в разделе "Применяется к".

Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.

В сообществах можно задавать вопросы и отвечать на них, отправлять отзывы и консультироваться с экспертами разных профилей.

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?
После нажатия кнопки "Отправить" ваш отзыв будет использован для улучшения продуктов и служб Майкрософт. Эти данные будут доступны для сбора ИТ-администратору. Заявление о конфиденциальности.

Спасибо за ваш отзыв!

×