Перейти к основному контенту
Поддержка
Войдите с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Выберите другую учетную запись.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой нужно войти.

Симптомы

Компьютер под управлением Windows Server 2003 перестает отвечать на запросы при завершении работы компьютера в сеанс удаленной консоли. Эта проблема возникает случайным образом.

Примечание. Может установить сеанс удаленной консоли с помощью средства подключения к удаленному рабочему столу (Mstsc.exe) с параметром/Console .

Причина

В обычный процесс завершения работы Windows Server 2003 операционная система имеет период ожидания, в течение которого диспетчер управления службами (SCM) завершает работу службы. Если диспетчер управления Службами не завершается завершает работу всех служб в течение периода тайм-аута, операционная система продолжает завершить работу без ожидания. Период ожидания задается в записи реестра WaitToKillServiceTimeout. По умолчанию период ожидания длится 20 секунд.

Однако если компьютер выключается во время сеанса удаленной консоли, операционная система продолжает завершить работу независимо от периода тайм-аута. В этом случае операционная система продолжает завершение работы через несколько секунд после SCM отправляет уведомление о завершении работы службы. Затем драйвер NTFS начинается на завершение работы в рамках процесса завершения работы системы. Драйвер NTFS начинает завершить работу раньше, чем ожидалось, если служба по-прежнему завершает работу. Служба может обращаться к ресурсам диск при завершении работы. Взаимоблокировки, вероятно возникновение завершение работы NTFS и доступа к ресурсам диска.

Решение

Важно. Это исправление заменяет исправление для старых, которое было выпущено с тем же номером статьи базы знаний Майкрософт (930045). Если старый исправления уже применено, необходимо удалить старый исправление и затем установить последнее исправление. Чтобы удалить старые исправления, используйте элемент Установка и удаление программ панели управления.

Сведения об исправлении

Существует исправление от корпорации Майкрософт. Однако данное исправление предназначено для устранения только проблемы, описанной в этой статье. Применяйте данное исправление только в тех системах, которые имеют данную проблему. Это исправление может проходить дополнительное тестирование. Таким образом если вы не подвержены серьезно этой проблеме, рекомендуется дождаться следующего пакета обновления, содержащего это исправление.

Если исправление доступно для скачивания, имеется раздел "Пакет исправлений доступен для скачивания" в верхней части этой статьи базы знаний. Если этот раздел не отображается, обратитесь в службу поддержки для получения исправления.

Примечание. Если наблюдаются другие проблемы или необходимо устранить неполадки, вам может понадобиться создать отдельный запрос на обслуживание. Стандартная оплата за поддержку будет взиматься только за дополнительные вопросы и проблемы, которые не соответствуют требованиям конкретного исправления. Полный список телефонов поддержки и обслуживания клиентов корпорации Майкрософт или создать отдельный запрос на обслуживание посетите следующий веб-узел корпорации Майкрософт:

http://support.microsoft.com/contactus/?ws=supportПримечание. В форме "Пакет исправлений доступен для скачивания" отображаются языки, для которых доступно исправление. Если нужный язык не отображается, значит исправление для данного языка отсутствует.

Предварительные условия

Для установки этого исправления требуется Пакет обновления 1 для Windows Server 2003 или Windows Server 2003 Пакет обновления 2 на компьютере. Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:

889100 как получить последний пакет обновления для Windows Server 2003

Необходимость перезагрузки

После установки исправления компьютер необходимо перезагрузить.

Сведения о замене исправлений

Это исправление не заменяет других исправлений.

Сведения о файлах

Английская версия данного исправления содержит атрибуты файла (или более поздние атрибуты файлов), приведенные в следующей таблице. Дата и время для этих файлов указаны в формате общего скоординированного времени (UTC). При просмотре сведений о файле, он преобразуется в локальное время. Чтобы узнать разницу между временем по Гринвичу и местным временем, откройте вкладку Часовой пояс элемента Дата и время в панели управления.

Windows Server 2003 с Пакет обновления 1 для систем на базе x86

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Termsrv.dll

5.2.3790.3043

246,272

14-Nov-2007

09:19

x86

Windows Server 2003 with Service Pack 2, x86 под управлением версий

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Termsrv.dll

5.2.3790.4188

246,272

14-Nov-2007

09:15

x86

Windows Server 2003 с пакетом обновления 1 для систем на базе процессоров Itanium

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Termsrv.dll

5.2.3790.3043

698,368

14-Nov-2007

07:08

IA-64

Windows Server 2003 с пакетом обновления 2, для систем на базе процессоров Itanium

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Termsrv.dll

5.2.3790.4188

698,880

14-Nov-2007

07:12

IA-64

Windows Server 2003 для систем на базе x64

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Termsrv.dll

5.2.3790.3043

365,056

14-Nov-2007

07:08

x64

Windows Server 2003 with Service Pack 2, x64 под управлением версий

Имя файла

Версия файла

Размер файла

Дата

Время

Платформа

Termsrv.dll

5.2.3790.4188

365,056

14-Nov-2007

07:14

x64

Временное решение

Чтобы обойти эту проблему, не перезагрузите компьютер под управлением Windows Server 2003 в сеанс удаленной консоли. Или не завершить работу компьютера под управлением Windows Server 2003 в сеанс удаленной консоли.

Статус

Корпорация Майкрософт подтверждает, что это проблема продуктов Майкрософт, перечисленных в разделе "Относится к".

Дополнительные сведения

Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:

Описание 824684 Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт

Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.

В сообществах можно задавать вопросы и отвечать на них, отправлять отзывы и консультироваться с экспертами разных профилей.

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?
После нажатия кнопки "Отправить" ваш отзыв будет использован для улучшения продуктов и служб Майкрософт. Эти данные будут доступны для сбора ИТ-администратору. Заявление о конфиденциальности.

Спасибо за ваш отзыв!

×