Applies ToExchange Server 2013 Enterprise Edition Exchange Server 2013 SP1 Exchange Server 2013 Standard Edition

Симптомы

Пользователи не может получить доступ к почтовому ящику в Outlook Web App (OWA) или Microsoft Exchange ActiveSync (EAS) при выполнении обоих из следующих условий:

  • Все почтовые ящики переносятся из базы данных почтовых ящиков.

  • В исходной базе данных почтовых ящиков удаляется из организации.

При попытке входа в OWA, они получают пустую страницу или «HTTP 500» сообщение об ошибке. Например они получают следующее сообщение об ошибке: 

Веб-узел не может отобразить страницу HTTP 500

При выполнении командлета ActiveSyncConnectivity тест может появиться выходные данные, похожее на следующее:ClientAccessServer........: exch1.tailspintoys.comScenario................. : OptionsScenarioDescription.......: Issue an HTTP OPTIONS command to retrieve the Exchange ActiveSync protocol version.Result....................: FailureError.....................: [System.Net.WebException]: The remote server returned an error: (500) Internal Server............................Error.............................HTTP response headers:............................request-id: 20a9d8d4-5019-4048-9bf1-b659ef00fee4............................X-CasErrorCode: DatabaseGuidNotFound............................X-FailureContext: FrontEnd;500;RGF0YWJhc2VHdWlkTm90Rm91bmQ=;VGhlIGRhdGFiYXNlIHdpdGggSUQgM............................2QxNTMxYzktODEwOC00OGRiLWIyMmUtOTUxMzZkMWI4MjNlIGNvdWxkbid0IGJlIGZvdW5kLg==;DatabaseGuidNotFound;;............................X-FEServer: EXCH1............................Content-Length: 0............................Cache-Control: private............................Date: Tue, 08 Apr 2014 20:17:57 GMT............................Server: Microsoft-IIS/8.5............................X-AspNet-Version: 4.0.30319............................X-Powered-By: ASP.NET

Причина

Эта проблема возникает из-за содержащихся в клиентские файлы cookie пользователя почтового ящика идентификатор GUID базы данных (источника) и добавляется в кэш сервера на сервере клиентского доступа (CAS). HTTP-прокси на ЦС пытается найти базу данных почтовых ящиков, используя старый идентификатор GUID базы данных из кэша. Старый идентификатор GUID базы данных были удалены, попытка завершается неудачей и возвращает ошибку DatabaseGuidNotFound .

Решение

Для решения этой проблемы установите следующее обновление:

2961810 накопительного обновления 6 для Exchange Server 2013

Временное решение

Чтобы избежать этой проблемы, не удаляйте сразу же исходной базы данных почтовых ящиков после завершения перемещения почтового ящика.Чтобы обойти эту проблему, удалить все файлы cookie клиента и перезапустите пулы приложений MSExchangeOWAAppPool и MSExchangeSyncAppPool , чтобы очистить кэш сервера.

Статус

Корпорация Майкрософт подтверждает, что это проблема продуктов Майкрософт, перечисленных в разделе "Относится к".

Дополнительные сведения

Если база данных почтового ящика пользователя удалена после установки накопительного обновления 5 для Exchange Server 2013, может возникнуть одна из следующих проблем:

  • OWA пользователь получает «HTTP 500» сообщение об ошибке один раз. Последующие попытки войти в OWA успешно.

  • Если загружаются через https:///OWAдоменаузла OWA, пользователь может иметь снимите соответствующий файл cookie в веб-обозревателе. Это одноразовый при очистке.

Чтобы убедиться, что пользователи отправляют обновленные cookie, откройте среду управления Exchange на сервере, который имеет роль ЦС и запустите следующую команду:Get-ChildItem 'C:\Program Files\Microsoft\Exchange Server\V15\Logging\HttpProxy\Owa' | Select-String (Get-MailboxDatabase <OldMailboxDatabase>).Guid | ft Path,LineNumber -AutoSize Примечание. Эта команда также должен быть проверен с EAS папку в следующем месте:

C:\Program Files\Microsoft\Exchange Server\V15\Logging\HttpProxy\EasДля вывода журнала файла и номер строки, на котором расположен код GUID. При старой базы данных GUID больше не отображается в текущем журнале HttpProxy, следует удалить базу данных.

Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.

В сообществах можно задавать вопросы и отвечать на них, отправлять отзывы и консультироваться с экспертами разных профилей.