Проблемы
Рассмотрим следующий сценарий.
-
На сервере Microsoft Exchange Server 2013 или Microsoft Exchange Server 2016 в среде сосуществования используется либо оба сервера Microsoft Exchange Server 2010, либо Exchange Server 2007.
-
Почтовые ящики в этой среде подключаются через сервер Exchange Server 2013 (ЦС) или службу клиентского доступа Exchange Server 2016.
-
Пользователи в этой среде пытаются подключить к ним почтовые ящики Exchange Server 2010 или Exchange Server 2007 с помощью мобильного компонента Outlook.
В этом сценарии эти пользователи не могут установить соединение. Вместо этого они будут постоянно запрашивать свои учетные данные. Кроме того, клиенты Outlook могут оставаться в отключенном состоянии. Эта проблема также может повлиять на подключения Outlook к Exchange Server 2010 или Exchange Server 2007 устаревшие общедоступные папки или автономные адресные книги (OAB). Устранение неполадок указывает на то, что пользователи не могут подключаться к старым серверам клиентского доступа (ЦС) с помощью мобильного Outlook.
Причина
Эта проблема возникает в том случае, если серверы Exchange Server 2010 или Exchange Server 2007 с ролью CAS работают в Windows Server 2008 R2. Эта проблема возникает из-за того, что в глобальных учетных данных задан неверный флаг после изменения пароля компьютера для ЦС. Дополнительные сведения об этой проблеме содержатся в пакете исправлений, упомянутом в разделе "решение".
Решение
Чтобы устранить эту проблему, установите следующее обновление на всех ЦС Exchange Server 2010 и Exchange Server 2007, работающих в Windows Server 2008 R2:
3140410 Обновление для системы безопасности для Microsoft Windows, по которому можно получить разрешение на повышение прав: 8 марта 2016 г.Примечание. После установки этого обновления для системы безопасности необходимо перезагрузить компьютер.
Дополнительная информация
При возникновении этой проблемы в журналах прокси-сервера HTTP RPC может быть зарегистрирована ошибка, указанная ниже.
C:\Program Files\Microsoft\Exchange Server\V15\Logging\HttpProxy\RpcHttpЭта запись журнала напоминает следующее:Complete=PrepareServerRequest;,WebExceptionStatus=ProtocolError;ResponseStatusCode= 401;WebException=System.Net.WebException: The remote server returned an error: (401) Unauthorized. atSystem.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult) atMicrosoft.Exchange.HttpProxy.RpcHttpProxyRequestHandler.<>c__DisplayClass1.nullb__0 ();HttpException=System.Web.HttpException (0x80004005): NegotiateSecurityContext failed with for host 'mail.contoso.com' with status 'InvalidToken' at Microsoft.Exchange.HttpProxy.KerberosUtilities.GenerateKerberosAuthHeader.
Обходное решение
Чтобы обойти эту проблему, настройте пул приложений по умолчанию на всех центрах сертификации 2010/2007 для работы с учетной записью Network Service, а не с удостоверением пула приложений. Это временное решение. Чтобы изменить конфигурацию пула приложений по умолчанию, выполните указанные ниже действия.
-
Запустите диспетчер служб IIS.
-
Щелкните Пулы приложений, щелкните правой кнопкой мыши элемент DefaultAppPoolи выберите пункт Дополнительные параметры.
-
Нажмите кнопку Идентификацияи щелкните многоточие (...). →.
-
Щелкните стрелку раскрывающегося списка и найдите сетевую службу в списке Встроенная учетная запись.
-
Щелкните правой кнопкой мыши пул приложений по умолчанию , а затем выберите пункт " повторный запуск ".