Перейти к основному контенту
Поддержка
Войдите с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Выберите другую учетную запись.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой нужно войти.

Поддержка Windows Vista Пакет обновления 1 (SP1) заканчивается 12 июля 2011 г. Чтобы продолжать получать обновления для системы безопасности Windows, убедитесь, что вы работаете в Windows Vista с Пакет обновления 2 (SP2). Дополнительные сведения можно найти на этой веб-странице Майкрософт: прекращение поддержки некоторых версий Windows.

Проблемы

Рассмотрим следующий сценарий.

  • Вы работаете на windows XP Пакет обновления 3 (SP3), Windows Vista Пакет обновления 1 (SP1) или компьютере с Windows 7

  • Используйте имя пользователя, которое содержит двухбайтовую по набору символов (DBCS).

При попытке установить приложение, использующее распространяемый пакет Microsoft Visual C++ 2005, вы получаете следующее сообщение об ошибке:

Ошибка синтаксиса параметра командной строки. Введите команду/? Для справки.

Причина

Эта проблема возникает из-за того, что средство Self-Extractor Win32 Cabinet не может обрабатывать символы DBCS в имени пользователя.

Решение

Чтобы мы могли решить эту проблему для вас, перейдите в раздел"Устранитьэту проблему для меня". Чтобы устранить проблему самостоятельно, перейдите к разделу «Самостоятельное решение проблемы».

Помощь в решении проблемы



Чтобы устранить эту проблему автоматически, нажмите кнопку или ссылку "Исправить". Затем в диалоговом окне "Загрузка файла" нажмите кнопку "Выполнить" и следуйте шагам мастера fix it.




Примечания

  • Решение Fix it не будет работать, если ваша учетная запись не является учетной записью администратора.

  • Возможно, мастер доступен только на английском языке. При этом автоматическое исправление подходит для любых языковых версий Windows.

  • Решения по устранению проблем можно скачать на любой компьютер, а затем сохранить их на устройство флэш-памяти или компакт-диск и запустить на нужном компьютере.


Затем перейдите в раздел"Проблема была исправлена?"



Самостоятельное решение проблемы

Чтобы устранить эту неполадку, выполните следующие действия:

  1. Нажмите кнопку " Кнопка "Начните" ", щелкните правой кнопкоймыши "Компьютер" и выберите "Свойства".

  2. В области параметров компьютера, домена и группы щелкните "Изменить параметры".

     Разрешение на управление учетной записью пользователя  Если вам будет предложено ввести пароль администратора или подтвердить его, введите пароль или нажмите кнопку "Продолжить".

  3. Щелкните "Изменить параметры" и выберите вкладку "Дополнительные параметры". Нажмите кнопку "Переменные среды"

  4. В области переменных пользователя щелкните TEMP и нажмите кнопку "Изменить".

  5. В поле "Значение переменной" введите C:\Temp и нажмите кнопку "ОК" два раза.

  6. Нажмите кнопку Применить, а затем — ОК.

  7. Выполните действия 4-6 для переменной среды TMP.

  8. Утвердим, что папка C:\Temp существует, если она не существует.

  9. Перезагрузите компьютер.

  10. Попытаться установить приложение еще раз.


Проблема устранена?

  • Проверьте, устранена ли проблема. Если устранена, пропустите дальнейшие инструкции, приведенные в этом разделе. Если нет, обратитесь в службу технической поддержки.

  • Мы ценим ваши замечания. Чтобы оставить отзыв или сообщить о проблемах с этим решением, оставьте комментарий в блоге«Fix it for me»или отправьте нам сообщение электронной почты.

Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.

В сообществах можно задавать вопросы и отвечать на них, отправлять отзывы и консультироваться с экспертами разных профилей.

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?
После нажатия кнопки "Отправить" ваш отзыв будет использован для улучшения продуктов и служб Майкрософт. Эти данные будут доступны для сбора ИТ-администратору. Заявление о конфиденциальности.

Спасибо за ваш отзыв!

×