KB3201865 - การแก้ไข: เวลาการกู้คืนเป้าหมายของฐานข้อมูลที่ตั้งค่าเป็นค่าที่ไม่ใช่ศูนย์ทําให้เกิดการยืนยันและการหมดเวลาของการเช่าใน SQL Server

นำไปใช้กับ
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Enterprise Core SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1 SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

อาการ

สมมติว่าคุณมีเวลาการกู้คืนเป้าหมายของฐานข้อมูลเป็นค่าที่ไม่ใช่ศูนย์ใน Microsoft SQL Server 2012,2014 หรือ 2016 ถ้าการยืนยันเกิดขึ้นระหว่างกระบวนการตรวจสอบ การยืนยันนั้นจะทําให้การเช่าฐานข้อมูลหมดเวลา และคุณได้รับไฟล์บันทึกข้อมูลต่อไปนี้:

date time  spid14s Error: 17066, Severity: 16, State: 1.
 date time  spid14s SQL Server Assertion: File: <recoveryunit.cpp>, line=7849 Failed Assertion = 'm_ReducedDataSlice <= MaxReducedDataSlice'. This error may be timing-related. If the error persists after rerunning the statement, use DBCC CHECKDB to check the database for structural integrity, or restart the server to ensure in-memory data structures are not corrupted.
date time spid14s Error: 3624, Severity: 20, State: 1.
date time spid14s A system assertion check has failed. Check the SQL Server error log for details. Typically, an assertion failure is caused by a software bug or data corruption. To check for database corruption, consider running DBCC CHECKDB. If you agreed to send dumps to Microsoft during setup, a mini dump will be sent to Microsoft. An update might be available from Microsoft in the latest Service Pack or in a Hotfix from Technical Support.
 date time  spid14s Error: 18400, Severity: 16, State: 1.
 date time  spid14s The background checkpoint thread has encountered an unrecoverable error. The checkpoint process is terminating so that the thread can clean up its resources. This is an informational message only. No user action is required. 

การแก้ปัญหา

ปัญหานี้ได้รับการแก้ไขในการอัปเดตแบบสะสมต่อไปนี้สําหรับ SQL Server:

การอัปเดตสะสม 7 สําหรับ SQL Server 2012 Service Pack 3
      

การอัปเดตสะสม 3 สําหรับ SQL Server 2014 Service Pack 2

การอัปเดตสะสม 10 สําหรับ SQL Server 2014 Service Pack 1

การอัปเดตสะสม 4 สําหรับ SQL Server 2016

การอัปเดตสะสม 1 สําหรับ SQL Server 2016 SP1


เกี่ยวกับการอัปเดตสะสมสําหรับ SQL Server

เกี่ยวกับการอัปเดตสะสมสําหรับ SQL Server

การอัปเดตแบบสะสมใหม่แต่ละรายการสําหรับ SQL Server จะมีโปรแกรมแก้ไขด่วนและการแก้ไขข้อบกพร่องด้านความปลอดภัยทั้งหมดที่รวมอยู่ในการอัปเดตแบบสะสมครั้งก่อนหน้า ตรวจดูการอัปเดตแบบสะสมล่าสุดสําหรับ SQL Server:

     การอัปเดตสะสมล่าสุดสําหรับ SQL Server 2012 SP3

การอัปเดตสะสมล่าสุดสําหรับ SQL Server 2014การอัปเดตสะสมล่าสุดสําหรับ SQL Server 2016

      

วิธีแก้ไขปัญหาชั่วคราว

เมื่อต้องการแก้ไขปัญหานี้ ให้ตั้งค่าเวลาการกู้คืนเป้าหมายเป็นศูนย์สําหรับฐานข้อมูลที่ได้รับผลกระทบ

สถานะ

Microsoft ได้ยืนยันว่านี่เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ที่แสดงไว้ในส่วน "นำไปใช้กับ"

การอ้างอิง

เรียนรู้เกี่ยวกับ คําศัพท์ที่ Microsoft ใช้เพื่ออธิบายการอัปเดตซอฟต์แวร์