ข้ามไปที่เนื้อหาหลัก
การสนับสนุน
ลงชื่อเข้าใช้
ลงชื่อเข้าใช้ด้วย Microsoft
ลงชื่อเข้าใช้หรือสร้างบัญชี
สวัสดี
เลือกบัญชีอื่น
คุณมีหลายบัญชี
เลือกบัญชีที่คุณต้องการลงชื่อเข้าใช้

อาการ

หากการติดตั้งแอปพลิเคชันกําลังดําเนินการอยู่เมื่อ ccmsetup อัปเกรดไคลเอ็นต์Configuration Manager Microsoft System Center การติดตั้งแอปพลิเคชันอาจล้มเหลวหลังการอัปเกรด

หมายเหตุ การปรับใช้แอปพลิเคชันใหม่จะไม่ได้รับผลกระทบ

สําหรับแอปพลิเคชันที่มีการลบข้อมูลการร้องขอเนื้อหา การติดตั้งแอปพลิเคชันล้มเหลว และข้อความแสดงข้อผิดพลาดต่อไปนี้ถูกบันทึกในไฟล์ AppEnforce.log:

+++++ ล้มเหลวในการบังคับใช้แอป ข้อผิดพลาด0x87d01106
+++++ AppEnforce วันที่และเวลา 8128 (0x1FC0)

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากข้อมูลการร้องขอเนื้อหาถูกลบระหว่างการอัปเกรดเนื่องจากการเปลี่ยนแปลง Schema

ชั้นเรียนต่อไปนี้จะติดตามคําขอเนื้อหาที่ทําในระหว่างการติดตั้งแอปพลิเคชัน คลาสนี้ถูกลบระหว่างการอัปเกรดไคลเอ็นต์:

root\ccm\softmgmtagent:DownloadContentRequestEx2

สภาพแวดล้อมของฉันได้รับผลกระทบหรือไม่

เมื่อต้องการตรวจสอบว่าปัญหานี้มีอยู่หรือไม่ในสภาพแวดล้อมของคุณ ให้เรียกใช้แบบสอบถามต่อไปนี้บนฐานข้อมูลเซิร์ฟเวอร์ไซต์ของคุณ

select cia.AssignmentName, col.CollectionName  from CI_CurrentErrorDetails ced 

join CI_ConfigurationItems ci on ci.CI_ID = ced.CI_ID

join CI_AssignmentTargetedCIs cat on cat.CI_ID = ci.CI_ID

join CI_CIAssignments cia on cia.AssignmentID = cat.AssignmentID

join Collections_G col on col.CollectionID = cia.TargetCollectionID

where ced.ErrorCode in ( -2016407290)

group by cia.AssignmentName, col.CollectionName

ถ้าคิวรีส่งคืนผลลัพธ์ที่มีลักษณะดังต่อไปนี้ สภาพแวดล้อมของคุณจะได้รับผลกระทบ

ชื่องานที่มอบหมาย

ชื่อคอลเลกชัน

Adobe ผ่าน CMD_All Systems_Install

ระบบทั้งหมด

การแก้ไข

ปัญหานี้ได้รับการแก้ไขแล้วในเวอร์ชัน 1702 ที่พร้อมใช้งานทั่วโลก และในการอัปเดตต่อไปนี้สําหรับคลื่นลูกแรก 1702:

4018732 การอัปเดตสําหรับ System Center Configuration Managerเวอร์ชัน 1702 คลื่นลูกแรก

หมายเหตุ การอัปเดตนี้จะป้องกันไม่ให้เกิดปัญหาที่ระบุไว้ในส่วน "อาการ" เกิดขึ้นเมื่อ ccmsetup อัปเกรดไคลเอ็นต์Configuration Manager อย่างไรก็ตาม หากปัญหาเกิดขึ้นแล้ว การอัปเดตนี้จะไม่สามารถแก้ไขปัญหาได้ เมื่อต้องการแก้ไขปัญหาหลังจากที่เกิดปัญหาขึ้น ให้ทําตามขั้นตอนที่แสดงอยู่ในส่วน "แก้ไขปัญหาชั่วคราว"

วิธีแก้ไขปัญหาชั่วคราว

เมื่อต้องการแก้ไขปัญหานี้ชั่วคราว ให้ใช้หนึ่งในวิธีต่อไปนี้:

  • ยกเลิกการกําหนดเป้าหมายและกําหนดเป้าหมายแอปพลิเคชันที่ได้รับผลกระทบใหม่

  • ใช้งานการล้างข้อมูล RunOnce ทันทีหลังจากการอัปเกรดเสร็จสมบูรณ์ โดยทําตามขั้นตอนต่อไปนี้:

    1. สร้างแพคเกจและโปรแกรมการแจกจ่ายซอฟต์แวร์โดยใช้คําสั่งต่อไปนี้: powershell -executionpolicy bypass -noprofile -command "& {$query=gwmi -class CCM_CITask -namespace root\ccm\citasks; $query| rwmi}"

    2. ตั้งค่าการติดตั้งให้เรียกใช้หนึ่งครั้ง (โดยเฉพาะอย่างยิ่งเมื่อไม่มีผู้ใช้เข้าสู่ระบบ)

    3. ปรับใช้กับระบบที่ได้รับผลกระทบทั้งหมด

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "นำไปใช้กับ"


ผลิตภัณฑ์ที่ได้รับผลกระทบ

บทความนี้ยังนําไปใช้กับ:

  • Configuration Manager Microsoft System Center (Current Branch - เวอร์ชัน 1702)

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ต้องการตัวเลือกเพิ่มเติมหรือไม่

สํารวจสิทธิประโยชน์ของการสมัครใช้งาน เรียกดูหลักสูตรการฝึกอบรม เรียนรู้วิธีการรักษาความปลอดภัยอุปกรณ์ของคุณ และอื่นๆ

ชุมชนช่วยให้คุณถามและตอบคําถาม ให้คําติชม และรับฟังจากผู้เชี่ยวชาญที่มีความรู้มากมาย

ข้อมูลนี้เป็นประโยชน์หรือไม่

คุณพึงพอใจกับคุณภาพภาษาเพียงใด
สิ่งที่ส่งผลต่อประสบการณ์ใช้งานของคุณ
เมื่อกดส่ง คำติชมของคุณจะถูกใช้เพื่อปรับปรุงผลิตภัณฑ์และบริการของ Microsoft ผู้ดูแลระบบ IT ของคุณจะสามารถรวบรวมข้อมูลนี้ได้ นโยบายความเป็นส่วนตัว

ขอบคุณสำหรับคำติชมของคุณ!

×