อาการ
ใน Microsoft Commerce Server 2007 หรือ ใน 2009 Server พาณิชย์ของ Microsoft คุณต้องเลือกชนิดการนำเข้าแทนที่จะทำการนำเข้าแค็ตตาล็อก ถ้าแค็ตตาล็อกข้อมูลมีอยู่ การนำเข้าใช้เวลานานจะเสร็จสมบูรณ์ ตัวอย่างเช่น ถ้าคุณนำเข้าแค็ตตาล็อกใหม่ การนำเข้าใช้เวลาประมาณ 10 นาที ถ้าคุณใช้ชนิดการนำเข้าแทนที่จะนำเข้าแค็ตตาล็อกไฟล์เดียวกันอีกครั้งหลังจากการนำเข้าครั้งแรก การนำเข้าใช้เวลาหนึ่งชั่วโมงจะเสร็จสมบูรณ์
สาเหตุ
ปัญหานี้เกิดขึ้นเนื่องจาก ctlg_RepairCatalogsAfterImport แผนการสอบถามที่ต่ำสำหรับกระบวนการนำเข้าแค็ตตาล็อกที่เลือก
การแก้ไข
ข้อมูลโปรแกรมแก้ไขด่วน
มีโปรแกรมแก้ไขด่วนที่รองรับพร้อมให้บริการจาก Microsoft อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มุ่งหวังเพื่อการแก้ไขเฉพาะปัญหาที่อธิบายไว้ในบทความนี้ ใช้การแก้ไขด่วนนี้กับระบบต่าง ๆ ที่พบปัญหาอธิบายไว้ในบทความนี้เท่านั้น โปรแกรมแก้ไขด่วนนี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น ถ้าคุณไม่ได้รับผลกระทบจากปัญหานี้รุนแรง เราขอแนะนำให้ คุณรอการปรับปรุงซอฟต์แวร์ถัดไปที่ประกอบด้วยโปรแกรมแก้ไขด่วนนี้ หากโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด คุณจะเห็นส่วน "มีโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด" ที่ด้านบนของบทความฐานข้อมูลองค์ความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น ติดต่อฝ่ายสนับสนุนและบริการลูกค้าของ Microsoft เพื่อขอรับโปรแกรมแก้ไขด่วน หมายเหตุ ถ้ามีปัญหาอื่น ๆ เกิดขึ้น หรือถ้าจำเป็นต้องแก้ไขปัญหาใด ๆ คุณอาจต้องสร้างคำขอรับบริการแยกต่างหาก จะมีค่าใช้จ่ายในการสนับสนุนปกติกับคำถามเพิ่มเติมและเรื่องอื่น ๆ ที่ไม่มีสิทธิได้รับโปรแกรมแก้ไขด่วนเฉพาะนี้ สำหรับรายชื่อทั้งหมด ของหมายเลขโทรศัพท์ของฝ่ายบริการลูกค้าและการสนับสนุนของ Microsoft หรือเพื่อสร้างการร้องขอบริการแยกต่างหาก แวะไปที่เว็บไซต์ของ Microsoft ต่อไปนี้:
http://support.microsoft.com/contactus/?ws=supportหมายเหตุ แบบฟอร์ม "มีโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด" แสดงภาษาที่โปรแกรมแก้ไขด่วนพร้อมใช้งาน ถ้าคุณไม่เห็นภาษาของคุณ อาจเป็น เพราะไม่มีโปรแกรมแก้ไขด่วนพร้อมใช้งานสำหรับภาษานั้น
ข้อกำหนดเบื้องต้น
คุณต้องมีการติดตั้งรุ่นต่อไปนี้หนึ่ง:
-
Microsoft Commerce Server 2007 SP2
-
เซิร์ฟเวอร์ Microsoft พาณิชย์ 2009
ความต้องการการรีสตาร์ท
คุณไม่ต้องรีสตาร์ทคอมพิวเตอร์ อย่างไรก็ตาม คุณต้องเริ่มต้นบริการข้อมูลทางอินเทอร์เน็ต (IIS) และโปรแกรมประยุกต์ Commerce เซิร์ฟเวอร์แค็ตตาล็อกนำเข้าโฮสต์ COM + หลังจากใช้โปรแกรมแก้ไขด่วนนี้ เมื่อต้องการรีสตาร์ท IIS ที่พรอมต์คำสั่ง พิมพ์คำสั่งต่อไปนี้ และจากนั้น กด ENTER:
IISRESET /RESTART หมายเหตุ ตัวเลือกนี้หยุด และเริ่มต้นบริการ IIS ทั้งหมดที่กำลังทำงานอยู่แล้ว
ข้อมูลการแทนที่
โปรแกรมแก้ไขด่วนนี้ไม่ได้ใช้แทนโปรแกรมแก้ไขด่วนที่มีการนำออกใช้ก่อนหน้านี้
ข้อมูลไฟล์
รุ่นสากลของโปรแกรมแก้ไขด่วนนี้ใช้แพคเกจ Microsoft Windows Installer เพื่อติดตั้งโปรแกรมแก้ไขด่วนนี้ วันที่และเวลาสำหรับแฟ้มเหล่านี้จะแสดงรายการไว้ในรูปแบบเวลามาตรฐานสากล (UTC) ในตารางต่อไปนี้ เมื่อคุณดูข้อมูลแฟ้ม วันที่จะถูกแปลงเป็นเวลาท้องถิ่น เมื่อต้องการค้นหาความแตกต่างระหว่างเวลา UTC กับเวลาท้องถิ่น ใช้แท็บ โซนเวลา ในรายการ วันที่และเวลา ในแผงควบคุม
สำหรับ Microsoft Commerce Server 2007
ชื่อไฟล์ |
รุ่นของไฟล์ |
ขนาดไฟล์ |
วันที่ |
เวลา |
แพลตฟอร์ม |
---|---|---|---|---|---|
Catalogcreate.sql |
Not applicable |
1,153,421 |
25-Feb-2011 |
10:38 |
Not applicable |
สำหรับเซิร์ฟเวอร์ Microsoft พาณิชย์ 2009
ชื่อไฟล์ |
รุ่นของไฟล์ |
ขนาดไฟล์ |
วันที่ |
เวลา |
แพลตฟอร์ม |
---|---|---|---|---|---|
Catalogcreate.sql |
Not applicable |
1,157,103 |
25-Feb-2011 |
10:38 |
Not applicable |
Cs2009hotfixhelper.exe |
6.0.4171.40 |
13,080 |
28-Feb-2011 |
08:01 |
x86 |
ข้อมูลการติดตั้งโปรแกรมแก้ไขด่วน
หลังจากที่คุณขยายแพ็คเกจโปรแกรมแก้ไขด่วน คุณได้แฟ้มต่อไปนี้:
-
สำหรับเซิร์ฟเวอร์ Commerce 2007:
-
CommerceServer2007SP2-KB2513798-ENU.exe
-
KB2513798.sql
ติดตั้งแฟ้มการปรับปรุงแฟ้ม Catalogcreate.sql CommerceServer2007SP2-KB2513798-ENU.exe
-
-
สำหรับเซิร์ฟเวอร์ Commerce 2009:
-
CommerceServer2007SP3-KB2513798-ENU.exe
-
KB2513798.sql
ติดตั้งแฟ้มการปรับปรุงแฟ้ม Catalogcreate.sql CommerceServer2007SP3-KB2513798-ENU.exe
-
คุณต้องติดตั้งโปรแกรมแก้ไขด่วนที่เหมาะสมเพื่อให้แน่ใจว่า ปัญหานี้ไม่เกิดขึ้นสำหรับฐานข้อมูลของแค็ตตาล็อกใหม่ นอกจากนี้ คุณต้องรันไฟล์ KB2513798.sql สำหรับฐานข้อมูลการแค็ตตาล็อกที่มีอยู่ในการปรับปรุงของกระบวนงานที่เก็บไว้
ข้อมูลเพิ่มเติม
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการนำเข้าแค็ตตาล็อกในเซิร์ฟเวอร์ Commerce แวะไปที่เว็บเพจที่ MSDN ต่อไปนี้: