ข้ามไปที่เนื้อหาหลัก
การสนับสนุน
ลงชื่อเข้าใช้
ลงชื่อเข้าใช้ด้วย Microsoft
ลงชื่อเข้าใช้หรือสร้างบัญชี
สวัสดี
เลือกบัญชีอื่น
คุณมีหลายบัญชี
เลือกบัญชีที่คุณต้องการลงชื่อเข้าใช้

อาการ

พิจารณาสถานการณ์ต่อไปนี้:

  • คุณสามารถติดตั้งซอฟต์แวร์ต่อไปนี้บนคอมพิวเตอร์:

    • Eclipse 3.5, Eclipse 3.6 หรือผลิตภัณฑ์ที่ขึ้นอยู่กับรุ่นเหล่านี้

    • Microsoft Visual Studio Team Explorer Everywhere 2010 Service Pack 1 (SP1) สำหรับ Eclipse

    • Windows Internet Explorer 9

  • คุณใช้ส่วนทีม Explorer ทุก 2010 เพื่อเชื่อมต่อไปยังเซิร์ฟเวอร์เซิร์ฟเวอร์มูลฐานทีม Microsoft (TFS)

  • คุณพยายามบันทึก หรือดูรายการงานที่ประกอบด้วยตัวควบคุม HTML บางอย่าง

ในสถานการณ์นี้ การบันทึก หรือดูการดำเนินการล้มเหลว นอกจากนี้ คุณได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้:

บันทึก FailedJava.lang.reflect.InvocationTargetException

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจาก มีการเปลี่ยนแปลงใน JavaScript กลไกจัดการที่ถูกนำมาใช้ใน Internet Explorer 9 การเปลี่ยนแปลงที่ขัดแย้งรหัส invoking รุ่นคราสได้รับผลกระทบ ความขัดแย้งนี้ทำให้ failaure เป็นในลักษณะการทำงานสำหรับรายการงานที่ประกอบด้วยรูปแบบ rich text ที่ยื่นควบคุมในทีม Explorer ทุก 2010 SP1 ดังนั้น ข้อผิดพลาดปรากฏขึ้น

การแก้ไข

ข้อมูลโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนนี้สามารถดาวน์โหลดได้จากศูนย์ดาวน์โหลด Microsoft เว็บไซต์ต่อไปนี้:Download ดาวน์โหลดแพคเกจโปรแกรมแก้ไขด่วนนี้ สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการดาวน์โหลดแฟ้มสนับสนุนของ Microsoft โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:

119591 วิธีการขอรับไฟล์สนับสนุนของ Microsoft จากบริการออนไลน์ Microsoft สแกนแฟ้มนี้เพื่อหาไวรัสแล้ว Microsoft ใช้ซอฟต์แวร์ตรวจสอบไวรัสที่เป็นปัจจุบันที่สุดซึ่งพร้อมใช้งานตั้งแต่วันที่ซึ่งมีการประกาศแฟ้มนี้ แฟ้มนี้ถูกจัดเก็บไว้ในเซิร์ฟเวอร์ที่เพิ่มการรักษาความปลอดภัยซึ่งช่วยป้องกันการเปลี่ยนแปลงใด ๆ ที่ไม่ได้รับอนุญาตต่อแฟ้มดังกล่าว หมายเหตุ  เมื่อต้องการติดตั้งโปรแกรมแก้ไขด่วนนี้ ให้ทำตามขั้นตอนเหล่านี้:

  1. บันทึกแฟ้มของแพคเกจโปรแกรมแก้ไขด่วน Tfseclipseplugin-updatesitearchive-10.1.0-qfe1.zip ในโฟลเดอร์ภายในเครื่อง

  2. เริ่มคราส

  3. บนเมนูวิธีใช้คลิกติดตั้งซอฟต์แวร์ใหม่

  4. คลิก เพิ่ม

  5. พิมพ์Explorer ทีมท้องถิ่นเก็บถาวรที่ปลั๊กอินในกล่องชื่อและจากนั้น คลิกเก็บถาวร

  6. เลือกไฟล์ Tfseclipseplugin-updatesitearchive-10.1.0-qfe1.zip ที่คุณบันทึกไว้ในโฟลเดอร์ภายในเครื่อง และจากนั้น คลิกตกลง

  7. ในกล่องโต้ตอบการติดตั้งคลิกเพื่อเลือกกล่องกาเครื่องหมายที่สอดคล้องกับทีม Explorer ทุกแห่งจากรายการของลักษณะการทำงาน

  8. คลิกถัดไปสองครั้ง

  9. ยอมรับเงื่อนไขการอนุญาตให้ใช้สิทธิ์ซอฟต์แวร์ของ Microsoft และจากนั้น คลิกถัดไป

  10. คลิก เสร็จสิ้น

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการติดตั้งเซิร์ฟเวอร์มูลฐานทีมที่ปลั๊กอินและบรรทัดคำสั่งไคลเอนต์ ดาวน์โหลด และดูเว็บเพจที่ต่อไปนี้ของ Microsoft:

วิธีการติดตั้งเซิร์ฟเวอร์มูลฐานทีมที่ปลั๊กอินและบรรทัดคำสั่งไคลเอนต์

ข้อกำหนดเบื้องต้น

เมื่อต้องการติดตั้งโปรแกรมแก้ไขด่วนนี้ คุณต้องมี Microsoft Visual Studio ทีม Explorer ทุก 2010 Service Pack 1 (SP1) ติดตั้งไว้บนคอมพิวเตอร์

ข้อมูลการเริ่มระบบใหม่

คุณต้องรีสตาร์คราสหลังจากใช้โปรแกรมแก้ไขด่วนนี้

ข้อมูลการแทนที่โปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนนี้ไม่ได้ใช้แทนโปรแกรมแก้ไขด่วนที่มีการนำออกใช้ก่อนหน้านี้

ข้อมูลไฟล์

รุ่นสากลของ hotfix นี้มีแอตทริบิวต์ของแฟ้ม (หรือแอตทริบิวต์ของแฟ้มที่ใหม่กว่า) ซึ่งแสดงอยู่ในตารางต่อไปนี้ วันที่และเวลาสำหรับแฟ้มเหล่านี้จะแสดงรายการไว้ในรูปแบบเวลามาตรฐานสากล (UTC) เมื่อคุณดูข้อมูลแฟ้ม ระบบจะแปลงข้อมูลนี้เป็นเวลาท้องถิ่น เมื่อต้องการค้นหาความแตกต่างระหว่างเวลา UTC กับเวลาท้องถิ่น ใช้แท็บ โซนเวลา ในรายการ วันที่และเวลา ในแผงควบคุม

ชื่อแฟ้ม

รุ่นของแฟ้ม

ขนาดแฟ้ม

วันที่

เวลา

Tfseclipseplugin-updatesitearchive-10.1.0-qfe1.zip

ไม่มีข้อมูล

12,854,618

24-May-2011

07:17

การแก้ปัญหา

เมื่อต้องการหลีกเลี่ยงปัญหานี้ ให้ทำตามขั้นตอนเหล่านี้:

  1. เปิดโฟลเดอร์โปรแกรมคราส

  2. ค้นหา และจากนั้น เปิด Eclipse.ini ในตัวแก้ไขข้อความ ตัวอย่างเช่น ใช้ Notepad เพื่อเปิดแฟ้ม

  3. ให้เพิ่มบรรทัดต่อไปนี้ที่ส่วนท้ายของแฟ้ม:

    -Dcom.microsoft.tfs.client.common.ui.controls.generic.html.htmleditor.disable=

  4. บันทึกแฟ้ม Eclipse.ini และเริ่มการทำงานคราส

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "นำไปใช้กับ"

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ต้องการตัวเลือกเพิ่มเติมหรือไม่

สํารวจสิทธิประโยชน์ของการสมัครใช้งาน เรียกดูหลักสูตรการฝึกอบรม เรียนรู้วิธีการรักษาความปลอดภัยอุปกรณ์ของคุณ และอื่นๆ

ชุมชนช่วยให้คุณถามและตอบคําถาม ให้คําติชม และรับฟังจากผู้เชี่ยวชาญที่มีความรู้มากมาย

ข้อมูลนี้เป็นประโยชน์หรือไม่

คุณพึงพอใจกับคุณภาพภาษาเพียงใด
สิ่งที่ส่งผลต่อประสบการณ์ใช้งานของคุณ
เมื่อกดส่ง คำติชมของคุณจะถูกใช้เพื่อปรับปรุงผลิตภัณฑ์และบริการของ Microsoft ผู้ดูแลระบบ IT ของคุณจะสามารถรวบรวมข้อมูลนี้ได้ นโยบายความเป็นส่วนตัว

ขอบคุณสำหรับคำติชมของคุณ!

×