อาการ
เมื่อคุณเริ่มตัวจัดการIntegration คุณอาจได้รับข้อผิดพลาดต่อไปนี้:
ข้อผิดพลาดภายในใน ADODB.connection เลข 3706 ไม่พบผู้ให้บริการ อาจติดตั้งไม่ถูกต้อง
สาเหตุ
โดยทั่วไปข้อผิดพลาดนี้เกิดจากคีย์ที่เสียหาย/ไม่ถูกต้องในไดเรกทอรี InstallShield ซึ่งเป็น C:\Program Files\InstallShield Installation Information
ความละเอียด
1. เอา Integration ManagerusingAdd/Remove Programs ออกทุกเวอร์ชัน
2. เอาHKEY_LOCAL_MACHINE\Software\Microsoft\Great Plains\Integration Manager\คีย์ในรีจิสทรีออก นอกจากนี้ ให้เอาHKEY_CURRENT_USER\Software\Microsoft\Great Plains\Integration Manager\หลักในรีจิสทรีออก
3. ตรวจสอบให้แน่ใจว่าไดเรกทอรีต่อไปนี้หายไปแล้ว:
%IM% <-ที่ที่เคยติดตั้ง IM ไปยัง
ไฟล์โปรแกรม%\IM\
%Program Files%\%Common Files%\CBOM\
4 ตรวจสอบให้แน่ใจว่าไฟล์ต่อไปนี้ไม่ได้อยู่ในไดเรกทอรี %System%
Cbomlibx.dllCbom.dll
Cbom.tlbTtgcomnx.dllTtgscrx.dllTtgvbolex.dllTtgvbole.dllวิธีที่เร็วที่สุดคือการค้นหา
Ttg*.* ใน %System% แล้วเอาออก จากนั้นค้นหาจาก Cb*.dll และเอาออก ดูให้แน่ใจว่าไฟล์เหล่านั้นอยู่ด้านบนไฟล์หนึ่งจริงๆ ก่อนที่คุณจะลบ
วิธีนี้ควรลบการอ้างอิงใดๆ ไปยังตัวจัดการการรวมบนเครื่องออกอย่างสมบูรณ์
5. ติดตั้ง MDAC เวอร์ชันล่าสุด ซึ่งคือ 2.8 จาก
http://msdn.microsoft.com/data/Default.aspx เมื่อต้องการตรวจสอบเวอร์ชัน MDAC ปัจจุบันของคุณ ให้ไปที่ HKEY_LOCAL_MACHINE\Software\Microsoft\DataAccessเวอร์ชันอื่น
6. สร้างโฟลเดอร์สํารองและตัดเนื้อหาจาก C:\Program Files\InstallShield Installation Information ลงในโฟลเดอร์สํารองที่คุณสร้าง
7. ติดตั้งใหม่ รุ่น 7.5 Service Pack 3of Integration Manager แล้วService Pack 4 คลิก
https://mbs.microsoft.com/fileexchange/?fileID=59682871-a5e0-4660-a36f-4be0d07aecfcเพื่อService Pack 3 คลิก
https://mbs.microsoft.com/downloads/customer/IM75sp4.zipเพื่อService Pack 4
บทความนี้คือ TechKnowledge Document ID:34645